Page 1 of 1

api doesn't work on raspberry pi 3 with buster OS

Posted: Wed Aug 05, 2020 7:20 am
by david1234
Hello ,
I'm running zoneminder V1.34.16 on pi Buster OS.
everything is working with the zoneminder (record 3 cameras all the time ,with sound - work great!)

now I'm trying to use API ,

I have done what it said in the guide

Code: Select all

AUTH_RELAY is set to hashed
A valid AUTH_HASH_SECRET is provided (not empty)
AUTH_HASH_IPS is disabled
OPT_USE_APIS is enabled
OPT_USE_GOOG_RECAPTCHA is disabled
have try with and without OPT_USE_AUTH (with password and without password)

no metter what I do
I get error

Code: Select all

curl -XPOST -d "user=David&pass=Davidpass" http://10.0.0.105/zm/api/host/login.json
{"name":"Not Found","message":"Not Found","url":"\/api\/zm\/api\/host\/login.json"}
pi@raspberrypi:~$
I have restart the zoneminder service
reboot the pi

still not working

what is missing?

Thanks ,

Re: api doesn't work on raspberry pi 3 with buster OS

Posted: Sun Aug 09, 2020 6:47 am
by david1234
anything?

cant be the only one....

Thanks,

Re: api doesn't work on raspberry pi 3 with buster OS

Posted: Sun Aug 09, 2020 12:13 pm
by bbunge
What instructions did you use to install Zoneminder?
Or did you use the pre-built image?

Re: api doesn't work on raspberry pi 3 with buster OS

Posted: Mon Aug 10, 2020 1:27 pm
by david1234
pre-build image from here

Code: Select all

https://zmrepo.zoneminder.com/

Re: api doesn't work on raspberry pi 3 with buster OS

Posted: Sun Aug 23, 2020 7:03 am
by david1234
anyone?

Re: api doesn't work on raspberry pi 3 with buster OS

Posted: Sun Nov 08, 2020 8:23 am
by david1234
can someone help \guide maybe ?

I really love working with zoneminder and the API option could make this program 100% good for my needed

?