ONVIF - Multiple Ethernet Ports

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
Pedulla
Posts: 132
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

ONVIF - Multiple Ethernet Ports

Post by Pedulla » Sat Mar 04, 2017 4:35 am

1.30.2 Test results

ONVIF seems to only probe the ethernet interface the Web Site is on.
I typically build a separate network adapter for the "camera net" for various reasons.

Is this expected behavior?
Can ONVIF have the option to search a particular network or ethernet port?

User avatar
knight-of-ni
Posts: 2205
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: ONVIF - Multiple Ethernet Ports

Post by knight-of-ni » Sat Mar 04, 2017 3:15 pm

We have an open issue on github for this.

I looked into this previously and the perl-io-multicast module documentation states it is sends out messages on all interfaces if none is specified. Since this isn't happening, further research must be done into why it isn't. Something is probably setting the interface before it is called, but troubleshooting the onvif perl script is rather convoluted. This is one of many issues that isn't a priority, not because we don't want to fix it, but we simply have got higher priorities to work on. Anyone else is welcome to try and fix this.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

bige40wings
Posts: 1
Joined: Sat Jun 02, 2018 4:44 pm

Re: ONVIF - Multiple Ethernet Ports

Post by bige40wings » Sat Jun 02, 2018 4:49 pm

Any movement towards a fix with this? I'm having the same issue. I've tried setting a static route for 239.255.255.250 out the Camera network interface, but it makes no difference. The probe only uses the interface used by the web page.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests