FFmpeg Pictureerrors

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
nokia001
Posts: 14
Joined: Tue Sep 06, 2011 8:40 pm

FFmpeg Pictureerrors

Post by nokia001 » Thu Sep 19, 2013 10:49 am

Hi,

i've installed 1.26.2 and i have a Panasonic BL-Vt164 via ffmpeg to zoneminder connected.
Settings:
Qellentyp = Ffempeg
Source Path = rtsp://xxxx:xxxxx@192.168.0.141:554/MediaInput/h264/
Target Colorspace= 24-Bit
Resolution= 1280x720

I have no errors with version 1.25.0

I've added two picture. Has anybody a idee?
thx.
Attachments
027-analyse.jpg
Error-Picture
027-analyse.jpg (84.24 KiB) Viewed 3269 times
010-capture.jpg
normal
010-capture.jpg (86.11 KiB) Viewed 3269 times

User avatar
Basildane
Posts: 108
Joined: Mon Sep 16, 2013 1:09 pm

Re: FFmpeg Pictureerrors

Post by Basildane » Thu Sep 19, 2013 4:30 pm

For what it's worth, I have the same problem. Same smearing, and generated alarms.
Different camera than yours.

Seems to happen at high bitrates.

Torsten73
Posts: 26
Joined: Thu Sep 19, 2013 9:45 pm

Re: FFmpeg Pictureerrors

Post by Torsten73 » Thu Sep 19, 2013 10:09 pm

I also have the same Problem, but its ffmpeg only. When using extern source with IP Adresse the picture is fine. And its eaqual if its h256 or MPEG stream Form cam.
But for me its not New. Same behavior in 1.25.

nokia001
Posts: 14
Joined: Tue Sep 06, 2011 8:40 pm

Re: FFmpeg Pictureerrors

Post by nokia001 » Fri Sep 27, 2013 7:15 am

It worked nice with 1.25

Any Ideas?
slowing down the FPS is no solution

whatboy
Posts: 304
Joined: Mon Aug 31, 2009 10:31 pm

Re: FFmpeg Pictureerrors

Post by whatboy » Mon Sep 30, 2013 8:36 pm

Had that problem too... uninstalled FFMPEG and installed new one!!! fix it... no more problems!!!

whatboy
Posts: 304
Joined: Mon Aug 31, 2009 10:31 pm

Re: FFmpeg Pictureerrors

Post by whatboy » Mon Sep 30, 2013 8:58 pm

Actually wasn't that simple, after installed newest FFMPEG had to rebulid zm, because the errors about FFMPEG libs... and then execute ldconfig...

whatboy
Posts: 304
Joined: Mon Aug 31, 2009 10:31 pm

Re: FFmpeg Pictureerrors

Post by whatboy » Mon Sep 30, 2013 9:15 pm

OLD ffmpeg version... problems...

Code: Select all

FFmpeg version SVN-r26402, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jun 15 2013 17:28:03 with gcc 4.5.1 20100924 (Red Hat 4.5.1-4)
  configuration: --enable-shared --enable-pthreads --enable-gpl --prefix=/usr/local --enable-swscale
  libavutil     50.36. 0 / 50.36. 0
  libavcore      0.16. 1 /  0.16. 1
  libavcodec    52.108. 0 / 52.108. 0
  libavformat   52.93. 0 / 52.93. 0
  libavdevice   52. 2. 3 / 52. 2. 3
  libavfilter    1.74. 0 /  1.74. 0
  libswscale     0.12. 0 /  0.12. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
NEW ffmpeg version, no problems!!! :)

Code: Select all

ffmpeg version N-56254-gb7bd688 Copyright (c) 2000-2013 the FFmpeg developers
  built on Sep 28 2013 19:20:33 with gcc 4.5.1 (GCC) 20100924 (Red Hat 4.5.1-4)
  configuration: --enable-shared --enable-pthreads --enable-gpl --prefix=/usr/local --enable-swscale
  libavutil      52. 43.100 / 52. 43.100
  libavcodec     55. 31.101 / 55. 31.101
  libavformat    55. 16.102 / 55. 16.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 84.100 /  3. 84.100
  libswscale      2.  5.100 /  2.  5.100
  libswresample   0. 17.103 /  0. 17.103
  libpostproc    52.  3.100 / 52.  3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests