zm_User.cpp Log bug?

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

zm_User.cpp Log bug?

Post by dazed » Mon Oct 17, 2016 5:32 pm

Hi just wanted to pass on that I'm not seeing zm_user.cpp log updating since upgrading from 1.28.1

Just shows user log-in events before update...other logs appear to be working (haven't checked all)

I did not change default log installation settings.

dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

Re: zm_User.cpp Log bug?

Post by dazed » Tue Nov 01, 2016 5:04 pm

Okay maybe not a bug since the dropdown has disappeared completely...which leads me to believe that since no records of users now in log no need for dropdown tick.

Can anybody help or point me to the new logging info (I did search but to no avail). I'm just looking to be able to see theusers that logged in like before.

Thanks...if I figure it out Ill be back.

SteveGilvarry
Posts: 445
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: zm_User.cpp Log bug?

Post by SteveGilvarry » Wed Nov 02, 2016 9:15 am

Perhaps this is where it went https://github.com/ZoneMinder/ZoneMinde ... d9a0630d96

And the actual pull request where it seems justified https://github.com/ZoneMinder/ZoneMinder/pull/983
Production Zoneminder 1.35.x
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

SteveGilvarry
Posts: 445
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: zm_User.cpp Log bug?

Post by SteveGilvarry » Wed Nov 02, 2016 9:37 am

I was thinking PHP should be logging user actions more so than streaming. Which it does https://github.com/ZoneMinder/ZoneMinde ... ns.php#L53
Production Zoneminder 1.35.x
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

Re: zm_User.cpp Log bug?

Post by dazed » Wed Nov 02, 2016 5:32 pm

So it has been removed??

Or is mine just messed up with the upgrade?

I looked at your links...and it would appear that in the last one (code still there)its still functional.

Thanks for the info, I just don't quite understand your answer.

I am tech savvy but im not really a programmer....but I can edit and change things if i have reference.

I would just like to be able to know who (and what times) users log in for reference....Maybe I need to figure out how to log in PHP if ZM is not handling it anymore.

Also maybe I understand it to be available now in only debug (first & second link).....wouldn't that be a little extreme way of handling this?


Thanks again.

Edit...I think I should be looking for a php session file....

SteveGilvarry
Posts: 445
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: zm_User.cpp Log bug?

Post by SteveGilvarry » Wed Nov 02, 2016 8:44 pm

I don't use authentication, but what I showed you was zm_user.cpp now logs that message to a debug not info message so it will only show when running debug logs settings. It is not the correct log record to be looking at, there should Info type logs for user logon and logoff from the web interface. I will try tonight (12hours) to turn on auth and try it.
Production Zoneminder 1.35.x
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

Re: zm_User.cpp Log bug?

Post by dazed » Sun Nov 06, 2016 1:39 am

SteveGilvarry wrote:I will try tonight (12hours) to turn on auth and try it.

Any luck?

User avatar
iconnor
Posts: 1379
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zm_User.cpp Log bug?

Post by iconnor » Sun Nov 06, 2016 2:17 am

There is something wrong somewhere. In the systems I manage I get emails from the logs at a certain level... and I get logs regarding logins.... for some reason the debug level thing is being ignored or something. I just havn't been able to figure it out just yet.

It is weird, because the log line should be debug, but it shows up at a higher level.

As I said, I havn't been able to figure it out yet.

dazed
Posts: 66
Joined: Thu Feb 13, 2014 5:32 pm

Re: zm_User.cpp Log bug?

Post by dazed » Sun Jan 01, 2017 5:43 am

HI Happy New Year!

I just came across this drop down selection in logs (usr/share/zoneminder/www/includes/functions.php)

It appears I can see User & Login times here along with other errors (just have to scroll more).

Not as nice as in past, but never the less I can see the login info.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests