Anyone managed to get Lorex IP cameras working?

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
xeddog
Posts: 13
Joined: Wed Sep 14, 2016 10:46 pm

Anyone managed to get Lorex IP cameras working?

Post by xeddog » Tue Sep 20, 2016 7:56 pm

I currently have a complete Lorex security system with 8 cameras that are all 1080p IP POE cameras. I just found out about ZoneMinder and want to test it because my Lorex LNR400 NVR has only 8 ports and I think I need (ok, WANT) a couple more. 10 ports would probably do, but 12 could also be possible. To upgrade to a 16 port NVR is hundreds of dollars. I am VERY new to Zoneminder and I only have one camera to "play" with for the time being. That camera is a Lorex MCNB3153 IP 1080p camera. I have the camera connected to my local network and I can access it via Firefox. I have the IP address, and all port numbers used by the camera. But I have not found the key (if there is one) to get it working with ZM. And before anyone asks, I know the Lorex cameras are not in the HCL, but lists like that can be very out-of-date.

For particulars, I am running ZM 1.29 on an Ubuntu Linux 16.04 machine with an older I-7 processor and 16GB RAM. I am using 1.29 because that is the one in the repros and I would rather use that than mess around adding a PPA. The camera obtained it's IP address via DHCP, and uses the following ports:
TCP = 35000
UDP = 37778
HTTP = 80
RTSP = 554
HTTPS = 443 (not enabled at the present time.)

If no one can help without log files, I can provide them although the "export" function doesn't work and I have to copy/paste the logs. And depending on definitions, they are different so there might be more than one.


Thanks,

Wayne

xeddog
Posts: 13
Joined: Wed Sep 14, 2016 10:46 pm

Re: Anyone managed to get Lorex IP cameras working?

Post by xeddog » Wed Sep 21, 2016 5:12 pm

I think I have made a little progress in trying to figure this out. I was finally able to get a feed from the camera in VLC. The one thing that came up was after opening the feed with VLC I was prompted for a userid/password for the camera. From the ZM documentation I have been reading, it says

Code: Select all

If you require authentication to access your camera then add this onto the host name in the form <username>:<password>@<hostname>.com. 
So I opened the "Source" tab in ZM and enter the hostname. But when I try to save the configuration, it barfs any time I try to put ANYthing after the host name. So in the Remote Host Name field if I put "IPC" (I added IPC to my hosts file) I can save the config. If I put "IPC realuserid:realpasswd@IPC", I get an error that says "Hostname must be set to a valid IP address or Hostname, do not include http://". I get that same error if I put ANYthing after the hostname, even a single character.

So the question is - how do I get a userid and password passed to the camera???

User avatar
knight-of-ni
Posts: 2216
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Anyone managed to get Lorex IP cameras working?

Post by knight-of-ni » Wed Sep 21, 2016 5:58 pm

Change your source type to ffmpeg, then enter the url exactly as you entered it into vlc. Include the username nad password in the url.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

xeddog
Posts: 13
Joined: Wed Sep 14, 2016 10:46 pm

Re: Anyone managed to get Lorex IP cameras working?

Post by xeddog » Fri Sep 23, 2016 5:22 pm

I don't know what happened to my original reply, but changing source type to ffmpeg worked like a charm. Now when I get my replacement for the LNB3321-C camera which is an updated model to the MCNB3153 with color night vision) I will test that one out too.


Thanks,

Wayne

User avatar
knight-of-ni
Posts: 2216
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Anyone managed to get Lorex IP cameras working?

Post by knight-of-ni » Fri Sep 23, 2016 8:51 pm

For modern h264 ip cameras, always start with the ffmpeg source type. ffmpeg is by far the most compatible. libvlc is there in case you run into screen tearing issues with ffmpeg, and the remote source type is largely unmaintained. Only use remote as a last resort. We may remove it in the future due to lack of resources to maintain it.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

RWBUMP
Posts: 1
Joined: Thu Dec 20, 2018 12:59 pm

Re: Anyone managed to get Lorex IP cameras working?

Post by RWBUMP » Fri Dec 21, 2018 7:34 pm

For the Lorex LNR300 you use ffmpg and in the source line the following worked for mine:

rtsp://user_name:password@ip address:1025/Streaming/channels/xxx/video.mjpg

explanation of terms, tested on LNR 300, but not LNR 200:
username - your login user name for your LNR200 or LNR300
password - the password you use to login to your LNR200 or LNR300
ip address - the ip address for your LNR 200 or LNR 300
1025 - is the default port for rtsp on the LNR 300, ensure in your LNR to check what port number is set in the mobile port
/Streaming/channels/ - have worked in two different applications for my LNR 300, newer NVRs may be different. It is case dependent.
xxx - the channel number 102, 202, 302, 402, 502, 602, 702, 802. If you have more than eight cameras, your guess is as good as mine. 101, 201, 301 . . . works also
video.mjpg - I used picture in one application since I was snapshotting a picture, for video this is working. It appears to be different in later models.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests