new Axis cameras connection problem

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
craver84
Posts: 96
Joined: Sun Aug 31, 2008 7:35 am

new Axis cameras connection problem

Post by craver84 » Thu Oct 09, 2014 10:41 am

Hi guys,
I'm got a problem with RTSP (RTP/RTSP/HTTP) connection to an Axis M3014 (firmware 5.40.9.3 just updated)

I read that with new 5.x firmwares the path to use is: /axis-media/media.amp
I tried it, but the connection is not stable, it crashes and live view doesn't work

With older cams,I have for example an AXIS 209FD with firmware version 4.47.1
the connection with the path /mpeg4/media.amp works pefectly.

although RTSP doesn't work for me, I can connect to M3014 using mjpeg
/mjpg/1/video.mjpg?resolution=800x600&fps=10
but I saw in nethogs that this connection uses 450kb/s for a 800x600 image.
AXIS 209FD streaming with h264, 800x600 use about 120kb brandwidth.

is anyone else facing this problem with new axis cameras?
thanks Paolo





http://www.axis.com/files/manuals/um_m3 ... n_1112.pdf

Code: Select all

2014-10-09 12:27:16.245220	zmdc	16522	INF	'zmc -m 7' crashed, signal 8	zmdc.pl	
2014-10-09 12:27:14.493001	zma_m5	19095	INF	Monitor-5: 64000 - Processing at 13.33 fps	/builddir/build/BUILD/ZoneMinder-1.27.0/src/zm_monitor.cpp	1153
2014-10-09 12:27:13.584957	zmc_m5	19084	INF	Monitor-5: 64000 - Capturing at 13.33 fps	/builddir/build/BUILD/ZoneMinder-1.27.0/src/zm_monitor.cpp	2831
2014-10-09 12:27:10.242363	zmc_m7	20152	INF	Got signal 15 (Terminated), exiting	/builddir/build/BUILD/ZoneMinder-1.27.0/src/zm_signal.cpp	40
2014-10-09 12:27:10.203210	zmdc	16522	INF	'zmc -m 7' stopping at 14/10/09 12:27:10	zmdc.pl	
2014-10-09 12:27:10.104450	zmwatch	16586	INF	Restarting capture daemon for Monitor-7, time since last capture 7 seconds (1412850430-1412850423)	zmwatch.pl	
2014-10-09 12:27:00.134942	zmc_m7	20152	INF	Starting Capture	/builddir/build/BUILD/ZoneMinder-1.27.0/src/zmc.cpp	195
2014-10-09 12:27:00.027860	zmdc	20152	INF	'zmc -m 7' started at 14/10/09 12:27:00	zmdc.pl	
2014-10-09 12:27:00.027860	zmdc	16522	INF	'zmc -m 7' starting at 14/10/09 12:27:00, pid = 20152	zmdc.pl	
2014-10-09 12:26:59.930750	zmwatch	16586	INF	Restarting capture daemon for Monitor-7, time since last capture 22 seconds (1412850419-1412850397)	zmwatch.pl

User avatar
knight-of-ni
Posts: 2231
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: new Axis cameras connection problem

Post by knight-of-ni » Sat Oct 11, 2014 11:07 pm

The ffmpeg & libvlc source types have better RTSP support than the Remote source type.
Try those.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

craver84
Posts: 96
Joined: Sun Aug 31, 2008 7:35 am

Re: new Axis cameras connection problem

Post by craver84 » Mon Oct 13, 2014 9:35 am

hi knnniggett
I tried this settings

path = rtsp://root:pass@10.0.1.101:554/axis-media/media.amp?videocodec=h264&streamprofile=Balanced

I notice that with
streamprofile=Quality -> max 4 frames/sec
streamprofile=Balanced -> 15 frames/sec but delay of 1-2 seconds


it works but I prefer mjpg, it look much more real in "live view" mode

despite that, thank you Knnniggett!

Lars
Posts: 6
Joined: Mon Sep 15, 2014 11:46 am

Re: new Axis cameras connection problem

Post by Lars » Mon Oct 20, 2014 7:28 am

I have this issue as well!

RTSP works find with 225FD but a newer Axis camera just freezes when I use RTSP.

User avatar
knight-of-ni
Posts: 2231
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: new Axis cameras connection problem

Post by knight-of-ni » Mon Oct 20, 2014 11:55 am

Did you change your source type from "Remote" to "ffmpeg" or "libvlc" like I suggested in the previous post?
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests