Compile Error

Forum for questions and support relating to the 1.25.x releases only.
orsty3001
Posts: 47
Joined: Tue Jan 26, 2010 5:55 pm

Compile Error

Post by orsty3001 » Tue Sep 06, 2011 12:02 am

I'm trying to install zm on a box running slackware 13.37 64bit.

When I try to compile I get this error I get.

Code: Select all

make  all-recursive
make[1]: Entering directory `/home/225125/ZoneMinder-1.25.0'
Making all in src
make[2]: Entering directory `/home/225125/ZoneMinder-1.25.0/src'
g++ -DHAVE_CONFIG_H -I. -I..  -I/usr/include -I/usr/include -Wall -Wno-sign-compare -fno-inline -I/usr/include   -g -O2 -MT zmc.o -MD -MP -MF .deps/zmc.Tpo -c -o zmc.o zmc.cpp
In file included from zm_stream.h:27:0,
                 from zm_event.h:39,
                 from zm_zone.h:27,
                 from zm_monitor.h:26,
                 from zmc.cpp:28:
zm_mpeg.h:43:7: error: use of enum 'PixelFormat' without previous declaration
zm_mpeg.h:44:2: error: 'AVOutputFormat' does not name a type
zm_mpeg.h:45:2: error: 'AVFormatContext' does not name a type
zm_mpeg.h:46:2: error: 'AVStream' does not name a type
zm_mpeg.h:47:2: error: 'AVFrame' does not name a type
zm_mpeg.h:48:2: error: 'AVFrame' does not name a type
make[2]: *** [zmc.o] Error 1
make[2]: Leaving directory `/home/225125/ZoneMinder-1.25.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/225125/ZoneMinder-1.25.0'
make: *** [all] Error 2
Thanks in advance for your help.

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Re: Compile Error

Post by zoneminder » Tue Sep 06, 2011 4:03 pm

What version of the ffmpeg libraries (libavformat, libavcodec etc) are you compiling against?
Phil

orsty3001
Posts: 47
Joined: Tue Jan 26, 2010 5:55 pm

Re: Compile Error

Post by orsty3001 » Tue Sep 06, 2011 10:16 pm

Code: Select all

FFmpeg version 0.6
  libavutil     50.15. 1 / 50.15. 1
  libavcodec    52.72. 2 / 52.72. 2
  libavformat   52.64. 2 / 52.64. 2
  libavdevice   52. 2. 0 / 52. 2. 0
  libavfilter    1.19. 0 /  1.19. 0
  libswscale     0.11. 0 /  0.11. 0
  libpostproc   51. 2. 0 / 51. 2. 0
Before this version it was ffmpeg was 0.8.2. Last night I changed ffmpeg to this older version as a stab in the dark but I still got the same error.

orsty3001
Posts: 47
Joined: Tue Jan 26, 2010 5:55 pm

Re: Compile Error

Post by orsty3001 » Sat Sep 10, 2011 3:44 am

What version should ffmpeg be?

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Re: Compile Error

Post by zoneminder » Sat Sep 10, 2011 8:32 pm

Any recent one should be fine, either 'official' releases from 0.6.3 onwards or snapshots. Though very recent ones often change the API and may be broken,
Phil

macfloripa
Posts: 9
Joined: Sun Sep 11, 2011 3:13 pm

Re: Compile Error

Post by macfloripa » Sun Sep 11, 2011 3:24 pm


garyc
Posts: 23
Joined: Fri Feb 26, 2010 5:24 pm

Re: Compile Error

Post by garyc » Sun Sep 11, 2011 3:47 pm

Hi folks,

I am seeking to update from 1.24.2 to 1.25.0 on CentOS 5 and am having similar problems running make. I get the following after a string of what look like information messages as the make command executes:

zm_sdp.h:43: error: use of enum ‘AVMediaType’ without previous declaration
zm_sdp.h:52: error: use of enum ‘AVMediaType’ without previous declaration
make[2]: *** [zm_rtsp.o] Error 1
make[2]: Leaving directory `/root/ZoneMinder-1.25.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/ZoneMinder-1.25.0'
make: *** [all] Error 2

yum tells me ffmpeg is up to date with version 0.6.1

I am completely stumped so any help greatly appreciated - as usual.

Cheers

Gary

paxx
Posts: 11
Joined: Tue Mar 01, 2011 4:20 pm

Re: Compile Error

Post by paxx » Sun Sep 11, 2011 4:45 pm

I was getting the same error compiling on CentOS 5.6. I had some old ffmpeg devel files installed so simple yum remove ffmpeg-devel.x86_64 worked for me

I then ran make clean, reconfigured, recompiled and everything installed nicely.

garyc
Posts: 23
Joined: Fri Feb 26, 2010 5:24 pm

Re: Compile Error

Post by garyc » Sun Sep 11, 2011 5:22 pm

I do not have the X86_64 package installed, so uninstalled ffmpeg completely and reinstalled then tried the make clean as you suggest but unfortunately without luck. I must admit I on the edge of my knowledge here too, so am somewhat reliant on slavishly following instruction...

paxx
Posts: 11
Joined: Tue Mar 01, 2011 4:20 pm

Re: Compile Error

Post by paxx » Sun Sep 11, 2011 5:39 pm

copy and paste the output of:

cat /etc/*-release && uname -isr

and aslo yum list installed | grep ffmpeg

garyc
Posts: 23
Joined: Fri Feb 26, 2010 5:24 pm

Re: Compile Error

Post by garyc » Sun Sep 11, 2011 5:47 pm

Hi paxx

Thanks for your interest in helping here - much appreciated.

Outputs are:

CentOS release 5.6 (Final)
Linux 2.6.18-238.19.1.el5 i386

ffmpeg.i386 0.6.1-1.el5.rf installed
ffmpeg-libpostproc.i386 0.6.1-1.el5.rf installed

macfloripa
Posts: 9
Joined: Sun Sep 11, 2011 3:13 pm

Re: Compile Error

Post by macfloripa » Sun Sep 11, 2011 5:50 pm

paxx wrote:copy and paste the output of:

cat /etc/*-release && uname -isr

and aslo yum list installed | grep ffmpeg

Fedora release 15 (Lovelock)
Fedora release 15 (Lovelock)
Fedora release 15 (Lovelock)
Linux 2.6.40.4-5.fc15.i686 i386

ffmpeg.i686 0.7-0.3.20110612git.fc15
ffmpeg-devel.i686 0.7-0.3.20110612git.fc15
ffmpeg-libs.i686 0.7-0.3.20110612git.fc15
gstreamer-ffmpeg.i686

paxx
Posts: 11
Joined: Tue Mar 01, 2011 4:20 pm

Re: Compile Error

Post by paxx » Sun Sep 11, 2011 6:18 pm

one last thing, ffmpeg output and your ./configure command you used.

macfloripa
Posts: 9
Joined: Sun Sep 11, 2011 3:13 pm

Re: Compile Error

Post by macfloripa » Sun Sep 11, 2011 6:34 pm

paxx wrote:one last thing, ffmpeg output and your ./configure command you used.

ffmpeg version git-snapshot-oldabi-20110612-RPMFusion, Copyright (c) 2000-2011 the FFmpeg developers
built on Jul 1 2011 17:42:31 with gcc 4.6.0 20110509 (Red Hat 4.6.0-7)
configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib --mandir=/usr/share/man --arch=i686 --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables' --enable-bzlib --enable-libdc1394 --enable-libdirac --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib --cpu=i686 --enable-runtime-cpudetect
libavutil 50. 41. 0 / 50. 41. 0
libavcodec 52.121. 0 / 52.121. 0
libavformat 52.108. 0 / 52.108. 0
libavdevice 52. 4. 0 / 52. 4. 0
libavfilter 1. 78. 0 / 1. 78. 0
libswscale 0. 14. 0 / 0. 14. 0
libpostproc 51. 2. 0 / 51. 2. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...



-----

./configure --with-webdir=/var/www/zm --with-cgidir=/var/www/cgi-bin --enable-mmap=yes

paxx
Posts: 11
Joined: Tue Mar 01, 2011 4:20 pm

Re: Compile Error

Post by paxx » Sun Sep 11, 2011 6:47 pm

add this --with-ffmpeg=/usr/local/share/ffmpeg CPPFLAGS="-D__STDC_CONSTANT_MACROS"

and ./configure again

note: for fedora it may be just /usr/share/ffmpeg

I never used the fedora distro

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests