ZM Viewers problem

If you've made a patch to quick fix a bug or to add a new feature not yet in the main tree then post it here so others can try it out.
DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

ZM Viewers problem

Post by DREMA » Fri Dec 12, 2008 2:43 am

Hello, I'm trying to use the zm4ms, zmviewer and oter to get a stream of my remote zm server, but I can't gei the to work. They ask me for a username and password, I had tried every password I have, varios zm users, zm admin, mysql root, but no one works, I always get "acces denied to DREMA@remoteserver.org".

I'm using zm 1.23 on Ubuntu intrepid.

Any help please??? :(

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Sat Dec 13, 2008 3:58 pm

Hello!

The only password required are the mysql database password to access event data and a password for the zoneminder it self.

Usually, mysql username is "root" and the password is the one you have setup during installation.

The username/password for zone minder is the one you use in the html interface.

Recently I start using a new client: JZMC.
It is in the initial development, but already very usable.

Check out this post:
http://www.zoneminder.com/forums/viewtopic.php?t=12606

Hope it helped.
Regards.

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Mon Dec 15, 2008 9:56 pm

Hi, thanks for your reply, I tried every user and password I have with no luck, I also commented out the line "bind network access only to: localhost", but I still can't connect.
Also tried de jzmc, but it doesnt accept my user/pass.
Any suggestion?

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Tue Dec 16, 2008 10:13 pm

Well, it should be for shore related with access to mysql from a remote location.

Don't you have to open some ports in the router of the remote site for mysql?

As far as I've found, 3306 is the default mysql port.

Hope it helps.

Best regards.

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Thu Dec 18, 2008 9:19 am

Yeah I have that port forwarded, but even on the local network I can't get iit to work.

Any other advice?

Thanks!

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Thu Dec 18, 2008 10:51 pm

If you type on a server console "mysql -u root -p" and enter the password, can you see the mysql prompth "mysql>" or an error message?

And in other machine on the local network?

And in a remote machine?

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Fri Dec 19, 2008 10:54 am

Hi Caladeira, thanks for your help!
Locally I can conect to the mysql server with no problem, but when I try to "mysql -h my mysqlserver.com -u root -p" I got "ERROR 1130 (00000): Host '189.xxx.xxx.xxx' is not allowed to connect to this MySQL server" so its clear for me that i cant get remote/localnetwork connection on this server, so how do I enable connections to my server?
I repeat, I'm using Ubuntu Intrepid32.

Thanks again.

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Sun Dec 21, 2008 9:08 pm

Well, I'm not a mysql expert, not even close!

I think you should look your firewall settings and mysql configuration files.

You mention Ubuntu Intrepid, but which version Server or Desktop?
Some people use desktop versions for server work because of a more user friendly interface.

I think firewall have different settings where you are using Ubuntu Server or Desktop.

Hopefully, some mysql expert read this post and post some solution.

Best regards.

jameswilson
Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK
Contact:

Post by jameswilson » Sun Dec 21, 2008 9:59 pm

you will need to tell mysql to listen on ip.
comment out 'skip netowrking' in the my conf file
James Wilson

Disclaimer: The above is pure theory and may work on a good day with the wind behind it. etc etc.
http://www.securitywarehouse.co.uk

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Mon Dec 22, 2008 6:19 am

I don't have that line on my conf file, but I have "bind network access only to: localhost" commented out already.
Again, I'm using Intrepid.

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Mon Dec 22, 2008 9:52 pm

DREMA wrote:Again, I'm using Intrepid.
Ok, but you have installed the "Ubuntu 8.10 Server" or "Ubuntu 8.10 Desktop"?

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Tue Dec 23, 2008 5:12 pm

Right, sorry, I'm using Intrepid Server 32bits.
Thanks

DREMA
Posts: 162
Joined: Fri Dec 12, 2008 2:39 am
Location: México

Post by DREMA » Mon Dec 29, 2008 6:24 pm

Hi!
Happy holidays for everyone!
Anymore help with my little problem?
Thaanks!

User avatar
caladeira
Posts: 64
Joined: Wed Dec 05, 2007 10:57 am
Location: Lisbon

Post by caladeira » Mon Dec 29, 2008 9:01 pm

Happy holidays to you!

I'm sorry, but I have no more ideas.

As soon as possible, I'll try to access my server from outside.
Then I'll post the results.

Best regards.

jbg70
Posts: 19
Joined: Tue Dec 30, 2008 9:00 am

Post by jbg70 » Tue Dec 30, 2008 9:15 am

The user accessing the database from outside needs the correct permission.
In mysql shell use:

Code: Select all

GRANT ALL on $_zm_database_name.* to $_your_username@'%' identified by '$_password';
Replace $_ with your real data.
The symbol % gives the user access from anywhere only on zm mysql database. If you have a static outside ip or a subnet you could also use it.

Regards.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests