bt878 conexant - working but black and white only

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.
Post Reply
monyol
Posts: 2
Joined: Fri May 30, 2008 6:19 pm

bt878 conexant - working but black and white only

Post by monyol » Fri May 30, 2008 6:29 pm

Hi all,

I have installed ZM on a debian system and it is working with a 8 input capture video card. The problem I try to solve is that the image I get is only black&white.

This is my video card:
Image
Brand eyes to eyes
Model P878H-8
Bus PCI 32bit
Chipset 4 Chip's Conexant BT878
Conexiones - 8 BNC (4 en tarjeta + 4 en latiguillo) - 1 RCA
Velocidad Reproducción/Grabación: 100 fps

I have tried to configure the video card with bttv (card number 0,77,133,102... and diferent gbuffers settings) but I cannot get it full working. I must select AUTO source in spite both (card and camera) are PAL system.

I would apreciate any help to configure correctly the card and to get the image coloured.

Thank you in advance.

we4zonM
Posts: 56
Joined: Fri May 30, 2008 7:21 am

Grayscale video easier to use for Motion Detection

Post by we4zonM » Fri May 30, 2008 7:33 pm

It may work better in Black in White for Motion detection! I am using an Airlink101 AIC250, and it sends RGB video in jpg streams. It would be easier to configure it for Motion detection if it was sending Grayscale, or "Black and White". You mean it is sending Grayscale, right? Black and White would be a Binary Image!

monyol
Posts: 2
Joined: Fri May 30, 2008 6:19 pm

Grayscale video bt878 conexant

Post by monyol » Fri May 30, 2008 7:51 pm

That is right; I am getting grayscale video (black and white is a literal translation form spanish :) ) and in spite that it is better to configure motion detection I would like to try with RGB image.

ZM is working perfectly in modect mode and my settings are:
Device format: AUTO
Capture Palette: RGB24

Any sugestions for the card settings?

Thank you

satyr09
Posts: 3
Joined: Wed Aug 27, 2008 2:02 pm

Settings for captureing with P878H-8 with all 8 cameras

Post by satyr09 » Wed Aug 27, 2008 2:28 pm

I think I'just cannot figure the right modules.conf card= options ...

I tried it like with Kodikom 4400R :

/sbin/modprobe bttv card=133,132,133,133

there are even clicking sounds as I switch the input from Composite1 to NN, in the xawtv , but only blue screan with each input variant! ...

if i use :

/sbin/modprobe bttv card=0,0,0,0
or
/sbin/modprobe bttv card=102,102,102,102
or
/sbin/modprobe bttv card=77,77,77,77

I have access to the firs 4 devices : /dev/video{0,1,2,3}

but I need all 8 , that is 4 on board and 4 extra BNCs connected through the 8pin parallel /female data cable !

You wrote in your Post by ZoneMinder Forum thet you can access all your cameras, the only problem was that you didn't reseive the colors only b/w which is not the problem with me
I just whant to have accsess to all 8 cameras.

Are my bttv moduel options ok?
Or perhaps should I set some jumpers on the Capture card board?
Thanks in advance.

narmar
Posts: 19
Joined: Sat Jun 28, 2008 5:06 pm

Post by narmar » Wed Aug 27, 2008 9:55 pm

monyol: do You use all inputs? if You have 2 cameras conected to one chip ie You have two monitors for ex. on /dev/video0 (1) and /dev/video0 (2) You must set up them in the same way. it can't be one grey scale and one rgb.

satyr09:
missing inputs are when You change channel number
http://www.zoneminder.com/wiki/index.ph ... _device.29

satyr09
Posts: 3
Joined: Wed Aug 27, 2008 2:02 pm

Post by satyr09 » Thu Aug 28, 2008 2:43 pm

hi narmar thanks that you help

but perhaps we just understanding different things under the meaning of word
- channel -
as the tuner=4 in the following option file for the bttv capture card initialisation
means " no tuner " and thats why no possibility to access any channel

the line from hardware help site http://www.zoneminder.com/wiki/index.ph ... ip_8inputs :
-> modules.conf options <-
options bttv card=0,0,0,0 tuner=4,4,4,4
------------------------------^^^^^^^^^^^

my card is just exactly the same as on the image in this thread
thats why I choose this enttry "Bt878_4chip_8inputs" of the hardware help page.

Do I miss something?

I am tryeing to check my options with mplayer comandline like this:

mplayer tv://0 -tv \
driver=v4l2:input=0:device=/dev/video0:norm=pal:noaudio:width=320:height=240 \
-vf spp,scale -fps 16 -vo x11

where [ tv://0 ] - is channel one
[ input=0 ] -is television (one can choose from
0-Television,
1-composite1,
2-composite2,
3-S-Video , ..etc.)

but switching of the channels tv://1,2,3... is to no awail ...

the only thing that does change something is input,
as with the input=0 I can access video from the camera which is connected directly to the card's board.
All the other input=1,2,3,4... give me bueutiful blue screen...

As I understand you mean that I should receive the other camera that are connected to the extra 4 -bnc connectors on the extra board by changeing the channel

from $ mplayer tv://0 ....
to $ mplayer tv://1 ....

but this doesn't go!

I tried the same thing with : ----------> $ xawtv -c /dev/video0
I just cannot switch channels and change of the input has the same result.!

What I'm missing?

so logically thought, I should use some other option for the tuner, becouse tuner=4 desables the channel switching...

but which one - of the Pal tuner parameters from the /usr/share/linux-kernel-documentation
should I use? -if at all. There are at least 40 ..
Last edited by satyr09 on Thu Aug 28, 2008 3:12 pm, edited 1 time in total.

satyr09
Posts: 3
Joined: Wed Aug 27, 2008 2:02 pm

Solved, that is my own fault >:)))..

Post by satyr09 » Thu Aug 28, 2008 4:22 pm

:lol:

Hey people sorry, I've had all the time the data band falsely connected.
the right whay is the redstripe should be directed to the side the bnc connectors on the
card board, and red stripe to the outside of the computer motherboard on the extantion bnc panel...

that done, I must add that switching takes plase through the changeing of the input parameter and not of the tv://channel

# .........................................................
so in the xawtv terms:

input:Television =>is the first camera on the card-board
and
input:Composite1=>is the first camera on the extention bnc panel ...
# .........................................................
and in mplayer terms:

device=/dev/video0:input=0: ---- =>is the first camera on the card-board
and
device=/dev/video0:input=1: ---- =>is the first camera on the extention bnc panel ...
# .........................................................

that makes it clear why one can use disabled tuner in modules.conf driver initialisation options: tuner=4,4,4,4 - tv-tuner isn't being used its common for the servielance capture cards!

the last thing, here is my bttv options line:

options bttv card=138,138,138,138 pll=1,1,1,1 tuner=4,4,4,4 gbuffers=16 latency=64

with it ibecome color video output with my pal cameras and P878H-8 Pro-Video Capture Card 4 connexant chips and 4 bnc onboard and 4bnc on the extra panel

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests