All works fine. A few days ago I found a lot of orphaned zms-??????.lock files in /run/zm/

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
DR_Omi
Posts: 2
Joined: Fri Oct 16, 2020 1:54 pm

All works fine. A few days ago I found a lot of orphaned zms-??????.lock files in /run/zm/

Post by DR_Omi » Mon Apr 19, 2021 8:38 pm

Hi,

OS: Ubuntu 20.04 (all current)
ZM: 1.34.23...25
Cameras: Dahua IPC-HFW*
ZM configured to use H264 passthrough
Source Path: rtsp://<user>:<password>@192.168.1.???:554/cam/realmonitor?channel=1&subtype=1 | 0
Method TCP

To produce error:
sudo find /run/zm/*.lock -delete
Open up Console in web browser (Firefox 87) and click on a camera for live viewing. Everything is ok. Press "BACK" to close view / window.

sudo ls -al /run/zm/

drwxr-xr-x 2 www-data www-data 120 kwi 19 21:15 .
drwxr-xr-x 37 root root 1220 kwi 19 21:02 ..
srwxrwxr-x 1 www-data www-data 0 kwi 19 10:06 zmdc.sock
-rw-rw-r-- 1 www-data www-data 6 kwi 19 10:06 zm.pid
-rw------- 1 www-data www-data 0 kwi 19 21:05 zms-150951.lock


And it lasts forever. After months I had over 5k zms-*.lock files in /run/zm/

The same is when I open "Montage" except more zms-*.lock files persists, one for each monitor

no errors in MySQL database zm Logs
LOG_LEVEL_SYSLOG checked Error | Warning | Info | Debug


any ideas ?

User avatar
iconnor
Posts: 1583
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: All works fine. A few days ago I found a lot of orphaned zms-??????.lock files in /run/zm/

Post by iconnor » Mon Apr 19, 2021 9:39 pm

Edit /usr/lib/tmpfiles.d/zoneminder.conf

add a line

e /run/zm/*.lock - - - 1d

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests