zmNinja bandwidth usage rather high even with lbm?

Discussion topics related to mobile applications for ZoneMinder
Post Reply
Fressikus
Posts: 7
Joined: Fri Jul 29, 2016 7:51 pm

zmNinja bandwidth usage rather high even with lbm?

Post by Fressikus » Thu Jan 24, 2019 1:37 pm

I feel like my zmNinja still uses a lot of mobile data even when switched to low bandwidth mode. I have just four active cameras configured at a time in montage and you can see well over 50MB of data getting used every minute.

Would there be a way to maybe drastically reduce the framerate or something else to be able to use up less data? Also, did any of you guys check how much data you are using with your ZM setups?

User avatar
asker
Posts: 1106
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja bandwidth usage rather high even with lbm?

Post by asker » Fri Jan 25, 2019 1:54 am

That does not seem normal. It however depends on how large your monitor resolution is and what you are doing in a minute.

I just ran zmN on Android for a minute. Low bandwidth was on. My monitors are around 1280x720 (averaging out) and I have 7.

with multi-port off (if you haven't explicitly configured multiport its off), in low bandwidth mode, each JPEG image takes around 50K. Images are refreshed once in I think 8 seconds. That comes to approx 3MB per min in montage mode (some overhead added).
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Fressikus
Posts: 7
Joined: Fri Jul 29, 2016 7:51 pm

Re: zmNinja bandwidth usage rather high even with lbm?

Post by Fressikus » Sun Jan 27, 2019 9:36 pm

Thank you for your reply. I've had some time to test this again, and it seems like I've misunderstood how the low bandwidth mode actually works. It only does something on the montage screen, not on a single camera monitor.

Two minutes on the montage screen with lbm on actually uses 3.8 MB for me, so that's great!
One minute of a single camera monitor (full HD, 15 FPS) uses 30 MB

The only way to get the single camera usage down would be to reduce the framerate or resolution of the camera "globally" in Zoneminder, I suppose?

User avatar
asker
Posts: 1106
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja bandwidth usage rather high even with lbm?

Post by asker » Mon Jan 28, 2019 8:15 am

In single monitor view, it switches the "&scale=" parameter to 50 (default is 70), so it does reduce. That being said, in single monitor view, it is continuously streaming images (whereas in montage, it is cycling snapshots every 8 secs, so there will be bandwidth differences). I think the bandwidth you see if similar to what you would see in ZM console.
Fressikus wrote:
Sun Jan 27, 2019 9:36 pm
Thank you for your reply. I've had some time to test this again, and it seems like I've misunderstood how the low bandwidth mode actually works. It only does something on the montage screen, not on a single camera monitor.

Two minutes on the montage screen with lbm on actually uses 3.8 MB for me, so that's great!
One minute of a single camera monitor (full HD, 15 FPS) uses 30 MB

The only way to get the single camera usage down would be to reduce the framerate or resolution of the camera "globally" in Zoneminder, I suppose?
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest