Upgrade fail on CentOS 6.8 1.29 - 1.30

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
basketcase
Posts: 31
Joined: Thu Aug 22, 2013 10:04 pm

Upgrade fail on CentOS 6.8 1.29 - 1.30

Post by basketcase » Mon Sep 19, 2016 1:49 am

Hi all,

I've been having trouble upgrading on Centos 6.8 from ZM 1.29 - 1.30.


So I've upgraded the standard way as I have many times before. This is with CentOS Base and the zmrepo enabled.

Code: Select all

yum install zoneminder

Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.aarnet.edu.au
 * zmrepo: 67.53.78.182
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.29.0-3.el6 will be updated
---> Package zoneminder.x86_64 0:1.30.0-3.el6 will be an update
--> Processing Dependency: perl(Sys::MemInfo) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Sys::CPU) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::XSD::Typelib::Builtin::anySimpleType) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::XSD::Typelib::Builtin) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Transport::HTTP) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::SOAP::Typelib::Fault11) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Transport) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Serializer) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Deserializer) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(IO::Socket::Multicast) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Digest::SHA) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Data::UUID) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Data::Dump) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Class::Std::Fast::Storable) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Class::Std::Fast) for package: zoneminder-1.30.0-3.el6.x86_64
--> Running transaction check
---> Package perl-Class-Std-Fast.noarch 0:0.0.8-2.el6 will be installed
--> Processing Dependency: perl(Class::Std) for package: perl-Class-Std-Fast-0.0.8-2.el6.noarch
---> Package perl-Data-Dump.noarch 0:1.15-1.el6 will be installed
---> Package perl-Data-UUID.x86_64 0:1.219-3.el6 will be installed
---> Package perl-Digest-SHA.x86_64 1:5.47-141.el6_7.1 will be installed
---> Package perl-IO-Socket-Multicast.x86_64 0:1.12-1.el6 will be installed
--> Processing Dependency: perl(IO::Interface) >= 0.94 for package: perl-IO-Socket-Multicast-1.12-1.el6.x86_64
---> Package perl-SOAP-WSDL.noarch 0:3.003-1.el6 will be installed
--> Processing Dependency: perl(Template) >= 2.18 for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(XML::Parser::Expat) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Term::ReadKey) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Class::Load) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestUtil) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestRec) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestIO) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Log) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Const) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(APR::Table) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
---> Package perl-Sys-CPU.x86_64 0:0.51-7.el6 will be installed
---> Package perl-Sys-MemInfo.x86_64 0:0.91-5.el6 will be installed
--> Running transaction check
---> Package mod_perl.x86_64 0:2.0.4-11.el6_5 will be installed
--> Processing Dependency: perl(BSD::Resource) for package: mod_perl-2.0.4-11.el6_5.x86_64
---> Package perl-Class-Load.noarch 0:0.10-1.el6 will be installed
--> Processing Dependency: perl(Try::Tiny) for package: perl-Class-Load-0.10-1.el6.noarch
--> Processing Dependency: perl(Package::Stash) for package: perl-Class-Load-0.10-1.el6.noarch
--> Processing Dependency: perl(Data::OptList) for package: perl-Class-Load-0.10-1.el6.noarch
---> Package perl-Class-Std.noarch 0:0.0.8-5.el6 will be installed
---> Package perl-IO-Interface.x86_64 0:1.05-15.el6 will be installed
---> Package perl-Template-Toolkit.x86_64 0:2.22-5.el6 will be installed
--> Processing Dependency: perl(Pod::POM) for package: perl-Template-Toolkit-2.22-5.el6.x86_64
--> Processing Dependency: perl(AppConfig) for package: perl-Template-Toolkit-2.22-5.el6.x86_64
---> Package perl-TermReadKey.x86_64 0:2.30-13.el6 will be installed
---> Package perl-XML-Parser.x86_64 0:2.36-7.el6 will be installed
--> Running transaction check
---> Package perl-AppConfig.noarch 0:1.66-6.el6 will be installed
---> Package perl-BSD-Resource.x86_64 0:1.29.03-3.el6 will be installed
---> Package perl-Data-OptList.noarch 0:0.104-4.el6 will be installed
--> Processing Dependency: perl(Sub::Install) >= 0.92 for package: perl-Data-OptList-0.104-4.el6.noarch
--> Processing Dependency: perl(Params::Util) for package: perl-Data-OptList-0.104-4.el6.noarch
---> Package perl-Package-Stash.noarch 0:0.32-1.el6 will be installed
--> Processing Dependency: perl(Package::Stash::XS) >= 0.24 for package: perl-Package-Stash-0.32-1.el6.noarch
--> Processing Dependency: perl(Package::DeprecationManager) for package: perl-Package-Stash-0.32-1.el6.noarch
---> Package perl-Pod-POM.noarch 0:0.25-2.el6 will be installed
---> Package perl-Try-Tiny.noarch 0:0.11-4.el6 will be installed
--> Running transaction check
---> Package perl-Package-Stash.noarch 0:0.32-1.el6 will be installed
--> Processing Dependency: perl(Package::Stash::XS) >= 0.24 for package: perl-Package-Stash-0.32-1.el6.noarch
--> Processing Dependency: perl(Package::DeprecationManager) for package: perl-Package-Stash-0.32-1.el6.noarch
---> Package perl-Params-Util.x86_64 0:1.00-3.el6 will be installed
---> Package perl-Sub-Install.noarch 0:0.925-6.el6 will be installed
--> Finished Dependency Resolution
Error: Package: perl-Package-Stash-0.32-1.el6.noarch (zmrepo)
           Requires: perl(Package::Stash::XS) >= 0.24
Error: Package: perl-Package-Stash-0.32-1.el6.noarch (zmrepo)
           Requires: perl(Package::DeprecationManager)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have actually navigated through the repo source and the files it wants are there:
example: perl-Package-Stash-0..> 2011-09-08 16:07 32K

I'm at a loss as to what I'm doing wrong...

Here I've disabled all other packages, get a different error:

Code: Select all

Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * zmrepo: zmrepo.mehvc.com
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.29.0-3.el6 will be updated
---> Package zoneminder.x86_64 0:1.30.0-3.el6 will be an update
--> Processing Dependency: perl(Sys::MemInfo) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Sys::CPU) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::XSD::Typelib::Builtin::anySimpleType) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::XSD::Typelib::Builtin) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Transport::HTTP) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::SOAP::Typelib::Fault11) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Transport) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Serializer) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(SOAP::WSDL::Factory::Deserializer) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(IO::Socket::Multicast) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Digest::SHA) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Data::UUID) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Data::Dump) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Class::Std::Fast::Storable) for package: zoneminder-1.30.0-3.el6.x86_64
--> Processing Dependency: perl(Class::Std::Fast) for package: zoneminder-1.30.0-3.el6.x86_64
--> Running transaction check
---> Package perl-Class-Std-Fast.noarch 0:0.0.8-2.el6 will be installed
--> Processing Dependency: perl(Class::Std) for package: perl-Class-Std-Fast-0.0.8-2.el6.noarch
---> Package perl-Data-Dump.noarch 0:1.15-1.el6 will be installed
---> Package perl-Data-UUID.x86_64 0:1.219-3.el6 will be installed
---> Package perl-IO-Socket-Multicast.x86_64 0:1.12-1.el6 will be installed
--> Processing Dependency: perl(IO::Interface) >= 0.94 for package: perl-IO-Socket-Multicast-1.12-1.el6.x86_64
---> Package perl-SOAP-WSDL.noarch 0:3.003-1.el6 will be installed
--> Processing Dependency: perl(Template) >= 2.18 for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(XML::Parser::Expat) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Term::ReadKey) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Class::Load) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestUtil) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestRec) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestIO) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Log) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Const) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(APR::Table) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
---> Package perl-Sys-CPU.x86_64 0:0.51-7.el6 will be installed
---> Package perl-Sys-MemInfo.x86_64 0:0.91-5.el6 will be installed
---> Package zoneminder.x86_64 0:1.30.0-3.el6 will be an update
--> Processing Dependency: perl(Digest::SHA) for package: zoneminder-1.30.0-3.el6.x86_64
--> Running transaction check
---> Package perl-Class-Load.noarch 0:0.10-1.el6 will be installed
--> Processing Dependency: perl(Try::Tiny) for package: perl-Class-Load-0.10-1.el6.noarch
--> Processing Dependency: perl(Package::Stash) for package: perl-Class-Load-0.10-1.el6.noarch
--> Processing Dependency: perl(Data::OptList) for package: perl-Class-Load-0.10-1.el6.noarch
---> Package perl-Class-Std.noarch 0:0.0.8-5.el6 will be installed
---> Package perl-IO-Interface.x86_64 0:1.05-15.el6 will be installed
---> Package perl-SOAP-WSDL.noarch 0:3.003-1.el6 will be installed
--> Processing Dependency: perl(Template) >= 2.18 for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(XML::Parser::Expat) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Term::ReadKey) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestUtil) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestRec) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestIO) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Log) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Const) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(APR::Table) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
---> Package zoneminder.x86_64 0:1.30.0-3.el6 will be an update
--> Processing Dependency: perl(Digest::SHA) for package: zoneminder-1.30.0-3.el6.x86_64
--> Running transaction check
---> Package perl-Class-Load.noarch 0:0.10-1.el6 will be installed
--> Processing Dependency: perl(Data::OptList) for package: perl-Class-Load-0.10-1.el6.noarch
---> Package perl-Package-Stash.noarch 0:0.32-1.el6 will be installed
--> Processing Dependency: perl(Package::Stash::XS) >= 0.24 for package: perl-Package-Stash-0.32-1.el6.noarch
--> Processing Dependency: perl(Package::DeprecationManager) for package: perl-Package-Stash-0.32-1.el6.noarch
---> Package perl-SOAP-WSDL.noarch 0:3.003-1.el6 will be installed
--> Processing Dependency: perl(Template) >= 2.18 for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(XML::Parser::Expat) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Term::ReadKey) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestUtil) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestRec) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::RequestIO) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Log) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(Apache2::Const) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
--> Processing Dependency: perl(APR::Table) for package: perl-SOAP-WSDL-3.003-1.el6.noarch
---> Package perl-Try-Tiny.noarch 0:0.11-4.el6 will be installed
---> Package zoneminder.x86_64 0:1.30.0-3.el6 will be an update
--> Processing Dependency: perl(Digest::SHA) for package: zoneminder-1.30.0-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Term::ReadKey)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(XML::Parser::Expat)
Error: Package: zoneminder-1.30.0-3.el6.x86_64 (zmrepo)
           Requires: perl(Digest::SHA)
Error: Package: perl-Package-Stash-0.32-1.el6.noarch (zmrepo)
           Requires: perl(Package::DeprecationManager)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(APR::Table)
Error: Package: perl-Package-Stash-0.32-1.el6.noarch (zmrepo)
           Requires: perl(Package::Stash::XS) >= 0.24
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Apache2::Const)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Apache2::RequestIO)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Apache2::Log)
Error: Package: perl-Class-Load-0.10-1.el6.noarch (zmrepo)
           Requires: perl(Data::OptList)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Template) >= 2.18
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Apache2::RequestRec)
Error: Package: perl-SOAP-WSDL-3.003-1.el6.noarch (zmrepo)
           Requires: perl(Apache2::RequestUtil)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Ideas much appreciated - it's probably something simple I'm missing

edit: That's CentOS 6.8 not 6.7

Cheers!
Dave

User avatar
knight-of-ni
Posts: 2341
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Upgrade fail on CentOS 6.8 1.29 - 1.30

Post by knight-of-ni » Mon Sep 19, 2016 2:58 pm

Looks like I missed a couple of Perl dependencies of ZoneMinder's Perl dependencies. This has been fixed.

Try it again, but with your base repo enabled (never disable that).

The CentOS 6 repo does not receive the same amount of love as the CentOS 7 repo because I no longer use it in production nor do I directly develop on it.
Sorry for the inconvenience.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

basketcase
Posts: 31
Joined: Thu Aug 22, 2013 10:04 pm

Re: Upgrade fail on CentOS 6.8 1.29 - 1.30

Post by basketcase » Mon Sep 19, 2016 10:11 pm

Excellent works a perfect now.

Had to flip the resolution settings on a few 720p cams which I'd previously rotated left or right. I see the resolution height and width are now rotated automatically, fixed the corresponding zones.

Looks to have a good performance improvement too, load levels are down under normal operations.

You make a good point too, this old box is due an upgrade, I think I've run it since about 2012 24/7, thing just keeps on going! Only gets power cycled on major updates I've been waiting for something like the primary HDD to go to motivate me into action.

Thanks again.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests