v1.34.11 - Email works in command line but not zm

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

v1.34.11 - Email works in command line but not zm

Post by vskatusa » Tue May 12, 2020 1:27 pm

Hi, I followed the guide https://wiki.zoneminder.com/How_to_get_ ... Zoneminder to setup SSMTP.

Please note that the command line works great.

But when I FORCE ALARM in one of the camera's I do not get an email.

Here is my configuration screenshot of options->email
https://pasteboard.co/J827lEu.jpg

Would appreciate some help!

User avatar
iconnor
Posts: 1352
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: v1.34.11 - Email works in command line but not zm

Post by iconnor » Tue May 12, 2020 2:09 pm

You need to setup a filter to do the actual emailing. It isn't automatic.

vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

Re: v1.34.11 - Email works in command line but not zm

Post by vskatusa » Tue May 12, 2020 2:19 pm

Thank you.
Here is the screenshot of a filter I have setup. Is this all I need?
https://pasteboard.co/J82spNo.jpg

Please find the error message "unable to send email: error closing /usr/lib/sendmail (exit 256) zmfilter.pl (screenshot included)
https://pasteboard.co/J82wnQK.jpg

vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

Re: v1.34.11 - Email works in command line but not zm

Post by vskatusa » Tue May 12, 2020 6:54 pm

Solved! execute permission on ssmtp.conf solved it

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests