USB microphone

Forum for questions and support relating to 1.33.x development only.
Post Reply
samsungcoho
Posts: 1
Joined: Sat Dec 22, 2018 2:19 am

USB microphone

Post by samsungcoho » Sat Dec 22, 2018 2:24 am

Hi,

I hope you are all well!

Just installed ZM today and so far I love it. I have connected my RPI camera via motioneye. Motioneye doesn't support audio recording so I want to add a USB microphone to ZM so that I have the video with audio. Is this possible? I can do this in ispy but I see no options in any menus in ZM.

If you know if this is possible please let me know!

Thanks!

James

Pedulla
Posts: 142
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

Re: USB microphone

Post by Pedulla » Tue Feb 05, 2019 4:40 pm

You're going to have to figure out how to mux the video and mic on the Pi and then stream it to ZM.

chibi
Posts: 3
Joined: Thu Mar 05, 2020 6:32 pm

Re: USB microphone

Post by chibi » Wed Mar 11, 2020 7:28 pm

If it is not too lat; may I ask what your settings are in ZM and MotionEye to get the video stream to be shown in ZM?

User avatar
iconnor
Posts: 1449
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: USB microphone

Post by iconnor » Thu Mar 12, 2020 3:01 am

In 1.35 will come the ability to mux a separate audio stream.

ml35
Posts: 5
Joined: Tue Nov 03, 2020 12:28 pm

Re: USB microphone

Post by ml35 » Thu Nov 26, 2020 10:49 am

is microphone recording usable now in the dev version? does it work for locally attached camera via usb with integrated microphone?

User avatar
iconnor
Posts: 1449
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: USB microphone

Post by iconnor » Fri Nov 27, 2020 9:07 pm

no

surfzoid
Posts: 3
Joined: Tue Dec 08, 2020 3:17 pm

Re: USB microphone

Post by surfzoid » Wed Feb 10, 2021 8:26 am

Hi
I have similar issue, in my case, i use an uvc webcam with mic integrated, so in ZM (1.32 from my distro (mageia 7.1)), i set as local and /dev/video0, so i don't have sound, my workarroud is like this :
ffmpeg -thread_queue_size 512 -f v4l2 -i /dev/video0 -f pulse -i alsa_input.usb-Sonix_Technology_Co.__Ltd_USB_2.0_Camera_SN0001-02.analog-mono -ac 1 -ar 44100 -an -pass 1 -profile:v high -pix_fmt yuvj420p -level:v 4.1 -preset ultrafast -tune zerolatency -vcodec libx264 -vpre medium -b:a 180000 -bt 180000 -r 10 -b:v 2048k -s 1920x1080 -acodec aac -strict -2 -ac 1 -ar 44100 -ab 256k -listen 1 -f mpegts -flush_packets 0 http://127.0.0.1:8081
and in ZM ffmpeg source and audio passthrough.
with VLC stream is ok, in ZM live view too, but in ZM log i see ZM can't save mp4 event file because of incorect input!
I don't know the litlle arguments whose need to be adjusted!
which debug output i need to provide ?

surfzoid
Posts: 3
Joined: Tue Dec 08, 2020 3:17 pm

Re: USB microphone

Post by surfzoid » Wed Feb 10, 2021 10:11 am

hum, intersting, changing ffmpeg by cvlc : cvlc v4l2:///dev/video0 :size=1920x1080 :v4l2-standard=525_60 :input-slave=alsa://hw:0,0 :live-caching=300 --sout '#transcode {vcodec=theo,acodec=vorb,samplerate=48000}:std{access=http,mux=ffmpeg{mux=ogg},dst=0.0.0:8083}'

give me an different issue, first in ZM log i got :
févr. 10 11:02:52 localhost zmc_m1[4564]: WAR [zmc_m1] [Option rtsp_transport not recognized by ffmpeg]

i forced an alarm and get an infinite loop like in ZM log with :
févr. 10 11:07:24 localhost zmc_m1[5032]: WAR [zmc_m1] [Unable to set movflags to frag_custom+dash+delay_moov]
févr. 10 11:07:24 localhost zmc_m1[5032]: ERR [zmc_m1] [Error occurred when writing out file header to /mnt/cams/zm//1/2021-02-10/113/113-video.mp4: Invalid argument]
févr. 10 11:07:24 localhost zmc_m1[5032]: INF [zmc_m1] [Opening video storage stream /mnt/cams/zm//1/2021-02-10/113/113-video.mp4 format: mp4]
févr. 10 11:07:24 localhost zmc_m1[5032]: WAR [zmc_m1] [Unable to set movflags to frag_custom+dash+delay_moov]

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests