Noob First Time Install - No Video

Forum for questions and support relating to the 1.29.x releases only.
jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Noob First Time Install - No Video

Post by jimkoh » Mon Nov 20, 2017 1:49 am

Hello
I just installed ZoneMinder for the first time on my Debian server and everything seems o.k., except I don't have video. All I get is a blue screen. My settings are as follows: General: Source - Remote, Function - Monitor. Source: Remote Protocol - http, Remote Method - Simple, Remote Host Port - 80, Capture Width - 640, Capture Height - 480. I know the camera works because I see video when I use the native software. The camera I have is Jennov.
Thanks for any help

Jim

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Noob First Time Install - No Video

Post by rockedge » Wed Dec 06, 2017 2:17 pm

Hello Jim....the usual main cause of the blue screen is the camera resolution does not match your camera height and width settings!.....use VLC to open the camera stream and use VLC to check the actual camera output size....or try ffprobe ..... the key is finding out the actual camera image width and height and entering that in the "Source" tab in the monitor setup....

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Wed Dec 06, 2017 5:53 pm

Thanks for the reply. The problem now is I can't get vlc to play the stream and I don't even get the blue screen in zone minder any more. It's just blank. The only way I can view the camera's output is through IE in Windows (in VirtualBox). If I try to load it through any other browser, it gives me an error about an ocx plugin not being loaded, which I can't do because FF or Chrome no longer support ActiveX Plugin's. The IP of one of the camera's is 192.168.2.123 and the path to the stream in IE is http://192.168.2.123/asp/mainview.asp on the log in page it does say rtsupport 554. I have tried putting all these settings in ZM without success per info on this forum.

bbunge
Posts: 2727
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Noob First Time Install - No Video

Post by bbunge » Wed Dec 06, 2017 9:26 pm

Source Type Remote
Remote Protocol HTTP
Remote Host Name 192.168.2.123
Remote Host Port 80
Remote Host Path /asp/mainview.asp
Capture Width (pixels) 640
Capture Height (pixels) 480

or

Source Type ffmpeg
Source Path http://192.168.2.123//asp/mainview.asp


To test in VLC use the media stream option http://192.168.2.123/asp/mainview.asp

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Wed Dec 06, 2017 10:17 pm

I tried the settings you suggest and I still get nothing. The closest I can get is using Chrome or Konqueror which both tell me the plugin isn't supported. When I look in the code it's looking for Flash/Shockwave.
And this is the error I get in vlc QXcbConnection: XCB error: 3 (BadWindow), sequence: 12439, resource id: 37632182, major code: 40 (TranslateCoords), minor code: 0

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Noob First Time Install - No Video

Post by rockedge » Thu Dec 07, 2017 4:12 pm

take a look at https://www.ispyconnect.com/sources.aspx

see if you can find your camera and determine the correct path to the stream(s)

UPDATE: I looked, didn't find anything. I have a feeling the the path your using is not the correct one for the streaming method.

what happens if while running the camera's native software and viewing the stream you attempt to get the location url of the stream?

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Thu Dec 07, 2017 5:40 pm

The url I listed is the one that shows in IE when using the native software. I don't know how else to find the url if it's different.

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Noob First Time Install - No Video

Post by rockedge » Thu Dec 07, 2017 5:44 pm

if you use the url itself in IE will it stream at all on it's own? Do you have ffprobe along with ffmpeg? what happens if you on a terminal use

Code: Select all

#ffprobe http://192.168.2.123/asp/mainview.asp
is the camera ONVIF capable?

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Thu Dec 07, 2017 5:59 pm

IE will stream the video once I log in.

This is what I get when running ffprobe:
root@debian:/home/jim# ffprobe http://192.168.2.123/asp/mainview.asp
ffprobe version 3.3.5 Copyright (c) 2007-2017 the FFmpeg developers
built with gcc 6.3.0 (Debian 6.3.0-18) 20170516
configuration: --disable-decoder=amrnb --disable-decoder=libopenjpeg --disable-mips32r2 --disable-mips32r6 --disable-mips64r6 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-msa --disable-libopencv --disable-podpages --disable-stripping --enable-avfilter --enable-avresample --enable-gcrypt --enable-gnutls --enable-gpl --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libfdk-aac --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libilbc --enable-libkvazaar --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtesseract --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx265 --enable-libxvid --enable-libzvbi --enable-nonfree --enable-opengl --enable-openssl --enable-postproc --enable-pthreads --enable-shared --enable-version3 --incdir=/usr/include/x86_64-linux-gnu --libdir=/usr/lib/x86_64-linux-gnu --prefix=/usr --toolchain=hardened --enable-frei0r --enable-chromaprint --enable-libx264 --enable-libiec61883 --enable-libdc1394 --enable-vaapi --disable-opencl --enable-libmfx --disable-altivec --shlibdir=/usr/lib/x86_64-linux-gnu
libavutil 55. 58.100 / 55. 58.100
libavcodec 57. 89.100 / 57. 89.100
libavformat 57. 71.100 / 57. 71.100
libavdevice 57. 6.100 / 57. 6.100
libavfilter 6. 82.100 / 6. 82.100
libavresample 3. 5. 0 / 3. 5. 0
libswscale 4. 6.100 / 4. 6.100
libswresample 2. 7.100 / 2. 7.100
libpostproc 54. 5.100 / 54. 5.100
http://192.168.2.123/asp/mainview.asp: Invalid data found when processing input

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Noob First Time Install - No Video

Post by rockedge » Fri Dec 08, 2017 8:30 pm

what model is the camera exactly? There must be a different URL to reach the camera stream that can be used.....trick is finding it. Perhaps the camera is similar in function to another model and something from the ispy database may work. How do you communicate and adjust settings on this camera?

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Sat Dec 09, 2017 4:38 pm

There is no model number that I can find, but here's the Amazon link https://www.amazon.com/Jennov-Security- ... +ip+camera

The only way I can communicate with the camera is to use the native software or log in to the ip address in IE.

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Sat Dec 09, 2017 5:28 pm

Update: I downloaded ispy in VirtualBox and got the camera working. From there I was able to get it working in vlc in Linux. The url is rtsp://admin:admin@192.168.2.123:554/stream1 but I can't get any combination of the updated url to work in zoneminder.

benThijssen
Posts: 3
Joined: Wed Dec 20, 2017 1:56 pm

Re: Noob First Time Install - No Video

Post by benThijssen » Wed Dec 20, 2017 3:20 pm

I also have a Jennov camera, but a slightly different version. It's called mini ptz bullet camera. I would not be surprised all camera's are based on the same chip set: hi3510.
For camera authentication I had to deviate from the Installation guide. That is only one line.
In the "Options" panel, tab "System" I changed the line:
"AUTH_RELAY Method used to relay authentication information (?) hashed plain none" to "none"
Image

See the screen images for the configuration I used:
Image
Image
The "Source path" is not shown completely in the image but it reads: rtsp://user:password@jennov.localnamar.nu:554/11
Change user and password to your own settings.

Maybe not applicable for your type of camera, but I was able to fill the "Control" tab for the Pan and Tilt functions.
Image
Selecting "Control type" FI8620_Y2k was a bit cumbersome, and I do not recall exactly how I did that. Neither can I explain for what reason but I also had to enter the password of the camera in "Control device".

bbunge
Posts: 2727
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Noob First Time Install - No Video

Post by bbunge » Wed Dec 20, 2017 8:34 pm

jimkoh wrote:
Sat Dec 09, 2017 5:28 pm
Update: I downloaded ispy in VirtualBox and got the camera working. From there I was able to get it working in vlc in Linux. The url is rtsp://admin:admin@192.168.2.123:554/stream1 but I can't get any combination of the updated url to work in zoneminder.


Two common errors:
PATH_ZMS is not set to /zm/cgi-bin/nph-zms with a Ubuntu install
Camera resolution in Zoneminder does not match camera output. Use VLC (Tools, Media Information, Codec) to check camera Display Resolution.

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Noob First Time Install - No Video

Post by jimkoh » Wed Dec 20, 2017 9:22 pm

I made the changes to mimic yours and the best I get is a blue screen in IE that shows the time/date with numbers counting, but no picture. You must have a different version then 1.29 because I don't have all the options you do. I'm attaching 2 screenshots showing my settings.
Spectacle.TJ9522.jpeg
Spectacle.TJ9522.jpeg (55.56 KiB) Viewed 5886 times
Spectacle.J13119.jpeg
Spectacle.J13119.jpeg (47.12 KiB) Viewed 5886 times

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests