Fresh install 1.30 zoneminder - 1.28 entries do not work

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

Fresh install 1.30 zoneminder - 1.28 entries do not work

Post by vskatusa » Fri Oct 27, 2017 7:12 pm

Hi, I have a HIKVISION camera.... the fresh install for 1.30 went flawlessly - Excellent documentation by ZM. Thx.

I have a working 1.28 ZM working perfectly and all i wanted to do is copy paste camera entries from old to new ... but it does not work.

Example
==================================================================
1.28 ZM OLD --> HIKVISION entries
==================================================================
*** MONITOR/GENERAL Tab: ****
Source type: Ffmpeg
MAX FPS: 30.0

*** MONITOR/SOURCE Tab: ***
Source Path: rtsp://{username:pswd}@{IP address:rtspport#}//Streaming/Channels/1
Remote method: RTP/RTSP

==================================================================
1.30 ZM NEW --> HIKVISION entries
==================================================================
*** MONITOR/GENERAL Tab: ****
Source type: Ffmpeg
MAX FPS: 30.0

*** MONITOR/SOURCE Tab: ***
Source Path: rtsp://{username:pswd}@{IP address:rtspport#}//Streaming/Channels/1 [ as in old ]
Remote method: Unfortunately RTP/RTSP entry is not available and hence I selected TCP

However the above entries do not work.......meaning I am not able to see the live stream (however the IDENTICAL settings in 1.28 zm works). Any help would be appreciated.

Logs:

Socket /var/run/zm/zms-772683s.sock does not exist. This file is created by zms, and since it does not exist, either zms did not run, or zms exited early. Please check your zms logs and ensure that CGI is enabled in apache and check that the PATH_ZMS is set correctly. Make sure that ZM is actually recording. If you are trying to view a live stream and the capture process (zmc) is not running then zms will exit. Please go to http://zoneminder.readthedocs.io/en/lat ... window-etc for more information.

vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

Re: Fresh install 1.30 zoneminder - 1.28 entries do not work

Post by vskatusa » Fri Oct 27, 2017 8:12 pm

Solved changed PATH_ZMS

*** BEFORE ***
/cgi-bin/nph-zms

TO

***AFTER***
/zm/cgi-bin/nph-zms

Reference http://zoneminder.readthedocs.io/en/sta ... -streaming

My install is ZM 1.30 install in UBUNTU 16.04 server

Works fine now

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Fresh install 1.30 zoneminder - 1.28 entries do not work

Post by rockedge » Sat Oct 28, 2017 3:38 am

:D

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 16 guests