H.264 Camera Distortion Periodically

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
joako
Posts: 30
Joined: Mon Nov 01, 2010 7:10 am

H.264 Camera Distortion Periodically

Post by joako » Thu Oct 10, 2013 6:36 am

I have setup a generic IP camera that seems to work OK. However in Zoneminder I am forced to use the source type Ffmpeg because that camera sends non-hexadecimal characters in the RTSP session ID and Zoneminder only expects hexidecimal in that field, so I do not have the setting Source: Remote + RTSP to compare with.


When I use the Ffmpeg source the image sometimes is OK but sometimes it is not and half of the image is distorted badly. How can I resolve this? The camera always views OK through its web-interface. I have attached and example frame. This will go on continuously for minutes.
Attachments
100-capture.jpg
100-capture.jpg (65.45 KiB) Viewed 1637 times

Ehover_India
Posts: 3
Joined: Fri Oct 11, 2013 11:51 am

Re: H.264 Camera Distortion Periodically

Post by Ehover_India » Tue Oct 15, 2013 6:52 am

Hi....

till now no problem all good
I have enabled authentication in zoneminder and restarted

Now I am also facing same problem

I use very less resolution (320x240) and whole image gets distortion

please give any suggestion.....

stenny73
Posts: 3
Joined: Tue Oct 15, 2013 7:33 am

Re: H.264 Camera Distortion Periodically

Post by stenny73 » Tue Oct 15, 2013 7:42 am

Hello

i have this Problem on wansview when i Insert in Maximum FPS or Alarm Maximum FPS any fps.

do insert nothing in Maximum FPS or Alarm Maximum FPS

(sorry for my english)

stenny

bbunge
Posts: 2446
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: H.264 Camera Distortion Periodically

Post by bbunge » Tue Oct 22, 2013 11:03 pm

Here are my comments from the ZM 1.26.4 area:

I had this same issue with ZM 1.25.0 and my recent upgrade to 1.26.4. Running Ubuntu 12.04 LTS. I actually rebuilt the server with a fresh Ubuntu 12.04 Server, X264 and ZM 1.26.4 from the Launchpad repository (see my how to in the Ubuntu specific area of the WIKI). I have 11 Linksys IP cameras, 1 Vivotek IP camera, and 1 Logitech USB camera on a Core 2 Duo, 2.66 MHZ with 8 GIG RAM. The Vivotek was running on FFMPEG H.264 stream and recording smeared images every two minutes or so.
Earlier tonight I switched the Source to Remote
Remote Protocol: RTSP
Remote Method: RTP/RTSP
Remote Host Name: IP of camera
Remote Host Port: 554
Remote Host Path: set to the H.264 camera stream setting

Happy to report it has been over two hours with no smeared images! Only things that move get recorded.

bb

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests