Search found 32 matches

by B F
Mon Feb 15, 2021 1:04 pm
Forum: ZoneMinder 1.34.x
Topic: RESOLVED - Bug in 'settings.php'
Replies: 0
Views: 81

RESOLVED - Bug in 'settings.php'

When trying to change monitor settings in v1.34.23 nothing happens and the message "PHP Warning: require_once(Monitor.php): failed to open stream: No such file or directory in /usr/share/zoneminder/www/includes/actions/settings.php on line 32" appears in ssl_error_log. Solution: Edit line 32 of /usr...
by B F
Sun Feb 14, 2021 1:06 pm
Forum: ZoneMinder 1.34.x
Topic: RESOLVED - Catch 22? - PHP Fatal error: -> DateTime::__construct():
Replies: 1
Views: 96

Re: RESOLVED : Catch 22? - PHP Fatal error: -> DateTime::__construct():

Looks like ";date.timezone = " first has to be set in /etc/php.ini using the values given at http://php.net/date.timezone

Apache then needs restarting

Code: Select all

systemctl restart httpd.service
After that it's possible to set the timezone setting in Zoneminder via Options -> System -> TIMEZONE
by B F
Sun Feb 14, 2021 12:06 pm
Forum: ZoneMinder 1.34.x
Topic: RESOLVED - Catch 22? - PHP Fatal error: -> DateTime::__construct():
Replies: 1
Views: 96

RESOLVED - Catch 22? - PHP Fatal error: -> DateTime::__construct():

Complete fresh new installation of CentOS Linux release 7.9.2009 (Core) and new Zoneminder from RPM Fusion today. Part 4. of /usr/share/doc/zoneminder-common-1.34.23/README.httpd clearly states Manually setting the timezone in /etc/php.ini is deprecated. Instead, navigate to Options -> System from t...
by B F
Fri Jul 17, 2020 8:35 am
Forum: ZoneMinder 1.34.x
Topic: Time to next event = 1594938269 seconds
Replies: 5
Views: 595

Time to next event = 1594938269 seconds

Anyone know why Zoneminder says "Time to next event = 1594938269 seconds" when attempting to play back recordings & how to fix this? It never used to do behave like this, it only started with software versions released from approx 1.5 - 2 years ago. The number of seconds decrements but I've never wa...
by B F
Wed Jan 29, 2020 7:36 am
Forum: ZoneMinder 1.34.x
Topic: Cannot delete archived events
Replies: 5
Views: 1296

Re: Cannot delete archived events

I run ZoneMinder in 'Mocord' mode and have been using it since 2012 with every version inbetween & this is the first time I've not been able to delete archived events. The problem is that almost as soon as I unarchive everything the automatic filter that runs to archive anything of interest re-archi...
by B F
Tue Jan 28, 2020 7:52 pm
Forum: ZoneMinder 1.34.x
Topic: SOLVED: PHP Warning: htmlspecialchars(): charset `ANSI_X3.4-1968'... messages in ssl_error_log
Replies: 0
Views: 1827

SOLVED: PHP Warning: htmlspecialchars(): charset `ANSI_X3.4-1968'... messages in ssl_error_log

Operating System: CentOS Linux release 7.7.1908 (Core) /var/log/httpd/ssl_error_log reports the messages: PHP Warning: htmlspecialchars(): charset `ANSI_X3.4-1968' not supported, assuming utf-8 in /usr/share/zoneminder/www/includes/functions.php Solution: # yum install php-mbstring # httpd -k restart
by B F
Tue Jan 28, 2020 7:49 pm
Forum: ZoneMinder 1.34.x
Topic: Cannot delete archived events
Replies: 5
Views: 1296

Re: Cannot delete archived events

This comes up in the logs for each event I delete but I'm unclear where this comes from:

Code: Select all

web_php[2215]: INF [Cannot delete Archived event.]
by B F
Mon Jan 27, 2020 7:34 pm
Forum: ZoneMinder 1.34.x
Topic: Cannot delete archived events
Replies: 5
Views: 1296

Re: Cannot delete archived events

Not only can archived events not be deleted they also cannot be 'unarchived' (even though the gui suggests it has done it) so slowly my disk is filling up with archived events that cannot be got rid of. Anyone have suggestions on how to go about fault solving this?
by B F
Sun Jan 26, 2020 7:02 pm
Forum: ZoneMinder 1.34.x
Topic: Cannot delete archived events
Replies: 5
Views: 1296

Cannot delete archived events

Anyone else experiencing not being able to delete archived events in v1.34.0 ?
by B F
Wed Jul 10, 2019 12:44 pm
Forum: ZoneMinder 1.32.x
Topic: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events
Replies: 14
Views: 7360

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Finally got around to trying sabby's Thu Jan 24, 2019 3:22 pm solution today but ended up with the message "MooTools not found! Please check that it was installed correctly in ZoneMinder web root". In the end I think there was some symbolic links missing in the mootools directory because when it's l...
by B F
Thu Jan 03, 2019 7:33 am
Forum: ZoneMinder 1.32.x
Topic: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events
Replies: 14
Views: 7360

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Sorry my bad, it is ZoneMinder v1.32.3 I upgraded to. I wonder if there's a step I missed or incorrectly made during the upgrade. Odd how it just whizzes through all the events at the rate of about one minute per second. Unfortunately it's quite unusable now.
by B F
Wed Jan 02, 2019 9:26 pm
Forum: ZoneMinder 1.32.x
Topic: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events
Replies: 14
Views: 7360

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

I have exactly the same issues going from 1.30.x to 1.32.2 in both Firefox & Chrome. Also some odd behaviour in which played back events (JPG) just zoom through no matter what setting I use for WEB_H_DEFAULT_RATE or sometimes they never even start playing. Bit stuck how to debug this one as there's ...
by B F
Fri Mar 17, 2017 5:39 pm
Forum: ZoneMinder 1.30.x
Topic: [SOLVED] GPG keys not correct for this package: x265-libs-1.9-3.el7.x86_64
Replies: 3
Views: 1580

Re: GPG keys not correct for this package: x265-libs-1.9-3.el7.x86_64

Thank you knnniggett that indeed resolved the issue.
by B F
Fri Mar 17, 2017 12:24 pm
Forum: ZoneMinder 1.30.x
Topic: [SOLVED] GPG keys not correct for this package: x265-libs-1.9-3.el7.x86_64
Replies: 3
Views: 1580

[SOLVED] GPG keys not correct for this package: x265-libs-1.9-3.el7.x86_64

When time permits I'll have a proper look at this problem but in the meantime just throwing it out to the community in case anyone has an idea: Downloading packages: warning: /var/cache/yum/x86_64/7/zmrepo/packages/x265-libs-1.9-3.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID f5cf6c1e: NOKEY ...