Video stopping recording in the middle of the Alarm

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
mk45gti
Posts: 7
Joined: Fri Feb 16, 2024 6:59 pm

Video stopping recording in the middle of the Alarm

Post by mk45gti »

Hello guys!
I'm a technology enthusiast and decided to help a friend set up a camera network using zoneminder / rtmp. The configuration went well, we currently received the image and recorded it, the problem is that the alert video cuts out even when there is still movement, I have already changed several settings and even so, even when I have customers inside the store and within the detection area simply The video ends and another one starts right after, below is a screenshot of my settings and a video below:

Image

Image

Image

Image


https://youtu.be/_kDbEO-Q1xg

I already looked here on the forum and didn't find a solution, could you help me?
bbunge
Posts: 2934
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Video stopping recording in the middle of the Alarm

Post by bbunge »

Remove the 3.00 from Analysis FPS. Leave setting blank

Disable Save JPEGs. Video Writer use Camera Passthrough if you can. If you need to use Encode leave the next two to Auto.

Lower the Pre and Post event image count. 20 should work for both

Under MISC/Section Length the default is 600 seconds for max event record time. With continuous motion this value may be reached and will start another event. You may want to shorten this to 300.

Zone settings can be complicated and there is no clear recommendation other than to review the WIKI post (https://wiki.zoneminder.com/Understandi ... or_Dummies) and try different settings.

This is what I use for a 1080P cam. The active zone is about 80% of the camera area.
zone.jpg
zone.jpg (42.92 KiB) Viewed 2617 times
mk45gti
Posts: 7
Joined: Fri Feb 16, 2024 6:59 pm

Re: Video stopping recording in the middle of the Alarm

Post by mk45gti »

The event still continues to be cut in half, even with the client making movements within the detection area, with this configuration that you gave me, I was already scared with the recording quality and the file size, but even so the recording remains cut, would there be any other configuration to do?
dougmccrary
Posts: 1206
Joined: Sat Aug 31, 2019 7:35 am
Location: San Diego

Re: Video stopping recording in the middle of the Alarm

Post by dougmccrary »

Are you aware of the Options->Config->EVENT_CLOSE_MODE setting? Click on the "?" for info.
mk45gti
Posts: 7
Joined: Fri Feb 16, 2024 6:59 pm

Re: Video stopping recording in the middle of the Alarm

Post by mk45gti »

Alarm is selected
dougmccrary
Posts: 1206
Joined: Sat Aug 31, 2019 7:35 am
Location: San Diego

Re: Video stopping recording in the middle of the Alarm

Post by dougmccrary »

Alarm is selected
OK, don't you want Idle?
mk45gti
Posts: 7
Joined: Fri Feb 16, 2024 6:59 pm

Re: Video stopping recording in the middle of the Alarm

Post by mk45gti »

Your suggestion I left it marked on "Idle" and it still cut the recording at the same time, I don't know what else to do :roll:

Image
dougmccrary
Posts: 1206
Joined: Sat Aug 31, 2019 7:35 am
Location: San Diego

Re: Video stopping recording in the middle of the Alarm

Post by dougmccrary »

Hmm. It might take a restart for that setting to take effect. If you didn't already...
Or maybe it doesn't work, I've never tried to use it that way.
mk45gti
Posts: 7
Joined: Fri Feb 16, 2024 6:59 pm

Re: Video stopping recording in the middle of the Alarm

Post by mk45gti »

After changing to 'idle' detections improved a lot, they still happen to stop the video even with movement, but it decreased to 10%. Thanks to all for your help!
Post Reply