Problems with api since installing zm 1.34.16

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
bairesnetwork
Posts: 2
Joined: Wed Jul 01, 2020 5:19 am

Problems with api since installing zm 1.34.16

Post by bairesnetwork » Wed Jul 01, 2020 5:30 am

Hello, it is my first post, first of all I appreciate all possible collaboration. I'm a new Zoneminder user, I had version 1.34.15 and I also use zmninja. I use users with a password to authenticate. Since changing to Zoneminder version 1.34.16 I can no longer access it from zmninja, API error, I reinstalled the server thinking it was something that broke, but even with the clean installation of the server I cannot access it with zmninja. Someone had a similar problem or would you know how to guide me? From already thank you very much.
Attachments
zmninja_error_API_2.JPG
zmninja_error_API_2.JPG (47.46 KiB) Viewed 123 times
zmninja_error_API_1.JPG
zmninja_error_API_1.JPG (32.38 KiB) Viewed 123 times

User avatar
knight-of-ni
Posts: 2257
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Problems with api since installing zm 1.34.16

Post by knight-of-ni » Wed Jul 01, 2020 1:30 pm

Moved to the correct forum.

To troubleshoot your issue, please follow the API documentation here:
https://zoneminder.readthedocs.io/en/stable/api.html

To isolate where the problem lies, follow the examples to retrieve information using curl.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

bairesnetwork
Posts: 2
Joined: Wed Jul 01, 2020 5:19 am

Re: Problems with api since installing zm 1.34.16

Post by bairesnetwork » Wed Jul 01, 2020 5:52 pm

Excellent, thank you very much, I do the indicated steps. best regards.

davew
Posts: 6
Joined: Sat Jul 04, 2020 5:33 am

Re: Problems with api since installing zm 1.34.16

Post by davew » Sun Jul 05, 2020 2:33 am

I have the same issue and I just posted a lot of detailed information about my setup just recently. See link below.

viewtopic.php?f=40&t=29689

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest