ZM 1.32.3 Libvlc source cameras not working!!

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
wiekerein
Posts: 1
Joined: Mon Jan 13, 2020 4:00 pm

ZM 1.32.3 Libvlc source cameras not working!!

Post by wiekerein » Mon Jan 13, 2020 4:01 pm

I have just upgraded from 1.32.2 and now none of my cameras work as i use Libvlc as the source type. They all worked fine previously. Here are the debug logs i have. Any ideas?
CODE: SELECT ALL

12/29/18 09:05:26.541530 zms_m1[13410].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:26.583436 zms_m1[13410].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:26.595727 zms_m1[13410].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:26.607629 zms_m1[13410].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:28.151209 zms_m1[13434].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:28.679502 zms_m1[13434].WAR-zm_monitorstream.cpp/711 [no last_frame_sent. Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:38.708222 zms_m1[13434].ERR-zm_monitorstream.cpp/713 [Terminating, last frame sent time 10.208052 secs more than maximum of 10.000000]
12/29/18 09:05:41.839076 zms_m1[13481].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:42.372857 zms_m1[13481].WAR-zm_monitorstream.cpp/711 [no last_frame_sent. Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:43.348302 zms_m1[13486].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:43.888024 zms_m1[13486].WAR-zm_monitorstream.cpp/711 [no last_frame_sent. Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:40.472753 zms_m1[13476].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:41.010749 zms_m1[13476].WAR-zm_monitorstream.cpp/711 [no last_frame_sent. Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:51.642802 zms_m1[13499].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:51.716274 zms_m1[13499].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:51.730048 zms_m1[13499].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:51.741477 zms_m1[13499].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:53.234682 zms_m1[13504].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:53.262812 zms_m1[13504].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:53.276873 zms_m1[13504].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:53.297064 zms_m1[13504].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:54.497461 zms_m1[13510].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:54.535542 zms_m1[13510].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:54.543626 zms_m1[13510].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:54.555608 zms_m1[13510].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
CODE: SELECT ALL

12/29/18 09:04:30.461876 zmc_m1[13293].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:04:30.483814 zmc_m1[13293].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:04:45.497266 zmc_m1[13293].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:04:55.690958 zmc_m1[13354].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:04:55.781977 zmc_m1[13354].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:05:06.592335 zmc_m1[13354].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:05:28.111119 zmc_m1[13427].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:05:28.136394 zmc_m1[13427].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:05:38.218751 zmc_m1[13427].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:05:39.061059 zmc_m1[13456].I

User avatar
iconnor
Posts: 924
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: ZM 1.32.3 Libvlc source cameras not working!!

Post by iconnor » Thu Jan 16, 2020 12:13 am

I think you need to increase WATCH_MAX_DELAY in Options -> System. I use 45.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests