zmcontrol-3.sock error

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
alabamatoy
Posts: 170
Joined: Sun Jun 05, 2016 2:53 pm

zmcontrol-3.sock error

Post by alabamatoy » Fri Jan 10, 2020 5:22 pm

1.32.3 with latest version of Amcrest control script, on Ubuntu 18.04. Any attempts to execute control functions results in:

Code: Select all

Jan  9 17:37:11 servername web_php[6300]: ERR [/usr/bin/zmcontrol.pl --command=moveConDown --id=3=>]
Jan  9 17:37:11 servername zmcontrol[6746]: FAT [Can't connect: No such file or directory after 16 attempts to /var/run/zm/zmcontrol-3.sock]
No such file exists. can move continuous is selected.

What is happening, and how do I fix it?

User avatar
iconnor
Posts: 917
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zmcontrol-3.sock error

Post by iconnor » Sun Jan 12, 2020 10:59 pm

Try running it from command line to see what errors are generated

alabamatoy
Posts: 170
Joined: Sun Jun 05, 2016 2:53 pm

Re: zmcontrol-3.sock error

Post by alabamatoy » Sun Jan 12, 2020 11:29 pm

Code: Select all

[username@servername ~]# perl /usr/bin/zmcontrol.pl
"-T" is on the #! line, it must also be used on the command line at /usr/bin/zmcontrol.pl line 1.
so I tried

Code: Select all

[username@servername ~]# perl -T /usr/bin/zmcontrol.pl --id 3 --command=left
DBI::db=HASH(0x55ea5329a958)->disconnect invalidates 1 active statement handle (either destroy statement handles or call finish on them before disconnecting) at /usr/share/perl5/ZoneMinder/Database.pm line 128.
I still get

Code: Select all

Jan 12 17:25:35 servername zmcontrol[25897]: FAT [Can't connect: No such file or directory after 16 attempts to /var/run/zm/zmcontrol-3.sock]
???

User avatar
iconnor
Posts: 917
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zmcontrol-3.sock error

Post by iconnor » Thu Jan 16, 2020 12:15 am

not a lot of useful info there.

What gets logged? You might have to turn on debugging logs.

alabamatoy
Posts: 170
Joined: Sun Jun 05, 2016 2:53 pm

Re: zmcontrol-3.sock error

Post by alabamatoy » Thu Jan 16, 2020 1:14 am

Turned on debug, set level to 9 and added "_zmcontrol" for log_debug_target. zmdebug.log.11412 shows:

Code: Select all

01/15/20 19:09:45.428754 zmcontrol[11412].DBG [ZoneMinder::Logger:293] [LogOpts: level=DBG/DBG, screen=OFF, database=WAR, logfile=DBG->/var/log/zm/zm_debug.log.11412, syslog=WAR]
01/15/20 19:09:45.429021 zmcontrol[11412].DBG [main:73] [zmcontrol: arg string: --command=moveConLeft --id=3]
01/15/20 19:09:45.429659 zmcontrol[11412].INF [main:109] [Starting control server 3/amcrest_http_new]
01/15/20 19:09:45.444668 zmcontrol[11414].INF [main:136] [Control server 3/amcrest_http_new starting at 20/01/15 19:09:45]
01/15/20 19:10:00.446986 zmcontrol[11412].FAT [main:125] [Can't connect: No such file or directory after 16 attempts to /var/run/zm/zmcontrol-3.sock]
Does this shine any light on the problem?

simonpg
Posts: 11
Joined: Fri Nov 29, 2019 8:55 pm

Re: zmcontrol-3.sock error

Post by simonpg » Fri Jan 17, 2020 5:10 am

I happen to be fiddling with the Amcrest_HTTP control script. I am using version 1.33.16, so this may not be your problem at all. In 1.33.16, the Protocol is "Amcrest_HTTP", not "amcrest_http_new". Which, of course, is not a problem if there is a file named amcrest_http_new.pm in /usr/share/perl5/ZoneMinder/Control/ (That's where the script is in 1.33.16).

alabamatoy
Posts: 170
Joined: Sun Jun 05, 2016 2:53 pm

Re: zmcontrol-3.sock error

Post by alabamatoy » Fri Jan 17, 2020 3:58 pm

I changed the name of the file when this script was installed.

I hope to upgrade to 1.34 ASAP. I hope it fixes this socket issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest