HankVision Megapixel WIP6001

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.
Post Reply
papinkivi
Posts: 4
Joined: Fri Oct 11, 2019 6:51 pm

HankVision Megapixel WIP6001

Post by papinkivi » Fri Oct 11, 2019 8:12 pm

Hi,

Background

I bought unbranded NVR Kit with 9 bullet cameras from:
https://www.e-ville.com/fi/3045495-elek ... telma.html (It has 8 cameras, but otherwise it is same)
https://www.shopclues.com/hankvision-9- ... ision.html

System worked fine few months. Now the NVR hangs after few hours and its very hot. I can't get it working stable so searching ZoneMinder as a solver.

Investigations

After (three days) of investigating here are my results.

NVR

Has DHCP on LAN1 (internet), 192.168.1.9 on LAN2 and WLAN has DHCP 192.12.12.120 - 220.

Camera

### Camera label

The only label in camera says:
Wireless Wi-Fi IP Camera
Model No: WIP6001-1.3MP
Power: DC 12V
TV System: PAL 3.6mm

### Camera addresses

Camera LAN DHCP is disabled by default. LAN addresses are about 192.168.1.61 - 69. WLAN addresses are about 192.20.20.120 - 140.

### Camera ports

NMAP result is following:
PORT STATE SERVICE
23/tcp open telnet
80/tcp open http
90/tcp open dnsix
8088/tcp open radan-http
10081/tcp open famdc
20203/tcp open unknown

#### Telnet

This site helped much: https://sergei.nz/ildvr-inc-mh40d06/ And the link http://sergei.nz/ildvr-inc-mh40d06-or- ... se-camera/ says that Telnet username and password should be HANKVISION, but I had no success.

#### Web UI

Web UI respods at port 80. Username and password there are admin. It advertises itself a Megapixel IP Camera. Response server header is Hankvision-Webs. If you browse using Internet Explorer, install required AxtiveX component, you are able to view streams. Wireshark says that streams (main and sub) are requested from port 90. JPEG stills are viewable (from port 80) via Chrome without extensions. In the UI I can see following details:

##### System - Basic information

Version: V1.04.10-170307
Product info: IPC-E15000-W0 series

##### Network - PORT

RTSP Port: 554
Onvif Port: 8999
Http Port: 80
Video Port: 90
Record Port: 8080

##### Network - Wifi (which I disabled)

SSID: HD-NVR-2AFD5096
Key: 12345678

Successful results

MJPEG

Web UI has following settings for MJPEG:
Resolution: 1280x720 (default) | Closed
Frame rate: 1 | 2 | 3 (default) | 4 | 5
Image quality: Lowest | Low | Average (default) | High | Highest

### ZoneMinder settings for MJPEG

Source Type: Remote
Protocol: HTTP
Method: Simple
Host Name: admin:admin@192.168.1.6x
Port: 80
Path: /jpgimage/1/image.jpg
(Also paths /jpgmulreq/1/image.jpg?key=0&lq=11 in browser, but not in ZoneMinder.)
Capture Width (pixels): 1280
Capture Height (pixels): 720
Default for others.

Failed results

Didn't got ONVIF, RTSP or port 90 working for main or sub stream. The exact paths are unknown. I'll continue on these if I got new ideas.

I'm not sure what are the differences in brands HankVision and HkVision, because UI uses HkVision JS and DLL drivers. Also HikVision, Megapixel (UI title) and Z-Ben (https://ipcamtalk.com/threads/reviving- ... 001.39147/ see same model) may have something common.

CountyLine
Posts: 27
Joined: Thu Aug 29, 2019 5:22 pm
Location: USA

Re: HankVision Megapixel WIP6001

Post by CountyLine » Sat Oct 12, 2019 2:05 pm

Try

Code: Select all

rtsp://admin:admin@<ip address>//Streaming/Channels/1
as the RTSP path.

It's from my only HikVision camera. It's default login/password combo is admin/12345. You could substitute that in the code above, although it would be a bit strange if they used a different login than that of port 80.

User avatar
snake
Posts: 198
Joined: Sat May 21, 2016 2:20 am

Re: HankVision Megapixel WIP6001

Post by snake » Sat Oct 12, 2019 4:28 pm

Hankvision looks to be a blatant ripoff of the successful Hikvision. I don't know why anyone would purchase a camera like this. Hikvision is ok, but Hankvision...

A quick web search brings up these results on Hankvision:
https://ipcamtalk.com/threads/hankvisio ... ams.23961/
https://ipcamtalk.com/threads/beware-un ... ide.28143/
https://sergei.nz/ildvr-inc-mh40d06-sec ... re-part-2/

The images in the second link don't look like HIkvision's GUI at all.

Everything to be said about these has already been done in the above links.

papinkivi
Posts: 4
Joined: Fri Oct 11, 2019 6:51 pm

Re: HankVision Megapixel WIP6001

Post by papinkivi » Sun Oct 13, 2019 11:33 am

CountyLine wrote:
Sat Oct 12, 2019 2:05 pm
Try

Code: Select all

rtsp://admin:admin@<ip address>//Streaming/Channels/1
as the RTSP path.

It's from my only HikVision camera. It's default login/password combo is admin/12345. You could substitute that in the code above, although it would be a bit strange if they used a different login than that of port 80.
Thanks for reply! The URL doesn't work. And doesn't either login/password combo. I just realized that RTSP port 554 isn't open (according to NMAP), so I tried port 90, with no success on FFMPEG or Remote RTSP.

Can test different URLs on VLC (VideoLAN) on Windows for faster results? When I try it I get different error response on port 554 (Can't connect) and 90 (Can't open stream)

papinkivi
Posts: 4
Joined: Fri Oct 11, 2019 6:51 pm

Re: HankVision Megapixel WIP6001

Post by papinkivi » Sun Oct 13, 2019 11:40 am

snake wrote:
Sat Oct 12, 2019 4:28 pm
Hankvision looks to be a blatant ripoff of the successful Hikvision. I don't know why anyone would purchase a camera like this. Hikvision is ok, but Hankvision...

A quick web search brings up these results on Hankvision:
https://ipcamtalk.com/threads/hankvisio ... ams.23961/
https://ipcamtalk.com/threads/beware-un ... ide.28143/
https://sergei.nz/ildvr-inc-mh40d06-sec ... re-part-2/

The images in the second link don't look like HIkvision's GUI at all.

Everything to be said about these has already been done in the above links.
Thanks for your opinions! I see HankVision seems to be blatant ripoff. I bought it only based on price (9 cameras and NVR at price of 400 €) the brand was unknown before (and after) purchase. I'm sorry about that (never buy clones again). But now I wan't some returns for my investment.

The GUI in second link matches my GUI.

User avatar
snake
Posts: 198
Joined: Sat May 21, 2016 2:20 am

Re: HankVision Megapixel WIP6001

Post by snake » Sun Oct 13, 2019 4:08 pm

Did you try the two video paths from the end of the 2nd post in the first link?

You can try VLC gui or ffmpeg from command line first to get resolution, and verify the stream works. Can also try port 8080, as the post mentions. You might need to poke around the GUI to change settings, if the ports aren't open in nmap. When you get it working, then use source FFMPEG or libVLC in ZM. Testing the streams with ffmpeg would be something like:

Code: Select all

$ ffmpeg -i rtsp://user:password@<ipaddress>:554/mpeg4/ch01/main/av_stream > export.mp4

Code: Select all

$ ffmpeg -i rtsp://user:password@<ipaddress>:554/1/h264major > export.mp4
I would also try the Hankvision_2016 user/pass from the second link in telnet. If you can get shell access... See https://wiki.zoneminder.com/Finding_Camera_Stream_Paths for more reverse engineering docs.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest