CentOS 8 cannot install zoneminder

Forum for questions and support relating to the 1.32.x releases only.
VaderPrime
Posts: 3
Joined: Thu Apr 21, 2016 8:34 pm

CentOS 8 cannot install zoneminder

Post by VaderPrime » Fri Sep 27, 2019 4:09 pm

I apologize ahead of time as this is probably a simple fix that I should have caught but here is my issue. I have install installed zoneminder multiple times before successfully (its been a few years though). I did a fresh install of CentOS Linux 8 (core) today. I then proceeded to install zoneminder, referencing the official help docs but am unable to get past the install step. Below are the commands I ran.

From install guide "ZoneMinder releases are now being hosted at RPM Fusion. New users should navigate the RPM Fusion site then follow the instructions to enable that repo." I then went to the link for RPM Fusion https://rpmfusion.org/ and found and ran the following command as root in CentOS which completed successfully.
sudo yum localinstall --nogpgcheck https://download1.rpmfusion.org/free/el ... noarch.rpm https://download1.rpmfusion.org/nonfree ... noarch.rpm

From install guide "RHEL/CentOS users must also navaigate to the EPEL Site and enable that repo as well." I then navigated to the link https://fedoraproject.org/wiki/EPEL and found and ran the following commands. The first of which said nothing to do and complete.
yum install https://dl.fedoraproject.org/pub/epel/e ... noarch.rpm
yum config-manager --set-enabled PowerTools

From install guide "Once enabled, install ZoneMinder from the commandline:
sudo dnf install zoneminder
Note that RHEL/CentOS 7 users should use yum instead of dnf." I then ran the following command
sudo yum install zoneminder

The response I get is:

[root@localhost ~]# sudo yum install zoneminder
Last metadata expiration check: 0:21:27 ago on Fri 27 Sep 2019 10:47:07 AM CDT.
No match for argument: zoneminder
Error: Unable to find a match

I appreciate any help I can get on this issue. I'v been unable to find a fix in forums/wikis/help docs.

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Fri Sep 27, 2019 7:31 pm

These packages are missing from EPEL 8 and prevent zoneminder from being built:
DEBUG util.py:593: No matching package to install: 'perl(Net::SFTP::Foreign)'
DEBUG util.py:593: No matching package to install: 'perl(PHP::Serialization)'
DEBUG util.py:593: No matching package to install: 'perl(Sys::Mmap)'
The process of getting these missing dependencies built and into EPEL 8 will take several weeks.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Mon Nov 11, 2019 2:55 pm

UPDATE:
This took a coordinated effort with multiple fedora packagers, including myself, to get the entire Zoneminder dependency tree into EPEL8, so that Zoneminder can be built.

Zoneminder will now build on EL8. To do so locally, start with the EL7 source rpm hosted on rpmfusion, then mock build it.

However, the package will not install due to still missing packages. You can following the progress of the missing packages here:
https://bugzilla.redhat.com/show_bug.cgi?id=1770505
https://bugzilla.redhat.com/show_bug.cgi?id=1770506
https://bugzilla.redhat.com/show_bug.cgi?id=1770507

If you are felling adventurous, you can build these packages locally, install them, and then your locally built ZoneMinder package will install on your machine.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

phoner
Posts: 11
Joined: Fri Nov 15, 2019 4:00 pm

Re: CentOS 8 cannot install zoneminder

Post by phoner » Fri Nov 15, 2019 4:21 pm

When will zoneminder be available on centos 8?

Digital_Warrior
Posts: 2
Joined: Sun Dec 15, 2019 8:14 pm

Re: CentOS 8 cannot install zoneminder

Post by Digital_Warrior » Sun Dec 15, 2019 8:21 pm

Looks like the dependency's have been completed. How long till zone minder is in the repo.

knight-of-ni wrote:
Mon Nov 11, 2019 2:55 pm
UPDATE:
This took a coordinated effort with multiple fedora packagers, including myself, to get the entire Zoneminder dependency tree into EPEL8, so that Zoneminder can be built.

Zoneminder will now build on EL8. To do so locally, start with the EL7 source rpm hosted on rpmfusion, then mock build it.

However, the package will not install due to still missing packages. You can following the progress of the missing packages here:
https://bugzilla.redhat.com/show_bug.cgi?id=1770505
https://bugzilla.redhat.com/show_bug.cgi?id=1770506
https://bugzilla.redhat.com/show_bug.cgi?id=1770507

If you are felling adventurous, you can build these packages locally, install them, and then your locally built ZoneMinder package will install on your machine.

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Tue Dec 17, 2019 3:20 am

Patience, grasshopper. This stuff takes time.

Yes, the dependencies are cleared because I was the one who cleared them.
That paved the way for another attempt to build zoneminder for el8 in the rpmfusion build system.... which failed.

The latest problem was with the build system itself. I found a solution then notified the rpmfusion repo admins, who fixed the problem this morning.

Zoneminder finally built successfully:
http://koji.rpmfusion.org/koji/buildinfo?buildID=13291

The admins usually collect built packages once a week and push them to testing.
When that happens, zoneminder will be mentioned in the weekly RPMFusion Update Report shown here:
https://lists.rpmfusion.org/archives/li ... usion.org/

The package will sit in testing for 1-2 weeks, probably 1. When it reaches stable, it will show up in the next RPMFusion Update Report.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Fri Dec 20, 2019 6:20 pm

FYI:
https://lists.rpmfusion.org/archives/li ... XEQP7JKNO/

You may need to wait 24 hours for the rpmfusion mirrors to sync.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Digital_Warrior
Posts: 2
Joined: Sun Dec 15, 2019 8:14 pm

Re: CentOS 8 cannot install zoneminder

Post by Digital_Warrior » Sat Dec 21, 2019 1:48 am

@Knight-of-ni

Thank you, you rock.

ejpb
Posts: 2
Joined: Thu Jan 16, 2020 10:11 am

Re: CentOS 8 cannot install zoneminder

Post by ejpb » Thu Jan 16, 2020 10:46 am

Hi. I tried to install now but I cannot complete the installation.

Code: Select all

Error:
 Problem: package zoneminder-1.32.3-4.el8.x86_64 requires zoneminder-common(x86-64) = 1.32.3-4.el8, but none of the providers can be installed
  - package zoneminder-common-1.32.3-4.el8.x86_64 requires libvlc.so.5()(64bit), but none of the providers can be installed
  - package zoneminder-common-1.32.3-4.el8.x86_64 requires vlc-core, but none of the providers can be installed
  - conflicting requests
  - nothing provides libssh2.so.1()(64bit) needed by vlc-core-1:3.0.9-22.el8.x86_64
It seems libssh2 is available for CentOS 8.0.1905, but not for 8.1.1911, so I guess one has to wait and see if it gets added?

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Thu Jan 16, 2020 1:40 pm

Looks like a packaging bug against vlc-core in RPMFusion. Nothing we can do about that here.

The place to get this resolved is RPMFusion bugzilla.
File a ticker here: https://bugzilla.rpmfusion.org/

Or you can try asking in the RPMFusion devel list:
https://lists.rpmfusion.org/archives/li ... usion.org/
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Sat Jan 18, 2020 5:44 pm

More bad news. Our friends from Redhat appear to have intentionally removed the libssh2 package from RHEL 8.1. This is what is causing vlc to fail to install, which in turn causes ZoneMinder to fail to build or install.

I've created a bug to track this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1792625

Until this is resolved, your choices are to wait some more or build your own zoneminder package, after manually fetching libssh2.

Best guess, this is going to take at least 2-3 weeks to get libssh2 into EPEL repos, and that assumes the libssh2 package maintainer reacts quickly.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Sat Jan 18, 2020 7:30 pm

...And just when it seemed all was lost, Nicolas over in RPMFusion pulled libssh2 support from the vlc package. Sweet.

With that change, I was able to successfully build ZoneMinder for el8:
http://koji.rpmfusion.org/koji/taskinfo?taskID=379786

New vlc and zoneminder packages will be pushed to RPMFusion testing in a day or so, following that, expect another week before they show up in RPMFusion stable.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

credulous11
Posts: 2
Joined: Thu Jun 09, 2016 7:43 pm

Re: CentOS 8 cannot install zoneminder

Post by credulous11 » Tue Mar 31, 2020 8:40 pm

I realise this thread goes back a bit, but I have just come to install zoneminder on Centos8 and am getting the following ..

Code: Select all

[swilson@harpo ~]$ sudo dnf install zoneminder
[sudo] password for swilson: 
Last metadata expiration check: 0:08:27 ago on Tue 31 Mar 2020 21:28:47 BST.
Error: 
 Problem: package zoneminder-1.34.5-1.el8.x86_64 requires zoneminder-common(x86-64) = 1.34.5-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(DateTime) needed by zoneminder-common-1.34.5-1.el8.x86_64
  - nothing provides perl(Data::UUID) needed by zoneminder-common-1.34.5-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[swilson@harpo ~]$ cat /etc/redhat-release 
CentOS Linux release 8.1.1911 (Core) 
[swilson@harpo ~]$
I can't find these dependencies in EPEL.

Thanks

Steve

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: CentOS 8 cannot install zoneminder

Post by knight-of-ni » Sat Apr 04, 2020 1:05 am

Those packages are in the PowerTools repo, which is a new "feature" of CentOS 8:

Code: Select all

[abauer@vcentos ~]$ repoquery -i perl-Data-UUID
Last metadata expiration check: 0:00:47 ago on Fri 03 Apr 2020 08:00:24 PM CDT.
Name         : perl-Data-UUID
Version      : 1.221
Release      : 10.el8
Architecture : x86_64
Size         : 31 k
Source       : perl-Data-UUID-1.221-10.el8.src.rpm
Repository   : PowerTools
Summary      : Globally/Universally Unique Identifiers (GUIDs/UUIDs)
URL          : http://search.cpan.org/dist/Data-UUID/
License      : BSD and MIT
Description  : [deleted for brevity]

[abauer@vcentos ~]$ repoquery -i perl-DateTime
Last metadata expiration check: 0:00:59 ago on Fri 03 Apr 2020 08:00:24 PM CDT.
Name         : perl-DateTime
Epoch        : 2
Version      : 1.50
Release      : 1.el8
Architecture : x86_64
Size         : 147 k
Source       : perl-DateTime-1.50-1.el8.src.rpm
Repository   : PowerTools
Summary      : Date and time object for Perl
URL          : https://metacpan.org/release/DateTime
License      : Artistic 2.0
Description  : [deleted for brevity]
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

allanhitch
Posts: 2
Joined: Thu Nov 29, 2018 6:35 pm

Re: CentOS 8 cannot install zoneminder

Post by allanhitch » Wed Apr 15, 2020 12:07 am

I'm lost.....
I can't get it to install
:(

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests