Api - 404 error

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
andyinno
Posts: 1
Joined: Sat Aug 31, 2019 11:45 am

Api - 404 error

Post by andyinno » Sat Aug 31, 2019 11:53 am

Hi everybody,

it's two days that I am reading everything related to zoneminder without finding what is going wrong.

I installed zoneminder v1.32.3 on a raspberry pi with raspbian buster light. I configured the camera and I can see it in the browser.

I now want to connect to it using the api.

The problem I facing is that the tests that I read on the net asks to view a json reply under the api folder.
The request is getting me a 404 reply.

Checking apache logs give me no more information. Just what it is in the browser.

I can browse my zm/api/ folder via browser and I see "Release Notes for CakePHP 2.10.11"

everything is green except for "DebugKit is not installed. It will help you inspect and debug different aspects of your application.
You can install it from GitHub"

Any ideas about how to go over this?
thank you in advance

sjoerd
Posts: 2
Joined: Sun Sep 01, 2019 2:37 pm

Re: Api - 404 error

Post by sjoerd » Sun Sep 01, 2019 2:45 pm

andyinno wrote:
Sat Aug 31, 2019 11:53 am
The problem I facing is that the tests that I read on the net asks to view a json reply under the api folder.
The request is getting me a 404 reply.

I have exactly the same problem :(
Also V1.32.a on RaspBerry PI.

Have looked around using Google, updated htaccess file as adviced but no success.
What should we do?

bbunge
Posts: 2430
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Api - 404 error

Post by bbunge » Mon Sep 02, 2019 2:05 am

Switch to Ubuntu 18.04 preload server for the Pi. Arm64 or armhf works.
If you use ZM from the master PPA video writing even works!

sjoerd
Posts: 2
Joined: Sun Sep 01, 2019 2:37 pm

Re: Api - 404 error

Post by sjoerd » Tue Sep 03, 2019 8:44 am

MY ZoneMinder API is now working on Raspbian Debian Buster!

I replaced my config in:
/etc/apache2/conf-available/zoneminder.conf

with this one:
felixr wrote:
Tue Sep 03, 2019 12:50 am
ZM 1.32.3 is working for me on Debian 10 with the following configuration for apache 2.4 (zoneminder.conf)
Thanx Felixr for sharing!

felixr
Posts: 21
Joined: Tue Aug 13, 2013 2:14 pm

Re: Api - 404 error

Post by felixr » Tue Sep 03, 2019 9:09 pm

Glad I could help.

sivik
Posts: 1
Joined: Fri Oct 11, 2019 4:53 pm

Re: Api - 404 error

Post by sivik » Fri Oct 11, 2019 7:05 pm

What the configuration change that you made? There is nothing there. My api page works but if I go to check the getversion, it gives the 404 that seems to match what is going on here.

kitkat
Posts: 76
Joined: Sun Jan 27, 2019 5:17 pm

Re: Api - 404 error

Post by kitkat » Sat Oct 12, 2019 3:48 pm

sivik wrote:
Fri Oct 11, 2019 7:05 pm
What the configuration change that you made? There is nothing there. My api page works but if I go to check the getversion, it gives the 404 that seems to match what is going on here.
Here's the original post: viewtopic.php?f=38&t=28460#p111773

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests