2 equal cams

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Heimo
Posts: 13
Joined: Sat Mar 15, 2014 10:41 pm

2 equal cams

Post by Heimo » Fri Jul 26, 2019 4:58 pm

Good afternoon everybody,

perhaps somebody can help me.

I changed to Raspberry pi 4 with raspbian and zoneminder 1.32.3 and got a Problem I never had.

I am working with 2 equal cams (Foscam FI 9826W), but only 1 cam is working. They are ok, because I get an image from both in another tool. Sometime the first is working, sometimes the other.

I tried VLans, Groups, different ports, it does not work.

Has anybody an idea?

Thanks a lot.

Kind regards.

Heimo

Baylink
Posts: 330
Joined: Sun Jun 19, 2005 3:19 am

Re: 2 equal cams

Post by Baylink » Tue Jul 30, 2019 6:10 pm

I thought I saw you get an answer to this in another board (cross-posting's frowned upon, BTW), but the answer is probably that you don't have enough shm (shared memory) for the number and size of frames configured for both cameras.

Switch both -- in both ZM and the camera -- to 640x480 by maybe 5fps, and see what happens.

Then bump up a bit at a time.

Unless it's a 2 or 4GB Pi4, you may have trouble.

Heimo
Posts: 13
Joined: Sat Mar 15, 2014 10:41 pm

Re: 2 equal cams

Post by Heimo » Fri Aug 02, 2019 7:57 pm

Thank you very much. It's a 4GB PI. I will try it after my holidays and post an answer.

Kind regards.

Heimo

Heimo
Posts: 13
Joined: Sat Mar 15, 2014 10:41 pm

Re: 2 equal cams

Post by Heimo » Thu Aug 15, 2019 8:23 am

Dear Baylink,

I have tried as you said, and it was working for a few minutes. Perhaps the shared Memory is near a border?

I will try to increase the max_framebuffers on the pi.

Thanks a lot.

Kind regards.

Heimo

Heimo
Posts: 13
Joined: Sat Mar 15, 2014 10:41 pm

Re: 2 equal cams

Post by Heimo » Fri Aug 30, 2019 6:56 am

I have tried, bt it does not work, so I will reinstall.

Thanks

Kind regards.

Heimo

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests