Stuck in Privacy Page - Can't Access Console (New Install)

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Petebacher
Posts: 2
Joined: Thu Jun 27, 2019 1:32 pm

Stuck in Privacy Page - Can't Access Console (New Install)

Post by Petebacher » Thu Jun 27, 2019 2:01 pm

Brand new install of ZM. When I click the "Submit" button on the Privacy page (regardless of whether I accept or decline Telemetry collection), the page refreshes and I'm back on the Privacy page.

Some notes:
  • I've disabled my pop-up blocker, so that shouldn't be causing my problem
Additional info:
  • ZM 1.32.3-bionic
  • Linux: Mint 19.1
  • Desktop: XFCE
  • Apache: 2.4.29-1ubuntu4.6
  • PHP: 7.2.19-0ubuntu0.18.04.1
  • My SQL: 5.7.26-0ubuntu0.18.04.1
  • Browser: Google Chrome 75.0.3770.100-1 (but I see the same thing in FireFox)
I've been running LM as my desktop and a media server for years, but have no real AMP experience.

Thanks

-Pete

Petebacher
Posts: 2
Joined: Thu Jun 27, 2019 1:32 pm

Re: Stuck in Privacy Page - Can't Access Console (New Install)

Post by Petebacher » Sun Jul 14, 2019 12:56 am

So Zoneminder has no support?

:/

User avatar
snake
Posts: 199
Joined: Sat May 21, 2016 2:20 am

Re: Stuck in Privacy Page - Can't Access Console (New Install)

Post by snake » Sun Jul 14, 2019 2:17 am

Mint is an unusual choice for ZM. Which instructions did you use to install it? You should be using the wiki guides here: https://wiki.zoneminder.com/Helpful_use ... _Procedure
See the Ubuntu specific guides.

The privacy page is loaded if ZM_SHOW_PRIVACY in the DB (zm.Config table) is set to 1. By default, the value is 1, so when you load it, and answer the prompt, it attempts to write a 0 to the privacy page, and also loads a value into ZM_TELEMETRY_DATA field in zm.Config depending on whether you said yes or no. It sounds like that 0 isn't getting written.

So you could technically hack the db field to say 0, and it should bypass it, but I have a feeling that the install process is incomplete and there will be other errors. I'd recommend following the guides above to reinstall.

Baylink
Posts: 330
Joined: Sun Jun 19, 2005 3:19 am

Re: Stuck in Privacy Page - Can't Access Console (New Install)

Post by Baylink » Sun Jul 14, 2019 5:38 pm

Indeed.

I strongly recommend -- and I recommend this having been stupid enough to not do it -- that if it's your first ZM install, you install it on a documented/supported platform, even if you have to dredge up a spare box to do that on. Once you've installed it and it works, you'll have aslightly better idea what to shoot at if you go off the beaten path, and have worse luck.

At the very least, you will know to your certain knowledge that *it does work*, and that can help a surprising amount. :-)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests