Old problem? 'Failed to set UVC probe control'

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
BobLaske
Posts: 20
Joined: Fri Oct 13, 2017 3:55 am

Old problem? 'Failed to set UVC probe control'

Post by BobLaske » Thu Mar 14, 2019 10:45 pm

I've been trying to get a Logitech, Inc. QuickCam Orbit/Sphere AF working with ZM 1.32 (Ubuntu server 18.04) but keep seeing a problem.
Looking around on the net, a lot, finds me a lot of old posts about problems relating to this error but nothing I've read has worked.

A suggestion I read was to install libv4l-0 and add this line in /usr/bin/zmdc.pl
$ENV{LD_PRELOAD} = '/usr/lib/libv4l/v4l1compat.so';

The closest I've gotten to getting it to work is by using
$ sudo rmmod uvcvideo
$ sudo modprobe uvcvideo

Which seems to allow the camera (it's LED at least) to turn on for a few moments rather than a few seconds.
At this point, I don't know what is factual or not so need to post in the forums because some of the things I'm trying seem to be from old posts so it's hard to know what has been updated or not.

Some things I see in dmesg;

[ 7679.801575] input: UVC Camera (046d:0994) as /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0/input/input10
[ 7679.801909] usbcore: registered new interface driver uvcvideo
[ 7679.801913] USB Video Class driver (1.1.1)
[ 7902.622927] usbcore: deregistering interface driver uvcvideo
[ 7906.224698] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0994)
[ 7906.240901] uvcvideo 1-3:1.0: Entity type for entity Extension 4 was not initialized!
[ 7906.240908] uvcvideo 1-3:1.0: Entity type for entity Extension 10 was not initialized!
[ 7906.240913] uvcvideo 1-3:1.0: Entity type for entity Extension 12 was not initialized!
[ 7906.240917] uvcvideo 1-3:1.0: Entity type for entity Extension 8 was not initialized!
[ 7906.240922] uvcvideo 1-3:1.0: Entity type for entity Extension 11 was not initialized!
[ 7906.240927] uvcvideo 1-3:1.0: Entity type for entity Extension 9 was not initialized!
[ 7906.240931] uvcvideo 1-3:1.0: Entity type for entity Processing 2 was not initialized!
[ 7906.240936] uvcvideo 1-3:1.0: Entity type for entity Extension 13 was not initialized!
[ 7906.240940] uvcvideo 1-3:1.0: Entity type for entity Camera 1 was not initialized!
[ 7906.241197] input: UVC Camera (046d:0994) as /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0/input/input11
[ 7906.241426] usbcore: registered new interface driver uvcvideo
[ 7906.241428] USB Video Class driver (1.1.1)
[13868.488102] uvcvideo: Failed to set UVC probe control : -110 (exp. 26).
[13886.788800] usb 1-3: reset high-speed USB device number 5 using ehci-pci
[13895.879921] uvcvideo: Failed to set UVC probe control : -110 (exp. 26).
[13906.756657] usb 1-3: reset high-speed USB device number 5 using ehci-pci

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest