After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
thoraxe
Posts: 14
Joined: Sun Jun 17, 2018 2:25 pm

After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by thoraxe » Fri Nov 09, 2018 2:10 am

Just upgraded to 1.32.2 from 1.30.x and when viewing events I notice a few issues. For example, the framerate playback and other info is displaying weirdly:

Mode: Replay Rate: 0x Progress: NaN:NaN:NaNs Zoom: 0x

It shows that for all events when I am playing them back.

I dug around in the httpd and zm logs when loading the event view page but there's no errors.

Linux dumpster.festive.local 3.10.0-862.3.3.el7.x86_64 #1 SMP Fri Jun 15 04:15:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
zoneminder 1.32.2 running in containers via podman, freshly built today (18-NOV-2018)

User avatar
iconnor
Posts: 848
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by iconnor » Fri Nov 09, 2018 4:56 pm

Try checking your javascript console... Right click anywhere, choose Inspect ELement, click on Console tab

thoraxe
Posts: 14
Joined: Sun Jun 17, 2018 2:25 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by thoraxe » Fri Nov 09, 2018 9:46 pm

No javascript errors. Here's the whole console output when the event page is loaded:

Code: Select all

zoomrotate: Start
videojs.zoomrotate.js:5 zoomrotate: Init defaults
videojs.zoomrotate.js:10 zoomrotate: Init Extend
videojs.zoomrotate.js:72 zoomrotate: End
enable-tooltip.ts:143 [Deprecation] HTML Imports is deprecated and will be removed in M73, around March 2019. Please use ES modules instead. See https://www.chromestatus.com/features/5144752345317376 for more details.
_init @ enable-tooltip.ts:143
Promise.all.then @ enable-tooltip.ts:69
Promise.then (async)
(anonymous) @ enable-tooltip.ts:64
(anonymous) @ enable-tooltip.ts:297
skins_classic_js_skin-base-1539455775.js:208 {result: "Ok", message: "	<div id="reload" class="container-fluid reduced-t…↵  </ul>↵    	↵<!-- End .footer/reload --></div>↵"}
skins_classic_js_skin-base-1539455775.js:208 {result: "Ok", message: "	<div id="reload" class="container-fluid reduced-t…↵  </ul>↵    	↵<!-- End .footer/reload --></div>↵"}

thoraxe
Posts: 14
Joined: Sun Jun 17, 2018 2:25 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by thoraxe » Thu Nov 15, 2018 8:20 pm

Guess I'll file a bug. Thanks!

B F
Posts: 22
Joined: Sat May 05, 2012 5:06 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by B F » Wed Jan 02, 2019 9:26 pm

I have exactly the same issues going from 1.30.x to 1.32.2 in both Firefox & Chrome. Also some odd behaviour in which played back events (JPG) just zoom through no matter what setting I use for WEB_H_DEFAULT_RATE or sometimes they never even start playing. Bit stuck how to debug this one as there's nothing in the logs.

rockedge
Posts: 1110
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by rockedge » Thu Jan 03, 2019 12:13 am

try an upgrade to 1.32.3
It runs smoother for me than 1.32.2 does.

B F
Posts: 22
Joined: Sat May 05, 2012 5:06 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by B F » Thu Jan 03, 2019 7:33 am

Sorry my bad, it is ZoneMinder v1.32.3 I upgraded to. I wonder if there's a step I missed or incorrectly made during the upgrade. Odd how it just whizzes through all the events at the rate of about one minute per second. Unfortunately it's quite unusable now.

Sabby
Posts: 4
Joined: Thu Jan 24, 2019 3:55 am

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by Sabby » Thu Jan 24, 2019 3:57 am

I am now getting the same exact thing, after the update to 1.32.3
1-Capture.PNG
1-Capture.PNG (1.07 KiB) Viewed 3158 times
2-Capture.PNG
2-Capture.PNG (49.75 KiB) Viewed 3158 times
Sad part, any archived video saved is corrupted too.

Sabby
Posts: 4
Joined: Thu Jan 24, 2019 3:55 am

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by Sabby » Thu Jan 24, 2019 1:08 pm

JS console doesn't show anything and no errors int he logs.

Sabby
Posts: 4
Joined: Thu Jan 24, 2019 3:55 am

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by Sabby » Thu Jan 24, 2019 2:22 pm

Just a note, I replaced the entire www folder in /usr/share/zoneminder with the web folder from the 1.32.2 archive, problem resolved I can view recorded events now. So whatever is wrong, it's with the 1.32.3 update and resides somewhere in the web folder, probably with js

IMSancho
Posts: 6
Joined: Wed Oct 12, 2011 1:01 am

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by IMSancho » Mon Jan 28, 2019 11:45 am

I'm seeing the same issue on a fresh install on CentOS 7 from the RPMFusion repository. Nothing in the console, and I can watch events with the fast forward and rewind buttons, but play and pause don't work. Hitting pause makes the mode briefly flash to 'Paused' but immediately changes back to 'Replay'
Screen Shot 2019-01-28 at 9.43.25 pm.png
Screen Shot 2019-01-28 at 9.43.25 pm.png (44.29 KiB) Viewed 3063 times

bigdigiman
Posts: 1
Joined: Sat Feb 16, 2019 2:10 am

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by bigdigiman » Sat Feb 16, 2019 2:12 am

I also have the issue. I found that opening the console window and executing "playClicked();" causes the video to play.

pat2
Posts: 73
Joined: Fri Sep 16, 2016 6:35 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by pat2 » Tue Apr 09, 2019 8:56 pm

I do have the same issue. Able to see the live streaming, not able to see recorded jpeg on fresh install.

Did anyone find how to solve?

B F
Posts: 22
Joined: Sat May 05, 2012 5:06 pm

Re: After upgrade from 1.30x, seeing "NaN:NaN:NaNs" and other issues on events

Post by B F » Wed Jul 10, 2019 12:44 pm

Finally got around to trying sabby's Thu Jan 24, 2019 3:22 pm solution today but ended up with the message "MooTools not found! Please check that it was installed correctly in ZoneMinder web root".

In the end I think there was some symbolic links missing in the mootools directory because when it's like the listing below the message goes away & video can now be played. Unfortunately though the display still says "Mode: Replay Rate: 0x Progress: NaN:NaN:NaNs Zoom: 0x", but progress at least.

Code: Select all

# ls -l /usr/share/zoneminder/www/tools/mootools/
total 556
-rw-r--r-- 1 root root 173557 Jul 10 12:28 mootools-core-1.6.0-compat.js
-rw-r--r-- 1 root root     81 Jul 10 12:28 mootools-core-compat.js.URL
lrwxrwxrwx 1 root root     29 Jul 10 12:28 mootools-core.js -> mootools-core-1.6.0-compat.js
-rw-r--r-- 1 root root 385273 Jul 10 12:28 mootools-more-1.6.0.js
lrwxrwxrwx 1 root root     22 Jul 10 12:28 mootools-more.js -> mootools-more-1.6.0.js

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests