Multi-server event counts wrong

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
tcg
Posts: 41
Joined: Fri Jan 13, 2012 3:41 pm

Multi-server event counts wrong

Post by tcg » Tue Oct 09, 2018 12:30 pm

I installed 1.32.1 in a test environment yesterday to try out multi-server mode as I need to deploy a multi-server setup. I have set up four cameras with two servers. I've noticed that the event totals are incorrect for the Hour column in the console. The system has not been up long enough to know whether the Day, Week and Month columns are accurate. In the attached photo, you can see that the Hour column actually shows the total number of events for that camera. When I click in the Hour column, there is only a couple of events for each camera within the last hour. Can anyone confirm?
Attachments
console.png
console.png (48.21 KiB) Viewed 969 times
Chris

User avatar
iconnor
Posts: 1197
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Multi-server event counts wrong

Post by iconnor » Tue Oct 09, 2018 1:00 pm

It looks to me like all the events happened in the last hour.

One thing to check is that zmstats.pl is being run on at least one of your servers. It does the event counts in the background.

tcg
Posts: 41
Joined: Fri Jan 13, 2012 3:41 pm

Re: Multi-server event counts wrong

Post by tcg » Tue Oct 09, 2018 1:49 pm

So, I can confirm that all of the events did NOT happen within the last hour but instead were spread out over the last 24 hours. Also, I have zmstats running on one of the two servers but according to journalctl it hasn't run since yesterday afternoon. How often is it supposed to execute?
Chris

tcg
Posts: 41
Joined: Fri Jan 13, 2012 3:41 pm

Re: Multi-server event counts wrong

Post by tcg » Tue Oct 09, 2018 2:08 pm

It looks like zmstats.pl was not running. I restarted zoneminder and it came back and updated the totals. Thanks for your help!
Chris

bspiegel
Posts: 10
Joined: Wed Oct 22, 2014 7:54 pm

Re: Multi-server event counts wrong

Post by bspiegel » Mon Jun 08, 2020 2:03 pm

I am running zm 1.32.3 on a single xubuntu 18 server. All working well but the event totals don't seem to update.
zmstats.pl is running. When I kill zmstats, it restarts.
Status_Update_interval=60. Screen refresh is 20. Set to Hi-B/W.
If I delete events, the counts do not reset, even after waiting 5 minutes. Sometimes they do update but takes forever.
Any ideas?

User avatar
iconnor
Posts: 1197
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Multi-server event counts wrong

Post by iconnor » Mon Jun 08, 2020 9:55 pm

You don't have triggers. mysql -u zmuser -p zm < /usr/share/zoneminder/db/triggers.sql

Also, we REALLY recommend updating to 1.34

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest