Streams Don't work when OPT_USE_AUTH is enabled

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
bloke
Posts: 5
Joined: Mon Dec 11, 2017 1:32 am

Streams Don't work when OPT_USE_AUTH is enabled

Post by bloke » Mon Dec 11, 2017 1:59 am

I apologize for the long post. TLDR at the end.
I recently installed zoneminder on a webserver (we'll call it webserver1) that I already have running LAMP. I immediately made a new user and enabled authentication because... security. Oh, and the webserver is publicly accessible ;) I then set up a camera and enabled modect. Since the whole application is new to me I started clicking around but couldn't see any live streams anywhere. I did notice that events were coming through when I moved in front of the camera. I could click the event number then click frames and see images! Wohoo some functionality! I then went back to the camera's page and inspected the network and saw that cgi was having issues loading the stream. After a bit of troubleshooting in circles I decided to do a fresh install of ubuntu and zoneminder on another server (we'll call it webserver2) on the same network. Using the same camera configurations as webserver1 as well as enabling OPT_USE_AUTH I am able to see live streaming (and event stream playback) on this webserver2. So, I figured, why not uninstall zoneminder from webserver1 and reinstall it. After doing this I was able to see live streams and streaming playback!... But, I noticed that I hadn't enabled authentication. So, I went in to options and enabled OPT_USE_AUTH. Then, streaming stopped working and I began getting the same issues as before. Curious, I disabled OPT_USE_AUTH on this webserver1 and immediately was able to see streaming video again. Obviously this is not a long term solution but does validate that my initial approach to troubleshooting was pretty comprehensive.
I am now back to enabling OPT_USE_AUTH on webserver1 with streaming video not working.
Does anyone have any idea on how to resolve this?

Symptom: Chromium network inspection fails loading (Again, this does not fail if I disable OPT_USE_AUTH):
http://MYURL.com/zm/cgi-bin/nph-zms?mod ... 1512957365

I also noticed this: I must have ran "add-apt-repository ppa:iconnor/zoneminder" before installing on webserver2 as it is on ZM version 1.30.4 instead of 1.29.0 like the problem webserver1. I do not think this is relevant but who knows!?

TLDR:
On zoneminder 1.29.0 streams work when OPT_USE_AUTH is disabled but streams do not work when OPT_USE_AUTH is enabled. Can anyone help me solve this since I need to enable authentication into Zoneminder?

rockedge
Posts: 1105
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Streams Don't work when OPT_USE_AUTH is enabled

Post by rockedge » Mon Dec 11, 2017 11:13 pm

you must set Options->System->AUTH_RELAY to "None" when you have OPT_USE_AUTH enabled......see if that works. There is something going on with Hash creation and authorization ....have you set AUTH_HASH_SECRET to something?

bloke
Posts: 5
Joined: Mon Dec 11, 2017 1:32 am

Re: Streams Don't work when OPT_USE_AUTH is enabled

Post by bloke » Tue Dec 12, 2017 6:28 am

Woohoo, that worked! Thanks! I had not changed the AUTH_HASH_SECRET from the default "...Change me to something unique...".

Is there any security threat to not enabling AUTH_REPLAY? Is that just used to separate access at the filesystem level?

rockedge
Posts: 1105
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Streams Don't work when OPT_USE_AUTH is enabled

Post by rockedge » Fri Dec 15, 2017 3:24 pm

the setting determines how the URL reaches the streams and passes the login/authority info back to ZM.....I sometimes set it None when I embed ZM monitor streams in other web pages....but I would use Hashed if there is no reason directly to use "None".

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests