Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 8:02 am

Hi all,

I am trying to test out RTSP streams of 720p cameras before I add them to my production system. I created a fresh build of Debian 7 with a fresh pull (20 minutes old!) of 1.28.100 from github; got all the dependencies installed, etc.

However, I am unable to get ffmpeg or libvlc streams to work. If I try to setup ffmpeg, I get the following error:

Code: Select all

Unable to open input rtsp://user:pass@xx.xx.xx.xx/videoMain due to: Operation now in progress
I've tried both with videoMain and videoSub; I've tried with port 80, 88, 554 - nope, no go.

I then tried using libvlc and instead I get this:

Code: Select all

2015-07-31 00:58:23.460110	zmdc	14689	ERR	'zmc -m 1' exited abnormally, exit status 255	zmdc.pl	
2015-07-31 00:58:23.431988	zmc_m1	15431	FAT	Unable to create libvlc instance due to: (null)	zm_libvlc_camera.cpp	170
Also - shell exploded with the following syslog messages:

Code: Select all

Jul 31 00:58:43 zoneminder in libvlc error:
Jul 31 00:58:43 zoneminder  plugins found! Check your VLC installation.

These are my current VLC libs:

Code: Select all

ii  libvlc-dev                         2.0.3-5+deb7u2+b1                  amd64        development files for libvlc
ii  libvlc5                            2.0.3-5+deb7u2+b1                  amd64        multimedia player and streamer library
ii  libvlccore-dev                     2.0.3-5+deb7u2+b1                  amd64        development files for libvlccore
ii  libvlccore5                        2.0.3-5+deb7u2+b1                  amd64        base library for VLC and its modules
ii  vlc-data                           2.0.3-5+deb7u2                     all          Common data for VLC
And - ffmpeg version (although something tells me this is... old :( ); of this is an invalid version - please let me know which one would be best for Debian 7.

Code: Select all

ffmpeg 0.8.17-6:0.8.17-1
libavutil    51. 22. 3 / 51. 22. 3
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 1 / 53. 21. 1
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0


Thanks in advance!

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 5:24 pm

Hopefully someone else has been in my shoes and got it to work :(

User avatar
knight-of-ni
Posts: 2217
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by knight-of-ni » Fri Jul 31, 2015 7:02 pm

Long time ago, I had to upgrade my ffmpeg as well to get Foscams to work. I think I was on 0.8 at the time so yeah I'd upgrade your ffmpeg.

Since you are using debian, you have the added complexity of having to deal with libav. If you've got libav installed, you need to verify your system is finding ffmpeg before libav, otherwise it'll still be using libav for function calls regardless of what version of ffmpeg you have installed.

I can't tell if your VLC is complaining it can't find any plugins at all, or just the specific plugin needed to transcode the video from your camera. I'm not familiar with Debian packaging, but I would look for any additional vlc packages not already installed. VLC 2.0.3 is a bit old too.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 7:34 pm

knnniggett wrote:Long time ago, I had to upgrade my ffmpeg as well to get Foscams to work. I think I was on 0.8 at the time so yeah I'd upgrade your ffmpeg.

Since you are using debian, you have the added complexity of having to deal with libav. If you've got libav installed, you need to verify your system is finding ffmpeg before libav, otherwise it'll still be using libav for function calls regardless of what version of ffmpeg you have installed.

I can't tell if your VLC is complaining it can't find any plugins at all, or just the specific plugin needed to transcode the video from your camera. I'm not familiar with Debian packaging, but I would look for any additional vlc packages not already installed. VLC 2.0.3 is a bit old too.

I do indeed have libav installed; looks like standard install. Any idea how to check whether libav is circumventing ffmpeg?

And I'll look into upgrading VLC as well, however all of these are stock debian packages. Perhaps I am better off trying this out on Ubuntu?

Thanks!

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 9:20 pm

OK - progress! It looks like the 9820 uses a non standard URL... nevertheless I got it to stream. However - only when using ASF and mpeg; when using SWF and mpeg - I get a blank screen.

Any ideas?

Thanks!

User avatar
knight-of-ni
Posts: 2217
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by knight-of-ni » Fri Jul 31, 2015 9:27 pm

Have you looked in the WiKi for Foscams?

This is url I use for my Foscam 9821:

Code: Select all

rtsp://username:password@192.168.1.81:88/videoMain
videoMain is case sensitive

my 9821 works with either a source type of foscam and remote/rtsp.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 9:35 pm

knnniggett wrote:Have you looked in the WiKi for Foscams?

This is url I use for my Foscam 9821:

Code: Select all

rtsp://username:password@192.168.1.81:88/videoMain
videoMain is case sensitive

my 9821 works with either a source type of foscam and remote/rtsp.

That URL does not appear to work for the 9820; I have to use the following one:

Code: Select all

rtsp://user:pass@192.168.1.81:554/11
With that, I can stream using asf in IE (but not without complaints regardless of whether i use ffmpeg or libvlc).

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Foscam FI9820 + Fresh install of 1.28.100 = no rstp :(

Post by McFuzz » Fri Jul 31, 2015 9:54 pm

I am onto something... If I use my non HD cameras, mpeg + swf works fine. Once I try to use the high def camera - which btw works fine if i do jpeg streaming now (needed libjpeg-turbo), i see this:

Code: Select all

getStreamCmdResponse stream error: socket_sendto( /tmp/zm/zms-156891s.sock ) failed: Connection refused - checkStreamForErrors()]

Ideas?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests