Thousands of Blue Screen events on remote IP cameras

Forum for questions and support relating to the 1.25.x releases only.
jonathancnewcomb
Posts: 38
Joined: Tue Sep 18, 2012 2:00 pm

Re: Thousands of Blue Screen events on remote IP cameras

Post by jonathancnewcomb » Sun Feb 03, 2013 5:17 pm

Hello, I am a network engineer, I had a similar problem and I found that TCP retransmissions were the root cause of the problem. You can validate this by installing tcpdump and tcptrace on your linux box (look for them in your package manager) then use the following filter:

Code: Select all

$ tcpdump -i [interface] -w dump.out port 80
Let this run until you catch a loss of signal, then evaluate using tcptrace:
Use CTRL+C to break

Note: You should see "X packets received by filter" where X is > 0

Code: Select all

$ tcptrace dump.out
Now then, you will see a list of TCP streams that were captured, there will be a number associated. Find the number next to the stream for your camera and replace the "#" below with that number:

Code: Select all

$ tcptrace -r -l -o# dump.out
You will see values in the output such as RTT and max # retrans, ensure that your RTT is below 150ms and the number of retransmissions are close to 0 (this will vary depending on capture time). Also, you will see throughput used by the stream, ensure your switch is capable of handling the load. All switches have maximum throughput and you may have to take that into account too.

mmike
Posts: 4
Joined: Tue May 23, 2017 1:41 am

Re: Thousands of Blue Screen events on remote IP cameras

Post by mmike » Mon Jul 31, 2017 3:45 am

netwrkr wrote:
Tue May 01, 2012 2:25 pm
Similar issue here - I resolved it by removing any settings in "Maximum FPS" for each camera. HTH
Same problem, this fixed the issue. I also removed the Alarm Maximum FPS also to see what happens.

Vladyck
Posts: 1
Joined: Thu Jan 31, 2019 9:31 am

Re: Thousands of Blue Screen events on remote IP cameras

Post by Vladyck » Thu Jan 31, 2019 9:37 am

I had same problem. decreasing FPS & quality on camera appropriate to monitor`s settings / network bandwidth has resolved this

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests