problem after upgrade to 1.26.4

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
topromotion
Posts: 22
Joined: Mon Aug 12, 2013 3:18 pm

problem after upgrade to 1.26.4

Post by topromotion » Mon Nov 18, 2013 9:31 pm

Hello!

After upgrading from 1.25.0 to 1.26.4 i have a problem - all monitors stay a red color in list, and in log lots of error like that:

Memory map file '/dev/shm/zm.mmap.20' should have been 896 but was instead 0
Can't run query: Unknown column 'Colours' in 'field list'
'zma -m 21' exited abnormally, exit status 30

I use a Dlink ip camera dcs-932l, its works through http.

chippy99
Posts: 66
Joined: Wed Aug 30, 2006 5:38 pm
Location: Barnet, Herts. UK

Re: problem after upgrade to 1.26.4

Post by chippy99 » Tue Nov 19, 2013 1:19 am

Did you run zmupdate.pl to update the database ? It seems to be complaining about a missing column in your database.

topromotion
Posts: 22
Joined: Mon Aug 12, 2013 3:18 pm

Re: problem after upgrade to 1.26.4

Post by topromotion » Tue Nov 19, 2013 6:49 am

Yes, i am run a zmupdate.pl, and upgrading of db pass succesfuly/

topromotion
Posts: 22
Joined: Mon Aug 12, 2013 3:18 pm

Re: problem after upgrade to 1.26.4

Post by topromotion » Tue Nov 19, 2013 6:57 am

i have another pc with zoneminder 1.25.0, in /dev/shm/ have a several files like zm.mmap.10, zm.mmap.11. But after update this files disappeared

chippy99
Posts: 66
Joined: Wed Aug 30, 2006 5:38 pm
Location: Barnet, Herts. UK

Re: problem after upgrade to 1.26.4

Post by chippy99 » Tue Nov 19, 2013 2:34 pm

Clutching at straws but have you set monitor colour space to 32 bit ?

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: problem after upgrade to 1.26.4

Post by mastertheknife » Tue Nov 19, 2013 2:37 pm

Hi,

Execute the SQL statements below to fix this manually:

Code: Select all

ALTER TABLE `Monitors` ADD `Colours` TINYINT UNSIGNED NOT NULL DEFAULT '1' AFTER `Height`;
ALTER TABLE `Monitors` ADD `Deinterlacing` INT UNSIGNED NOT NULL DEFAULT '0' AFTER `Orientation`
Kfir Itzhak.

topromotion
Posts: 22
Joined: Mon Aug 12, 2013 3:18 pm

Re: problem after upgrade to 1.26.4

Post by topromotion » Tue Nov 19, 2013 2:42 pm

mastertheknife wrote:Hi,

Execute the SQL statements below to fix this manually:

Code: Select all

ALTER TABLE `Monitors` ADD `Colours` TINYINT UNSIGNED NOT NULL DEFAULT '1' AFTER `Height`;
ALTER TABLE `Monitors` ADD `Deinterlacing` INT UNSIGNED NOT NULL DEFAULT '0' AFTER `Orientation`
Thank you! Its works for me! =)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests