Foscam FI9821W

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.
Post Reply
gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Foscam FI9821W

Post by gmar_87 » Fri Apr 05, 2013 2:03 am

Has anyone tried the new Foscam FI9821W HD cameras with Zoneminder?

http://www.foscamaustralia.com.au/All-F ... r-Warranty

Are they compatible?
Any known issues?
Any reviews?

This new model has megapixel display, ir cut filter, 30fps, H.264 compression.

Cheers,
John

gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Re: Foscam FI9821W

Post by gmar_87 » Sun Apr 14, 2013 3:20 am

Couldn't wait any longer... Purchased a Foscam FI9821W and now trying to get this working with my existing ZoneMinder 1.25 set up on Ubuntu 11.04.

The FI9821W must be running firmware 1.1.1.11 or higher. I wasted a lot of time trying to make this work only to discover RTSP has only been enabled in firmware 1.1.1.11 which was released 18th March 2013. See official Foscam release notes and download link here - http://foscam.us/blog/foscamipcameras/f ... v1-1-1-11/

RTSP for the Foscam FI9821W uses the camera's HTTP port and has 3 streams:
1. videoMain - main streaming
2. videoSub - sub streaming
3. audio - audio streaming

The RTSP URL for the Foscam FI9821W is:
rtsp://username:password@ipaddress:port/stream

(e.g.) rtsp://admin:admin123@192.168.1.10:80/videoMain

I have changed HTTP port to 80 via the the camera's web interface settings, as the HTTP port for my camera was running on port 88 instead of 80 out of the box. The Media port is 888 out of the box and i have left it as is.

Here is my current working config:
Source type: FFMPEG
Source path: rtsp://username:password@ipaddress:port/videoMain
Source colours: 24 bit
Capture width: 1280
Capture height: 720

I am not sure if this is normal, but I am not able to set control scripts when using FFMPEG (the Control Type drop down list is empty)... If the source type is set to "remote" i can define control scripts, but i haven't been able to get the FI9821W to work with source type of "remote".

Remote source type config (not working):
Source type: Remote
Remote protocol: RTSP
Remote Method: RTP/RTSP
Remote host name: username:password@ipaddress
Remote host port:80
Remote host path: /videoMain
Remote image colours: 24 bit
Capture width: 1280
Capture height: 720

When i use the above "remote" config i get the following errors in the logs:
- ERR [Unexpected response code 401, text is 'Unauthorized']
- ERR [Unexpected response code 404, text is 'Stream Not Found']

Looks like ZoneMinder isn't authenticating properly with the FI9821W... Is RTSP authentication working in 1.25?

I am starting to work on a control script for the FI9821W - hopefully have this done in a week or two (not much time at the moment)..
CGI/SDK for the Foscam FI9821W can be found here - http://foscam.us/forum/cgi-sdk-for-fi98 ... t4010.html

Cheers,
John

gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Re: Foscam FI9821W

Post by gmar_87 » Mon Apr 15, 2013 3:29 am

I have released my control script here - http://www.zoneminder.com/forums/viewto ... =9&t=20984

gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Re: Foscam FI9821W

Post by gmar_87 » Thu Apr 25, 2013 6:49 am

I have been experiencing stability issues with the FI9821W using RTSP stream over Wi-Fi.. Seems to be a firmware issue at this stage.
There is a full list of reported issues and discussion about this camera can on the Foscam forums - http://foscam.us/forum/fi9821w-issue-list-t3967.html
I upgraded the firmware to 1.1.1.12 and Wi-Fi connectivity got worse! I had to replace the camera with the old FI8918W until Foscam release fixes.
Some users have reported the camera works fine when wired.

gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Re: Foscam FI9821W

Post by gmar_87 » Thu Apr 25, 2013 6:55 am

Camera can also be used in MJPEG mode like the older Foscam cameras - http://foscam.us/forum/how-to-fetch-sna ... t4328.html

chaoticmachinery
Posts: 8
Joined: Sat Apr 20, 2013 9:59 pm

Re: Foscam FI9821W

Post by chaoticmachinery » Thu Apr 25, 2013 11:47 am

Just to add to this. The RTSP stream requires Digest authentication. Looking at the zoneminder code, it does not currently support Digest authentication.

-CM

oranjeboven
Posts: 1
Joined: Mon May 20, 2013 12:38 pm

Re: Foscam FI9821W

Post by oranjeboven » Mon May 20, 2013 12:54 pm

Hey,

I have tried about everything under the sun to get my fi9821w cam working. Current state of play:
- Ubuntu version 10.04 (running on a cubox)
- ZoneMinder version 1.24.2
- foscam fi9821w firmware 1.1.1.12

ZM keeps showing my monitor source in red and when I select the monitor it doesn't show an image at all.

However, the following URL works fine in any browser (I had to put spaces in http otherwise I couldn't submit the post):
h t t p://10.1.1.5:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=guest&pwd=

In ZM, I configured the monitor as follows:
General Tab:
sourceType=remote
function=Monitor

SourceTab:
protocol = http
method = simple
hostname = 10.1.1.5
port = 88
path = /cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=guest&pwd=



This works in a Browser as well:
h t t p://10.1.1.5:88/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=guest&pwd=

but configuring this in ZM doesn't work:
sourceType = ffmpeg
sourcepath = /cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=guest&pwd=

(note the source path field can't hold enough characters to store the entire URL so I "linked" it to the a second monitor with the correct ip address/port etc, but not sure if this is coming through correctly)



Anybody any ideas?

cheers,

H.

jb17bsome
Posts: 1
Joined: Sat May 25, 2013 3:16 pm

Re: Foscam FI9821W

Post by jb17bsome » Sat May 25, 2013 3:27 pm

I am not sure if the ffmpeg mode will work with the mjpeg option. The reason being that ffmpeg needs to know the input stream type. Maybe you already figured this out?

I was able to get ffmpeg to work at the command line using using:
ffplay -f mjpeg -i "url-hostnamepart/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=user&pwd=pwd"

In any case I am just using the camera in snapPicture2 mode. It does have a low frame rate (4 fps) but that is good enough for my needs. I can also configure it for rtsp and use the mainStream or subStream to get a higher fps.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests