ZoneMinder linux/windows/mac/*nix client Qt Viewer

If you've made a patch to quick fix a bug or to add a new feature not yet in the main tree then post it here so others can try it out.
timgman
Posts: 46
Joined: Wed Mar 14, 2007 6:01 pm

Postby timgman » Mon Feb 11, 2008 2:16 pm

With a nice gui this app would revoloutionize the DVR/Secutiry world.

Lee Sharp
Posts: 1059
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Postby Lee Sharp » Thu May 29, 2008 3:08 pm

zoneminder wrote:I think the main reason that ZM doesn't have a standalone GUI interface is that (a) I don't know any GUI libraries and (b) all my Linux boxes are headless so I never see or use Gnome or KDE and their ilk.

I agree with you, but those damn customers keep asking for it... ;) I am playing with all of these (this one, xlib_shm...) to see what is the most stable and with the lightest load. Reports to follow, some day.

timcraig
Posts: 195
Joined: Mon Dec 10, 2007 5:53 pm
Location: San Jose, CA
Contact:

Postby timcraig » Fri May 30, 2008 6:13 pm

I gave it a try on Ubuntu 8.04 with your hardy .deb.

zmviewer loaded at first fine. I then entered my Zoneminder's database information in the settings and it then crashed with the following message:

Code: Select all

zmviewer: symbol lookup error: /usr/lib/libzmviewercore.so: undefined symbol: _Z7qstrcmpRK10QByteArrayPKc


Now when I try to start the app again it crashes with the same error message.

I'll try a source install this weekend.

timcraig
Posts: 195
Joined: Mon Dec 10, 2007 5:53 pm
Location: San Jose, CA
Contact:

Postby timcraig » Mon Jun 02, 2008 4:05 am

Source install works on Ubuntu 8.04. There was a problem with not finding the zmviewercore library.

I then fix the problem with:

Code: Select all

ln -s /usr/local/lib/libzmviewercore.so /usr/lib/libzmviewercore.so

lopezlean
Posts: 14
Joined: Mon May 21, 2007 2:03 pm
Location: Argentina
Contact:

Postby lopezlean » Tue Jun 03, 2008 10:51 pm

timcraig wrote:I gave it a try on Ubuntu 8.04 with your hardy .deb.

zmviewer loaded at first fine. I then entered my Zoneminder's database information in the settings and it then crashed with the following message:

Code: Select all

zmviewer: symbol lookup error: /usr/lib/libzmviewercore.so: undefined symbol: _Z7qstrcmpRK10QByteArrayPKc


Now when I try to start the app again it crashes with the same error message.

I'll try a source install this weekend.

This error was caused because when I built zmviewer for hardy, hardy was beta and Qt's version has changed since it became stable
Leandro Emanuel López

lopezlean
Posts: 14
Joined: Mon May 21, 2007 2:03 pm
Location: Argentina
Contact:

Postby lopezlean » Wed Jul 16, 2008 1:18 pm

Hello, I've just released a preview version of the new zmviewer GUI for testing purposes.

At the moment, only source code and Ubuntu packages are available for download, in the next few days I will be releasing a Windows binary.

This new version has a lot of bug fixes and improvements:

* a new revamped UI
* support for hashed authentication
* new multiple cams layouts
* cameras shortcuts
* bandwidth usage optimization

I think this GUI is far more pretty that the older one and has a big usability improvement.
Leandro Emanuel López

coke
Posts: 518
Joined: Wed Jan 30, 2008 5:53 pm
Location: St. Louis, MO, USA

Postby coke » Wed Jul 16, 2008 3:46 pm

Anxious to try, but it's telling me "access denied for database @", have tried both my zm users and mysql users. The "driver" section is blank on the "more" tab, is that relevant?

coke
Posts: 518
Joined: Wed Jan 30, 2008 5:53 pm
Location: St. Louis, MO, USA

Postby coke » Wed Jul 16, 2008 4:14 pm

ok, an

Code: Select all

apt-get install libqt4-sql-mysql
solved that problem, now it's running dandy. (Technically, I used synaptic, but I imagine either would do the trick).

Update: Ok, this looks cool. Definitely feels more boss-friendly. Can't get any events to play, though, immediately says "Event Finished".

Ubuntu 8.0.4, ZM 1.23.3

Lee Sharp
Posts: 1059
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Postby Lee Sharp » Wed Jul 16, 2008 6:25 pm

lopezlean wrote:Hello, I've just released a preview version of the new zmviewer GUI for testing purposes.

This new version has a lot of bug fixes and improvements:

* support for hashed authentication


WooHoo! Will be testing!

cubber
Posts: 9
Joined: Fri Jul 18, 2008 4:47 pm

Postby cubber » Fri Jul 18, 2008 4:50 pm

I just compiled and installed zmviwer 1.6 on gentoo and it works if I manually enter a camera but not when I use the session function. I can connect to the ZM server with the session connect and it pulls down all the cameras but displays no images. The problem is that I had to set my apaches server on that machine to use port 81. When I manually add a camera and specifiy port 81 all works fine, but when I use session to import the cameras they all get defaulted to port 80 and I am unable to change it in the camera settings.

How can I correct the ports and use sessions.

Thanks

lopezlean
Posts: 14
Joined: Mon May 21, 2007 2:03 pm
Location: Argentina
Contact:

Postby lopezlean » Wed Aug 27, 2008 11:22 am

cubber wrote:I just compiled and installed zmviwer 1.6 on gentoo and it works if I manually enter a camera but not when I use the session function. I can connect to the ZM server with the session connect and it pulls down all the cameras but displays no images. The problem is that I had to set my apaches server on that machine to use port 81. When I manually add a camera and specifiy port 81 all works fine, but when I use session to import the cameras they all get defaulted to port 80 and I am unable to change it in the camera settings.

How can I correct the ports and use sessions.

Thanks


Check out the latest code from subversion's trunk, there I added the feature that you want.
Leandro Emanuel López

cubber
Posts: 9
Joined: Fri Jul 18, 2008 4:47 pm

Postby cubber » Wed Aug 27, 2008 2:36 pm

I just downloaded the SVN but cannot build it. The readme says that it requires QT 4.3 and cmake which I have installed but when I go to build it it by running cmake .. in the build directory it gives me the following errors:

Warning: this project requires version 2.6 of cmake you are running version 2.4.6.

CMake Error: The Installed QT version 4.3.3 is too old, at least version 4.4.0 is required.

The only version of cmake in gentoo's portage is 2.4 even if I use the unstable version. I can recompile qt to 4.4.1 through portage, but the readme says qt 4.3 is needed. Does the readme need an update?

I guess I will wait for cmake to be updated in portage. Also does the windows client now support the new update that is in svn or is that a work in progress?

Thanks

lopezlean
Posts: 14
Joined: Mon May 21, 2007 2:03 pm
Location: Argentina
Contact:

Postby lopezlean » Thu Aug 28, 2008 12:11 am

cubber wrote:I just downloaded the SVN but cannot build it. The readme says that it requires QT 4.3 and cmake which I have installed but when I go to build it it by running cmake .. in the build directory it gives me the following errors:

Warning: this project requires version 2.6 of cmake you are running version 2.4.6.

CMake Error: The Installed QT version 4.3.3 is too old, at least version 4.4.0 is required.

The only version of cmake in gentoo's portage is 2.4 even if I use the unstable version. I can recompile qt to 4.4.1 through portage, but the readme says qt 4.3 is needed. Does the readme need an update?

I guess I will wait for cmake to be updated in portage. Also does the windows client now support the new update that is in svn or is that a work in progress?

Thanks


I updated the README file in source code.

zmviewer need Qt >= 4.4 and cmake >= 2.6 to compile
Leandro Emanuel López

W.
Posts: 108
Joined: Tue Apr 10, 2007 5:06 pm
Location: Latvia

Postby W. » Wed Sep 10, 2008 3:51 pm

fix to get events viewed on 1.23.3 (maybe other versions too)

Code: Select all

--- trunk/zmviewer/src/core/stream.cpp~ 2008-08-28 14:43:13.000000000 +0300
+++ trunk/zmviewer/src/core/stream.cpp  2008-09-10 18:38:47.000000000 +0300
@@ -171,7 +171,7 @@ void Stream::start()
     if (d->type == Monitor )
         connection = QString ( "%1?mode=%2&monitor=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->monitor ).arg ( d->scale ).arg ( d->bitrate );
     else if ( d->type == Event )
-            connection = QString ( "%1?mode=%2&frame=1&event=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->event ).arg ( d->scale ).arg ( d->bitrate);
+            connection = QString ( "%1?source=event&mode=%2&frame=1&event=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->event ).arg ( d->scale ).arg ( d->bitrate);
     if ( !d->appendString.isNull() && d->appendString.size() > 0 )
             connection.append("&"+d->appendString);
     //#ifdef DEBUG_PARSING
if common sense is so uncommon, why is it called common then?

lopezlean
Posts: 14
Joined: Mon May 21, 2007 2:03 pm
Location: Argentina
Contact:

Postby lopezlean » Sat Sep 13, 2008 4:29 pm

W. wrote:fix to get events viewed on 1.23.3 (maybe other versions too)

Code: Select all

--- trunk/zmviewer/src/core/stream.cpp~ 2008-08-28 14:43:13.000000000 +0300
+++ trunk/zmviewer/src/core/stream.cpp  2008-09-10 18:38:47.000000000 +0300
@@ -171,7 +171,7 @@ void Stream::start()
     if (d->type == Monitor )
         connection = QString ( "%1?mode=%2&monitor=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->monitor ).arg ( d->scale ).arg ( d->bitrate );
     else if ( d->type == Event )
-            connection = QString ( "%1?mode=%2&frame=1&event=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->event ).arg ( d->scale ).arg ( d->bitrate);
+            connection = QString ( "%1?source=event&mode=%2&frame=1&event=%3&scale=%4&bitrate=%5" ).arg ( d->zms ).arg ( d->mode ).arg ( d->event ).arg ( d->scale ).arg ( d->bitrate);
     if ( !d->appendString.isNull() && d->appendString.size() > 0 )
             connection.append("&"+d->appendString);
     //#ifdef DEBUG_PARSING


Thanks, code from subversion's trunk was patched
Leandro Emanuel López


Return to “User Contributions”

Who is online

Users browsing this forum: No registered users and 1 guest