Two cameras go green every night

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
uros76
Posts: 3
Joined: Mon Sep 05, 2016 11:31 pm

Two cameras go green every night

Post by uros76 »

Hi. I have a weird problem where the same 2 cameras (out of 4) show up green on my ZM server for a short period every night at the same time. The other two cameras are not doing this.
All 4 cameras are IP cameras from HihVision connected to UTP cable and powered with POE. ZM server is v1.36.33 installed on the latest Ubuntu.

Attaching screenshots of those green anomalies. I checked camera settings and they are all the same.
Any idea why I am getting this every night?
greens.png
greens.png (331.92 KiB) Viewed 2537 times
bbunge
Posts: 2934
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Two cameras go green every night

Post by bbunge »

Is GMT your local time? If not do the cams go green switching from day to night?
uros76
Posts: 3
Joined: Mon Sep 05, 2016 11:31 pm

Re: Two cameras go green every night

Post by uros76 »

No. I am on CET timezone.
Also no. When the night or morning comes it's all good. They do not turn green then.

It's really weird I still can't figure out what is causing this.
User avatar
iconnor
Posts: 2900
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Two cameras go green every night

Post by iconnor »

In 1.37 I have been debugging long standing issues that only occur on some cameras. What I have determined is that the clock on the camera jumps back (or forward) in time. This is basically because the internal clock is really bad, and ntp is making a correction every hour. Some cameras are set to update their ntp time at a greater interval (1440m). So in 1.37 now, we kill the capture and restart instead of getting a corrupt video. Am trying to figure out a way to get the cameras to update their clocks more frequently.
User avatar
iconnor
Posts: 2900
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Two cameras go green every night

Post by iconnor »

Another thought here is that logrotate runs at midnight every night and will cause the monitor to start/restart capture. Shouldn't result in green, but maybe that's it. You can trigger it anytime using sudo zmdc.pl logrot
uros76
Posts: 3
Joined: Mon Sep 05, 2016 11:31 pm

Re: Two cameras go green every night

Post by uros76 »

iconnor wrote: Sun Feb 25, 2024 3:13 pm In 1.37 I have been debugging long standing issues that only occur on some cameras. What I have determined is that the clock on the camera jumps back (or forward) in time. This is basically because the internal clock is really bad, and ntp is making a correction every hour. Some cameras are set to update their ntp time at a greater interval (1440m). So in 1.37 now, we kill the capture and restart instead of getting a corrupt video. Am trying to figure out a way to get the cameras to update their clocks more frequently.
I think you might be on to something. I just checked those two cameras and both of them have NTP enabled for a time sync. Other cameras (without the night green effect) have manually set time.
I just disabled the NTP sync on problematic cameras and will see if that helps.
Post Reply