ONVIF & Pre Event Image Count ???

Current Development version likely to have breaking changes
Post Reply
IgorA100
Posts: 66
Joined: Sat Feb 03, 2024 11:55 am

ONVIF & Pre Event Image Count ???

Post by IgorA100 »

I still can't figure out if the Pre Event Image Count buffer value is used when using ONVIF detection?
Logically, it should be used with "Decoding = Always"
In practice, it seems that it is not used.
User avatar
iconnor
Posts: 2896
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: ONVIF & Pre Event Image Count ???

Post by iconnor »

It should be. The packet queue should maintain a buffer of that size + keyframe. SOmetimes it can't and there will be a log entry about it.
IgorA100
Posts: 66
Joined: Sat Feb 03, 2024 11:55 am

Re: ONVIF & Pre Event Image Count ???

Post by IgorA100 »

Yes, Pre Event Image Count & Post Event Image Count work when using ONVIF detection if specified:
Decoding = Keyframes + Ondemand and Decoding = Always. I haven't checked for other "Decoding" values.
BUT! the above buffers are not used correctly.
I use a short-term event ~1-2 sec.
For example, the camera has 20FPS, if I specify

Code: Select all

Pre Event Image Count=20
, then the event is not recorded! If I specify

Code: Select all

Pre Event Image Count=60
, the event is recorded, but there are only 40-50 frames before the event. At the same time, the location of the event is not correctly marked on the time strip; as a rule, the marked event is shifted forward in time, although in reality it happened earlier.
Post Reply