I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Current Development version likely to have breaking changes
Post Reply
Stupid20CharLimit
Posts: 6
Joined: Mon Nov 27, 2023 12:26 am

I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by Stupid20CharLimit »

I have been stuck for a long time on this. I can view event playback in a web browser but I can't do it on the zmninja app. It doesn't work on android or in the linux desktop appimage. I am using zmninja 1.7.006 although I get this same issue on the older versions too. I am on zoneminder 1.37.51.

When I track down the physical location on disk of where an event video is stored, I can type that in to a web browser. The raw video file doesn't play and I get "No video with supported format and MIME type found." If I replace that file with a known working mp4 video that doesn't have mime issues, it will work when I try to play it in the browser. When I try to view that same event in Zmninja, the video file actually plays.

This proves that the reason I have not been able to get zmninja to work since updating to Debian 12 is because now, the saved videos are being saved with mime errors. I have not been able to find a way to make ffmpeg convert the borked mp4 files to working mp4 files but I expect I'll figure that out eventually. Then, I can make a script or program that checks through all my video files a few times a day and converts them from "broken because mime" to "working".

Is there a way to prevent zoneminder from saving videos with whatever mime shenanigans it's doing? Is there a way to modify zoneminder's saved video format settings in any way? Because if there's a better workaround for this issue that doesn't involve a clunky script that has to check and convert stuff, I would love to hear it.
User avatar
iconnor
Posts: 2896
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by iconnor »

I suspect your non-playing file is h265 and the one that plays is h264
Stupid20CharLimit
Posts: 6
Joined: Mon Nov 27, 2023 12:26 am

Re: I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by Stupid20CharLimit »

iconnor wrote: Tue Feb 20, 2024 8:47 pm I suspect your non-playing file is h265 and the one that plays is h264
I can convert the file to h264 by renaming the original and then doing this:
ffmpeg -i 12681-video.hevc_borked.mp4 -map 0 -c:v libx264 12681-video.hevc.mp4
I can then open that event in zmninja and the video actually plays! :shock:

ffprobe shows that the original video file is h265.

Is it possible to make it so that those videos automatically get saved as h264? Or does it come from the camera like that? I haven't ever changed my camera and im using the same one now as I was when this used to work. If I change the decoder in source > decoder to libx264, it still saves the videos as h265 even after restarting the zoneminder service.
dougmccrary
Posts: 1205
Joined: Sat Aug 31, 2019 7:35 am
Location: San Diego

Re: I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by dougmccrary »

Usually, the camera has an h264/h265 option.
Stupid20CharLimit
Posts: 6
Joined: Mon Nov 27, 2023 12:26 am

Re: I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by Stupid20CharLimit »

Mine doesn't. Guess I'll have to explore the viability of making a file conversion hack/script then.

It used to work though..

edit: actually, no need for an external script. Video writer was set to passthrough and changing that to h264 worked!
dougmccrary
Posts: 1205
Joined: Sat Aug 31, 2019 7:35 am
Location: San Diego

Re: I finally found the cause of my "video playback not working" issue. Need help finding a workaround

Post by dougmccrary »

Video writer was set to passthrough and changing that to h264 worked!
Good to know!
Post Reply