.22 and .23 APT Upgrade Errors

Current Development version likely to have breaking changes
Post Reply
User avatar
jlw52761
Posts: 11
Joined: Thu Dec 03, 2020 9:29 pm

.22 and .23 APT Upgrade Errors

Post by jlw52761 »

Mainly wanted to report this. Manually running the contents of the SQL script using sudo seems to work, then running the "zmupdate.pl" sends up a second set of errors.

APT errors

Code: Select all

chown: cannot dereference '/var/cache/zoneminder/skins_classic_js_bootstrap.min-base-1639175790.js': No such file or directory
detected systemd
Warning: The unit file, source configuration file or drop-ins of zoneminder.service changed on disk. Run 'systemctl daemon-reload' to reload units.
Detected db service is mysql.service
Checking for db
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
Cannot talk to database. You will have to create the db manually with something like:
cat /usr/share/zoneminder/db/zm_create.sql | mysql -u root
ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)
/var/lib/dpkg/info/zoneminder.postinst: 29: [: -ne: unexpected operator
Updating permissions for user zmuser@localhost
ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)

Initiating database upgrade to version 1.37.23 from version 1.37.22

Upgrading database to version 1.37.23
Upgrading DB to 1.37.23 from 1.37.22
ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)
Output:
Command 'mysql --defaults-file=/etc/mysql/debian.cnf -hlocalhost zm < /usr/share/zoneminder/db/zm_update-1.37.23.sql' exited with status: 1
Error updating db.
dpkg: error processing package zoneminder (--configure):
 installed zoneminder package post-installation script subprocess returned error exit status 1
zmupdate.pl errors

Code: Select all

Initiating database upgrade to version 1.37.23 from version 1.37.22

Do you wish to take a backup of your database prior to upgrading?
This may result in a large file in /var/tmp/zm if you have a lot of events.
Press 'y' for a backup or 'n' to continue : y
Creating backup to /var/tmp/zm/zm-1.37.22.dump. This may take several minutes.
mysqldump: [Warning] Using a password on the command line interface can be insecure.
mysqldump: Error: 'Access denied; you need (at least one of) the PROCESS privilege(s) for this operation' when trying to dump tablespaces
Database successfully backed up to /var/tmp/zm/zm-1.37.22.dump, proceeding to upgrade.

Upgrading database to version 1.37.23
Upgrading DB to 1.37.23 from 1.37.22
mysql: [Warning] Using a password on the command line interface can be insecure.

Database successfully upgraded to version 1.37.23.

Database upgrade to version 1.37.23 successful.
Post Reply