problem seeing cameras video

Previous development branch now released as 1.36
Post Reply
billfoster
Posts: 1
Joined: Thu Apr 28, 2022 9:42 am

problem seeing cameras video

Post by billfoster »

I am completely new to zoneminder and have ran into a problem, when adding video it dosent show. The camera I am trying to add is a hikvision IPC-T221H and I have tried adding both rtsp and http based connections with various links with no success. The rtsp connection video shows unable to connect to monitor and the http connection video shows unable to stream.

When checking the logs it says for rtsp "Unable to open input rtsp:AdressOfRtsp due to: immediate exit requested" and "Unable to open input rtsp:AdressOfRtsp due to: operation not permitted" Then with http it says "Unable to open input http://:AdressOfHttp due to 403 forbidden (access denied)" Also a general error of "failed to prime capture of initial monitor" gb whatsapp

Now I know the rtsp adress should work because I tested it with VLC and it shows perfectly fine.

In the end I only really need rtsp but whatever I can get working is fine. I know I'm probally doing a beginners mistake or something along those lines and this is a easy fix. Any help would be appreciated!
Last edited by billfoster on Sat Apr 30, 2022 5:58 am, edited 1 time in total.
dougmccrary
Posts: 548
Joined: Sat Aug 31, 2019 7:35 am

Re: problem seeing cameras video

Post by dougmccrary »

for starters, get a release version - at least 1.34, or 1.36 - new users should stay away from the dev versions.

If your cam is similar to some of mine, the address should be something like rtsp://[user]:[password]@192.168.1.202:554/2
Post Reply