Ubuntu 7.04 (Feisty Fawn) installation walkthrough (kind of)

If you've made a patch to quick fix a bug or to add a new feature not yet in the main tree then post it here so others can try it out.
ryscar
Posts: 9
Joined: Tue Jul 10, 2007 1:45 pm
Location: Mesa, AZ

Post by ryscar » Tue Aug 21, 2007 10:42 pm

Lee,

I totally agree with your disagreeing! That is, in fact, one of the things I was going to change when I did the update.

kingpikey
Posts: 3
Joined: Wed Sep 05, 2007 12:13 am

Post by kingpikey » Wed Sep 05, 2007 6:26 am

Ok, so I managed to get zoneminder installed in Feisty (7.04) with your instructions... thank you so much.

Now I can't seem to get my webcam to show up as a source for zoneminder. The webcam is working... i used the bundled VoIP / chat software (starts with an e) to verify that the camera is working. It shows a live feed.

ZoneMinder however shows nothing...

Oh yeah, and its listed as /dev/video0

Please help if you can... thanks in advance!

ryscar
Posts: 9
Joined: Tue Jul 10, 2007 1:45 pm
Location: Mesa, AZ

Post by ryscar » Wed Sep 05, 2007 1:52 pm

I have never tried it with a web cam so I probably can’t help. I know when I first tried to get things working, I had my Device Channel in my Source settings set to 1 instead of 0 and that kept throwing me off…. Just a thought.

User avatar
Lee Sharp
Posts: 1069
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Post by Lee Sharp » Thu Sep 06, 2007 3:52 am

From a terminal type 'xawtv /dev/video0' and tell us what happens. If you have an nvidia card, use the -nogda flag. You may need to install xawtv.

sergiut2002
Posts: 30
Joined: Wed Sep 19, 2007 11:54 am
Location: Constanta Romania
Contact:

Database?

Post by sergiut2002 » Wed Sep 26, 2007 7:18 pm

is your guide complet?

about zm database? or it`s not really needed?

i don`t knwo how to setup phpmyadmin to use zm in ubuntu 7.04 desktop
________
Honda Hr-V Specifications
Last edited by sergiut2002 on Sun Feb 13, 2011 3:50 pm, edited 1 time in total.

ryscar
Posts: 9
Joined: Tue Jul 10, 2007 1:45 pm
Location: Mesa, AZ

Post by ryscar » Wed Sep 26, 2007 8:47 pm

Im not really sure what you are getting at but, if you follow the guide, it should work. As I have only installed it on a server, not a desktop, I don't know what issues you would run into.. if any.
The ZM database is needed as that is where everything except the video/images is stored and should get installed during installation.
You don't really "need" PHPMyAdmin. It just makes administering the database a little easer but, i have not needed it as most things are taken care of within ZM.

PeterHoward
Posts: 319
Joined: Thu Jul 20, 2006 1:07 am
Location: Australia
Contact:

Re: Database?

Post by PeterHoward » Wed Sep 26, 2007 10:21 pm

sergiut2002 wrote:is your guide complet?

about zm database? or it`s not really needed?

i don`t knwo how to setup phpmyadmin to use zm in ubuntu 7.04 desktop
As long as you've installed everything (esp mysql and php, in this case) by package, and not by manual build, then the zoneminder .deb should take care of setting up the database. You shouldn't need to do any manual tweaking.

PJH

sergiut2002
Posts: 30
Joined: Wed Sep 19, 2007 11:54 am
Location: Constanta Romania
Contact:

cool

Post by sergiut2002 » Thu Sep 27, 2007 5:09 am

ok..thanks for the help.
________
ARIZONA MARIJUANA DISPENSARIES
Last edited by sergiut2002 on Tue Mar 08, 2011 9:26 am, edited 1 time in total.

wtinney
Posts: 8
Joined: Sat Sep 29, 2007 11:01 am

Re: Ubuntu 7.04 (Feisty Fawn) installation walkthrough (kind

Post by wtinney » Wed Oct 03, 2007 9:43 pm

Hi,

I'm a newbie here. I'm familiar with Linux but not very adept at it (especially command line stuff).

I followed your instructions and installed ZoneMinder on Ubuntu 7.04 Desktop edition. It seems to work OK, but it's not producing thumbnails on the Event pages like the LiveCD version does (the LiveCD version didn't support my built-in LAN card).

Is there a setting I need to change to make it produce thumbnails for the Alert page? Or did I miss installing something I need?

Here's what I did:

Installed 7.04 from installer CD.
Installed Apache2 with extras I thought I'd need with Synaptic Package manager.
Installed MySQL with development headers (etc) with Synaptic
Followed your instructions (skipping a couple of steps like 3 which didn't seem relevant):
ryscar wrote:

Code: Select all

sudo -i
apt-get install ssh
wget ftp://www.northern-ridge.com.au/zoneminder/ubuntu/edgy/zoneminder_1.22.3-8_i386.deb
dpkg -i zoneminder_1.22.3-8_i386.deb
apt-get –f install
ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf
apt-get install patch
cd /usr/share/zoneminder
wget http://www.zoneminder.com/downloads/zm-1.22.3-filter.patch
patch -p0 < zm-1.22.3-filter.patch
chown www-data:www-data zm_actions.php
And then followed Lee Sharp's directions:
Lee Sharp wrote:

Code: Select all

sudo ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf
sudo apache2ctl restart
sudo chmod 4755 /usr/bin/zmfix
zmfix -a
sudo chown www-data.www-data /usr/share/zoneminder/temp

edit /etc/sysctl.conf and add the following lines (for 128meg shared mem)

kernel.shmall = 134217728
kernel.shmmax = 134217728

Download cambozola.jar and put it in /usr/share/zoneminder
Enable in options->Images.

Set path to ffmpeg in options -> Images
/usr/bin/ffmpeg

test with xawtv (-nodga may be needed)

Code: Select all

# Add extra repositories

# Medibuntu
wget -q http://medibuntu.sos-sts.com/repo/medibuntu-key.gpg -O- | sudo apt-key add -
sudo wget http://medibuntu.sos-sts.com/sources.list.d/feisty.list -O /etc/apt/sources.list.d/medibuntu.list

# Refresh repositories
sudo apt-get update

# Install everything

sudo apt-get install ssh traceroute p7zip unace rar xfonts-intl-european flashplugin-nonfree sun-java5-plugin faad ffmpeg gstreamer0.10-ffmpeg gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse lame liba52-0.7.4 libartsc0 libdc1394-13 libdvdread3 libfaac0 libfaad2-0 libgsm1 libid3tag0 libimlib2 liblame0 libmad0 libmjpegtools0c2a libmms0 libmodplug0c2 libmp4v2-0 libmpcdec3 libmpeg2-4 liboggflac3 libquicktime0 libsidplay1 libswfdec0.3 libxine-extracodecs libxine-main1 libxvidcore4 libxvmc1 mjpegtools ntp ntp-simple sox vorbis-tools libdvdcss2 w32codecs msttcorefonts ogle-mmx ogle-gui streamtuner streamripper
Then allowed the update program to run over several sessions (I'm on a satellite modem and have to keep an eye on how much bandwidth I use - if I exceed our limit they'll turn our speed down to 33.6 Kbps for 24 hours)

Then I used Automatix to install the correct driver for my add in video card.

Computer: eMachines T3522
add in video card: nvidia GeForce 7300 PCI-E
add in video capture card: Avermedia DVD EZMaker PCI

User avatar
Lee Sharp
Posts: 1069
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Post by Lee Sharp » Wed Oct 03, 2007 11:10 pm

Options --> Web --> ZM_WEB_LIST_THUMBS
Check this.

And you thought it would require command line stuff. ;)

sergiut2002
Posts: 30
Joined: Wed Sep 19, 2007 11:54 am
Location: Constanta Romania
Contact:

ffmpeg

Post by sergiut2002 » Thu Oct 04, 2007 5:11 am

any compiled 1.22.3 with ffmpeg support on ubuntu 7.04?
________
Mercedes-Benz M113 Engine History
Last edited by sergiut2002 on Sun Feb 13, 2011 3:50 pm, edited 1 time in total.

wtinney
Posts: 8
Joined: Sat Sep 29, 2007 11:01 am

Post by wtinney » Thu Oct 04, 2007 2:49 pm

Lee Sharp wrote:Options --> Web --> ZM_WEB_LIST_THUMBS
Check this.

And you thought it would require command line stuff. ;)
That did the trick. Thank you.

tronstorm
Posts: 1
Joined: Sat Oct 06, 2007 6:03 pm

webcam

Post by tronstorm » Sat Oct 06, 2007 6:09 pm

Need help with my webcam model Logitech Quickcam express. it is listed in /dev/video0, it worked fine with xawtv -nodga. But in zoneminder wont work, always shows red in the monitor.

any advice?

thanks


Raul

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Can't get camera image

Post by mrd » Thu Oct 11, 2007 7:35 pm

I've run through your install and everything went very smoothly, but when I try to create a new monitor, I can't get a camera image. I just get a broken image.

It appears that ffmpeg in not installed through the .deb package. Is this a problem?
root@system-t:~# ls -l /usr/local/bin/ffmpeg
ls: /usr/local/bin/ffmpeg: No such file or directory
root@system-t:~#

I'm using a Pinnacle PCTV card that works fine with the live CD. Here is some information ouput...

root@system-t:~# zmu -d /dev/video0 -v -q -U <user> -P <pword>
Video Capabilities
Name: BT878 video (Pinnacle PCTV Stud
Type: 171
Can capture
Can tune
Overlay onto frame buffer
Can clip
Scalable
Video Channels: 3
Audio Channels: 1
Maximum Width: 924
Maximum Height: 576
Minimum Width: 48
Minimum Height: 32
Window Attributes
X Offset: 0
Y Offset: 0
Width: 320
Height: 240
Picture Attributes
Palette: 4 - 24bit RGB
Colour Depth: 24
Brightness: 32768
Hue: 32768
Colour :32768
Contrast: 32768
Whiteness: 0
Channel 0 Attributes
Name: Television
Channel: 0
Flags: 3
Channel has a tuner
Channel has audio
Type: 1 - TV
Format: 0 - PAL
Channel 1 Attributes
Name: Composite1
Channel: 1
Flags: 2
Channel has audio
Type: 2 - Camera
Format: 0 - PAL
Channel 2 Attributes
Name: S-Video
Channel: 2
Flags: 2
Channel has audio
Type: 2 - Camera
Format: 0 - PAL


I see that the format = PAL even though my monitor is set to NTSC?

I've used the live CD's in the past with great success, but wanted to be able to break away from them. I'm also wondering if I've missed something under the "images" or "config" tabs in Options that might be causeing my troubles.

Any help would be great!
MRD

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Thu Oct 11, 2007 7:53 pm

Ok...got the video working bby following the Ubuntu wiki
http://www.zoneminder.com/wiki/index.php/Ubuntu_7.04
which I didn't find on my inital search here...

"chmod 666 /dev/video0"

worked...

I am still wondering why ffmpeg is not installed and if it is needed for full ZM operations?

Thanks!
MRD

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests