ZoneMinder 1.24.2 RPMs for SuSE released

If you've made a patch to quick fix a bug or to add a new feature not yet in the main tree then post it here so others can try it out.
Post Reply
User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

ZoneMinder 1.24.2 RPMs for SuSE released

Post by monex » Wed Jul 01, 2009 7:35 pm

Hi,

RPM's for the new ZoneMinder version are now available in the repositories. Installation/upgrade instructions can be found in the wiki. Required perl modules, which are missing in the normal openSuSE distribution, are also in the repositories and get's installed when solving the dependencies.

Short summarize of the upgrade instructions:
  • To upgrade your current ZoneMinder RPM install, just stop ZoneMinder, install the new package and run zm_database_init which will the automatic call the original zm database upgrade script after path checking to the db scripts. (If your path in the config file is wrong zm_database_init will auto correct the path. all you have to do is to answer the question for that with "y" or "yes"). After that start ZoneMinder by typing "rczm start" and all is done.
  • if you just want to update the database the traditional ZoneMinder way (it's recommended to use the wrapper zm_database_init script), edit /etc/zm.conf and change the version to the the new one (1.24.1) and check that ZM_PATH_BUILD is set to /srv/www/htdocs/zm. Then run "zmupdate.pl" and remove the lock file "rm -f /srv/www/htdocs/zm/lock" and start ZoneMinder.
The old packages are moved to the legacy directory:

openSuSE 11.0:
http://liquid-co.de/pub/suse/repositori ... 24.1/11.0/

openSuSE 11.0:
http://liquid-co.de/pub/suse/repositori ... 24.1/11.0/

openSuSE 11.1:
http://liquid-co.de/pub/suse/repositori ... 24.1/11.1/

You can also try to use the one click install feature:
Image

And for the MP version:
Image

Note: You can also install ZoneMinder (non MP) version from the openSuSE Build Service http://download.opensuse.org/repositori ... x:/stable/ so that you can find version for factory there.

If you find some bugs please report this in the forums and mention that you are using the RPM's :)

Note: This time I couldn't test it completely because the test system is down and I have no cams here at the moment, the only thing I can ensure is that it installs/upgrades properly :P If you find some bugs or have problems especially with mootools (I've upgraded to the latest version) report back here.

Have a lot of Fun

Dirk
Image

User avatar
kingofkya
Posts: 1112
Joined: Mon Mar 26, 2007 6:07 am
Location: Las Vegas, Nevada

Post by kingofkya » Thu Jul 02, 2009 12:51 am

man your quick with that rpm

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Thu Jul 02, 2009 6:14 pm

It isn't too complicated after I spent much time with creating a RPM sepc file which fits for almost all available suse version I normally only have to adapt the the std configuration patch for a minor version update. If there is a major version released things will get more complicated :)

Have a lot of fun
Image

bcnx
Posts: 2
Joined: Wed Nov 11, 2009 9:53 pm

/usr/local/bin

Post by bcnx » Wed Nov 11, 2009 10:00 pm

Thx for the rpms!

I just installed them after having had some problems with the source version (shared memory stuff).

After installing your rpms I notice that zmpkg.pl wants to start all the binaries from /usr/local/bin and not from /usr/bin.

Could this be an error? Or is this the result of my previous source based install ...


thx!

B.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sat Nov 21, 2009 2:39 pm

Hi,

sorry for my late answer, I was busy the last week.

I've already heard some other people having similar troubles, but I could not reproduce it here on my system. It might be because of your previous installation maybe you can verify if your old installation is completely removed (should be located under /usr/local/bin/) and/or which zmpkg.pl is called by invoking "which zmpkg.pl" in the shell. If it is the version under /usr/local/bin is on the output then zmpkg.pl from your previous installation gets called and this should then be the reason for this behavior.

Hope this helps
Image

bcnx
Posts: 2
Joined: Wed Nov 11, 2009 9:53 pm

Post by bcnx » Sat Nov 21, 2009 3:13 pm

Hi,

thx for your answer. It was indeed to residue of the last installation: the Perl related part of the install was still there in another path than the Perl related files out of the RPM. Since this other path was mentionned earlier in @INC, it was used before the actually needed files.

B.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sat Jan 09, 2010 8:24 pm

Hi,

packages for openSUSE 11.2 are now available at:

http://liquid-co.de/pub/suse/repositories/11.2/

You can also try to use the one click install feature:
Image

And for the MP version:
Image

If you find some bugs please report this in the forums and mention that you are using the RPM's :)

Have a lot of fun

Dirk
Image

aruzsi
Posts: 16
Joined: Sat Aug 21, 2010 4:11 pm
Location: Budapest

Post by aruzsi » Sat Aug 21, 2010 6:22 pm

Hi,

Packages for 11.3?

TIA,
Ruzsi

Painter
Posts: 12
Joined: Tue Oct 02, 2007 9:39 am
Location: Athens/Greece

Post by Painter » Mon Sep 13, 2010 10:25 am

I just found that at http://liquid-co.de/pub/suse/repositories/11.3/
there are packages for OpenSuse 11.3.
I updated my ZM repository and installed ZoneMinder.
Then i had to remove MariaDB and revert to Mysql as i was lazy to troubleshoot the sideeffects of that change (mysql>mariadb).

Everything works just fine again.

Thank you all for the good work.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Thu Sep 16, 2010 6:45 pm

Hi,

as you've already notices is that the packages are available now :) I didn't had the time to test them earlier.

Btw. are there troubles with mariadb?

packages for openSUSE 11.3 are now available at:

http://liquid-co.de/pub/suse/repositories/11.3/

You can also try to use the one click install feature:
Image

And for the MP version:
Image

If you find some bugs please report this in the forums and mention that you are using the RPM's :)

Have a lot of fun

Dirk
Image

linclkh
Posts: 15
Joined: Sat Sep 11, 2010 10:16 pm

suse 11.3

Post by linclkh » Fri Sep 17, 2010 2:51 am

Big Thank you , Dirk

aruzsi
Posts: 16
Joined: Sat Aug 21, 2010 4:11 pm
Location: Budapest

Post by aruzsi » Tue Sep 28, 2010 6:42 pm

Hi,

The installation was successfull except camera doesn't work. :-(

When I click on Probe I get: Unable to probe local cameras, status is 255.

I've got a not too young USB WEB camera. It is working under Xawtv.
I use /dev/vide0 and v4l.

Anyone can help me?

TIA,

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests