Does jZMConsole handle proxies

If you've made a patch to quick fix a bug or to add a new feature not yet in the main tree then post it here so others can try it out.
Post Reply
Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Does jZMConsole handle proxies

Post by Islandcoz » Wed May 13, 2009 1:42 pm

I am trying to get jZMConsole to work from behind my company firewall, I can access my ZoneMinder instance using a browser and with James Wilson's Viseon Viewer. Currently my Zoneminder Instance listens on port 85 not 80. Installation of both client and server went without errors, but I cannot get the jZMConsole to accept/connect to the url.

I also installed the client on a computer at home and the URL was accepted, but I was unable to logon.

I am looking forward to testing this client so any help I get would be appreciated.

BTW: the is no info in the jZMConsole.log file

ahagadorn
Posts: 61
Joined: Mon Aug 11, 2008 1:55 pm
Location: Burnt Hills, NY
Contact:

Post by ahagadorn » Thu May 14, 2009 1:07 pm

It currently does not directly handle proxies, but it is fairly easy for me to add that.

I will look in to a quick fix for the port issue.

Andy

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Thu May 14, 2009 1:17 pm

Thanks

ahagadorn
Posts: 61
Joined: Mon Aug 11, 2008 1:55 pm
Location: Burnt Hills, NY
Contact:

Post by ahagadorn » Thu May 14, 2009 1:36 pm

Did you try specifying the port in the URL, for example http://www.example.com:85 ?

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Thu May 14, 2009 1:42 pm

Yes I did, this worked at home on the same network, and I got to the login screen, but all login attempts failed.

However this did not work from my work PC which is behind a proxy

ahagadorn
Posts: 61
Joined: Mon Aug 11, 2008 1:55 pm
Location: Burnt Hills, NY
Contact:

Post by ahagadorn » Thu May 14, 2009 2:02 pm

Do you have OPT_USE_AUTH checked in your ZM System Options? If not, this will cause logins to fail.

If you are running the client on Linux, you can set the proxy in the jzmconsole startup script.

Edit the script, and change:

Code: Select all

java -jar $JZMC_CLIENT_HOME/jZMConsole.jar
To:

Code: Select all

java -Dhttp.proxyHost=webcache.mydomain.com -Dhttp.proxyPort=8080 -jar $JZMC_CLIENT_HOME/jZMConsole.jar

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Thu May 14, 2009 2:06 pm

I do have authorizations checked, and I am attempting to get the client to run on XP, have not tried it on linux yet.

I even added a special user to use from the JavaConsole, but I still cannot logon from the machine on the same network

ahagadorn
Posts: 61
Joined: Mon Aug 11, 2008 1:55 pm
Location: Burnt Hills, NY
Contact:

Post by ahagadorn » Thu May 14, 2009 2:28 pm

Do you get the "Bad Password" message on the login screen, or does it go beyond that?

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Thu May 14, 2009 4:59 pm

I let login failed message

ahagadorn
Posts: 61
Joined: Mon Aug 11, 2008 1:55 pm
Location: Burnt Hills, NY
Contact:

Post by ahagadorn » Thu May 14, 2009 5:12 pm

What version of ZM are you running?

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Thu May 14, 2009 9:17 pm

I am running v1.22.2 installed from a liveCD

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Fri May 15, 2009 8:16 pm

I had some of the same errors you mentioned when I was testing this on my install DVD. I'll try and take a look at it again and see what I did to fix it. You might find a hint off of stuff I put in the main jzmc section. It's all working now on my 1.24.x dvd, atleast the server side portion. I've tested XP, Vista, and Windows 7 and have had no problems running it.

Islandcoz
Posts: 25
Joined: Fri May 12, 2006 4:18 pm
Location: Alpharetta,GA
Contact:

Post by Islandcoz » Sat May 16, 2009 1:01 am

thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests