Remove 3 Part RTSP configuration.

Anything you want added or changed in future versions of ZoneMinder? Post here and there's a chance it will get in! Search to make sure it hasn't already been requested.
Post Reply
FreeSoftwareServers
Posts: 20
Joined: Mon Dec 07, 2015 10:37 pm

Remove 3 Part RTSP configuration.

Post by FreeSoftwareServers » Sat Aug 06, 2016 11:25 pm

I figure, by the time your configuring the source of your ZoneMinder camera's, your relatively good with computers/networking.

I personally think it makes life a lot harder for poeple when you break apart full links its "catagorys".

Example:

This link works, verified via VLC.

rtsp://admin:PassWoRD@192.168.1.42:88/videoMain

Now I had to break it apart to figure out what parts to put in the following fields.

Remote Host Name = admin:PassWoRD@192.168.1.42 # No :PORT# No RTSP://

Remote Host POrt = 88 # NO :

Remote Host Path = /videoMain # Make sure to start with “/”

This took me a big guessing game of do I use rtsp, do I add the : before port, or use the "/". Probably a half hour after I knew the URL worked, I had to test how to break it apart to work in ZoneMinder.

User avatar
knight-of-ni
Posts: 2096
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Remove 3 Part RTSP configuration.

Post by knight-of-ni » Fri Oct 07, 2016 12:24 am

This sounds like you are using a source type of remote for your ip camera. Instead, use one of the ffmpeg or libvlc source types, which allows you to enter the url exactly as you described.

We are no longer maintaining the Remote RTSP source type due to lack of resources. It may even go away at some future point since ffmpeg & libvlc are far better. It is just not worth our time to re-invent the wheel.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

nrbell
Posts: 3
Joined: Mon Jun 04, 2018 1:14 pm

Re: Remove 3 Part RTSP configuration.

Post by nrbell » Sat Jul 07, 2018 8:52 pm

I realize that this is an old thread, but it seems to still be relevant. I am currently using a Reolink RLC-411WS with ZoneMinder. When using an "ffmpeg" connection I see frequent image corruption and frequent devolution into a smeary multicolored mess. With a "remote" connection it seems to work perfectly. I understand deprecating the "remote" connection due to lack of resources. Can you give us any guidance on how to configure ffmpeg so that we don't have to rely on "remote" for these (probably) broken cameras?

User avatar
iconnor
Posts: 487
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Remove 3 Part RTSP configuration.

Post by iconnor » Tue Jul 10, 2018 4:36 pm

The fix is to use TCP instead of UDP. There is a dropdown on the FFmpeg source page for this.

alabamatoy
Posts: 123
Joined: Sun Jun 05, 2016 2:53 pm

Re: Remove 3 Part RTSP configuration.

Post by alabamatoy » Tue Jul 17, 2018 1:22 pm

iconnor wrote:
Tue Jul 10, 2018 4:36 pm
The fix is to use TCP instead of UDP. There is a dropdown on the FFmpeg source page for this.
To clarify...I think you mean to use "RTP/RTSP" option instead of "RTP/Unicast" or "RTP/Multicast", correct?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests