Unable to install on Banana Pro under jessie in any way

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
Post Reply
inoculator
Posts: 6
Joined: Mon Apr 04, 2016 8:21 am

Unable to install on Banana Pro under jessie in any way

Post by inoculator » Fri Dec 28, 2018 8:26 pm

Hi all,

I am running Zoneminder using the Bananian Wheezy image since 2 years now.
As Wheezy is totally end of life, I wanted to change to Jessie.

Installing the base system was no issue, but installing Zoneminder is freaking me out.

#1 Install by repository
Based on https://wiki.zoneminder.com/Debian_8_64 ... e_Easy_Way

Code: Select all

echo "deb http://ftp.debian.org/debian jessie-backports main contrib non-free" >> /etc/apt/sources.list
apt-get update && apt-get upgrade

apt-cache policy zoneminder
######################################
zoneminder:
  Installed: (none)
  Candidate: 1.29.0+dfsg-1~bpo8+1
  Version table:
     1.29.0+dfsg-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main armhf Packages
#####################################

apt-get install zoneminder
This ends up in this error

Code: Select all

The following packages have unmet dependencies:
 policykit-1 : Depends: libpam-systemd but it is not installable
E: Unable to correct problems, you have held broken packages.
Searched the Internet and squeezed out Google, but got to no result.


#2 the hard way
Based on: https://zoneminder.readthedocs.io/en/la ... rom-source

This ends up here:

Code: Select all

Reading state information... Done
Note, selecting 'apache2-dev' instead of 'dh-apache2'
Note, selecting 'libgcrypt20-dev' instead of 'libgcrypt-dev'
Note, selecting 'libgnutls28-dev' instead of 'libgnutls-openssl-dev'
Package dh-systemd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  debhelper

E: Package 'dh-systemd' has no installation candidate
E: Unable to locate package libmariadbclient-dev-compat
I will now roll back to Wheezy again. But I would appreciate any solution on this.

thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests