No camera found when using ppa:iconnor/zoneminder-master

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
Post Reply
Posts: 4
Joined: Sun Jul 09, 2017 7:26 am

No camera found when using ppa:iconnor/zoneminder-master

Post by drogos » Tue May 29, 2018 9:57 am

Just did a fresh install of ubuntu 18.04 server, then added this ppa, and found some issues that I managed to resolve, and some that I did not.

The '/var/cache/zoneminder/cache' directory is not readable by apache after install, so the ui does not look great. Giving apache permissions to that folder solved it:

Code: Select all

<Directory /var/cache/zoneminder/cache>
	Options -Indexes +FollowSymLinks
	AllowOverride All
	Require all granted
The rewrite module for apache is not enabled:

Code: Select all

sudo a2enmod rewrite
Zoneminder is not enabled by default after install. Not sure if this is the indended behaviour or not

Code: Select all

sudo a2enconf zoneminder
A nice feature to add to the installer would be to configure the datetime of php automatically, but that is just a minor feature wish :)

Got it up and running, and started to move my cameras from the old installation to the new one. They are all IP cameras, and this is where I am lost. The cameras have the exact same configuration as on the old server, but in the new installation I get the following error:

Code: Select all

'zmc -m 1' exited abnormally, exit status 255
I have searched this issue, and checked that cgi is enabled in apache, also installed libv4lconvert0, libv4l-dev and libv4l-0. Added

Code: Select all

$ENV{LD_PRELOAD} = '/usr/lib/x86_64-linux-gnu/libv4l/';
right before my

Code: Select all

@daemons = (
in /usr/bin/ But the error is still the same. I have no local camera connected to the server.

I tried Probe and ONVIF as well, both with an empty list.

Anyone have some suggestions on how to proceed getting the cameras back up?


For anyone that does not care too much about the ppa, but wants ZoneMinder up and running on ubuntu server 18.04 there is an excellent guide here: ... e_easy_way (Got this tip on IRC). Installed the nginx version there and it works great! The very last part about editing /etc/default/fcgiwrap that file was not there on my system, but I edited /etc/init.d/fcgiwrap and that seems to work for now, atleast until the system updates :)

Edit 2:

At a closer look, it seems like the problem was the for some reason I can not use DAEMON_OPTS="-f -c 1", had to remove -f and use DAEMON_OPTS="-c 1" instead.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests