ZM on FreeBSD

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
markcurry
Posts: 1
Joined: Mon Jun 12, 2017 7:33 am

Re: ZM on FreeBSD

Post by markcurry » Mon Jun 12, 2017 7:44 am

abi wrote:
Sun May 28, 2017 8:41 pm
vendor_perl under FreeBSD is /usr/local/lib/perl5/site_perl
Thanks Bro! works great for me too after installing.

xplitz27
Posts: 1
Joined: Sat Jun 24, 2017 7:13 am

Re: ZM on FreeBSD

Post by xplitz27 » Sat Jun 24, 2017 7:21 am

I just want to say thanks everyone! I finally installed a working zoneminder in my FreeBSD/FreeNas machine (with a few errors because of my ip camera). Since we know its working well, would we see a working zoneminder "# pkg install zoneminder" in the future? (somewhat a hassle free way of configuring it?)

Thanks alot! I was thinking doing this a few years back with no hope of installing it. Now its possible. Thanks!

maryhaugen
Posts: 3
Joined: Fri Aug 04, 2017 3:43 am

Re: ZM on FreeBSD

Post by maryhaugen » Fri Aug 11, 2017 10:26 am

One of the blocking issues is a report that the his build of ZoneMinder can only stream to one client at a time. Based on the presented data, this does not look like an issue with the ZoneMinder source code itself. This thread is probably a good place to have this discussion and determine the fix.
-----------
Extensions for Magento 2 - Magento 2 XML Sitemap extension - Magento 2 Social Login

Baylink
Posts: 284
Joined: Sun Jun 19, 2005 3:19 am

Re: ZM on FreeBSD

Post by Baylink » Thu Aug 24, 2017 11:59 pm

mary: read back up the thread; that turned out to be a misconfigured fcgi-wrap.

fqhrfrenzy
Posts: 6
Joined: Tue Jul 25, 2017 9:00 pm

Re: ZM on FreeBSD

Post by fqhrfrenzy » Fri Aug 25, 2017 1:36 pm

So has anyone actually gotten ZM to run properly on FreeBSD in it entirety? Reason I ask is I have been able to get it running and doing what it needs to do up until the API. I cannot get the API's to work at all for external controls. There is a very long time frame from original post to now and was wondering where it actually stood. The package install does do most of the work for you to get it running. There is a simple fix for the camera displaying the actual camera name not just N on the "Timestamp Label Format", Add %%N instead of %N simple fixes like that. There are a lot of little things that have to go down to get it working and I have wonderful notes on all of it. I want to move it off of a dedicated server running Linux into a jail on FreeBSD so I have less to maintain but right now I just cant get it to do what it needs to do properly. It throws a LOT of errors all the time as well unlike Linux. Atleast in a jail you just kill it and create a new one if it breaks. Beats reinstalling the OS on a dedicated server.

User avatar
knnniggett
Posts: 1994
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: ZM on FreeBSD

Post by knnniggett » Fri Aug 25, 2017 2:33 pm

fqhrfrenzy wrote:
Fri Aug 25, 2017 1:36 pm
So has anyone actually gotten ZM to run properly on FreeBSD in it entirety? Reason I ask is I have been able to get it running and doing what it needs to do up until the API. I cannot get the API's to work at all for external controls. There is a very long time frame from original post to now and was wondering where it actually stood. The package install does do most of the work for you to get it running. There is a simple fix for the camera displaying the actual camera name not just N on the "Timestamp Label Format", Add %%N instead of %N simple fixes like that. There are a lot of little things that have to go down to get it working and I have wonderful notes on all of it. I want to move it off of a dedicated server running Linux into a jail on FreeBSD so I have less to maintain but right now I just cant get it to do what it needs to do properly. It throws a LOT of errors all the time as well unlike Linux. Atleast in a jail you just kill it and create a new one if it breaks. Beats reinstalling the OS on a dedicated server.
%%N was not a perfect solution.
The good news is the issue with % character in the timestamp on *BSD systems has been addressed:
https://github.com/ZoneMinder/ZoneMinder/issues/1865
https://github.com/ZoneMinder/ZoneMinder/pull/1972

If the zoneminder api is not working, make sure php apcu module is installed. The package goes by different names like apcu, apcu-bc, or pecl-apcu-bc, etc depending on what version of php and what operating system you are on.

This user reported success:
viewtopic.php?f=36&t=26131&p=100361&hil ... cu#p100361

But then I heard from another user that this only works with php5, not php7. So I'm not entirely sure where we stand on this.

In my opinion, the best people to ask questions regarding ZoneMinder on FreeBSD are @schrorg @abishai (see the github issues above) as they have been at the front of diagnosing and fixing issues specific to FreeBSD.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Baylink
Posts: 284
Joined: Sun Jun 19, 2005 3:19 am

Re: ZM on FreeBSD

Post by Baylink » Fri Aug 25, 2017 3:19 pm

Did you expect those @'s to tag the users?

Cause that appears to be turned off -- at least, there's no visible indication it was an alerting tag...

User avatar
knnniggett
Posts: 1994
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: ZM on FreeBSD

Post by knnniggett » Fri Aug 25, 2017 5:17 pm

Baylink wrote:
Fri Aug 25, 2017 3:19 pm
Did you expect those @'s to tag the users?

Cause that appears to be turned off -- at least, there's no visible indication it was an alerting tag...
No, I did not. The "@" is a github notation.
That's why I referred the reader to the relevant github issues.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Baylink
Posts: 284
Joined: Sun Jun 19, 2005 3:19 am

Re: ZM on FreeBSD

Post by Baylink » Fri Aug 25, 2017 5:21 pm

Well, it's user tagging notation lots of places...

And since "Report Post" is still 404, I thought it might be something expected to tag a user, and which wasn't working.

da7
Posts: 4
Joined: Sun Nov 26, 2017 3:07 pm

Re: ZM on FreeBSD

Post by da7 » Tue Dec 12, 2017 1:55 pm

I used this these instructions to install ZM:
https://drive.google.com/file/d/0B6clHa ... hvcjQ/view

ONVIF probe do not work.

Code: Select all

Unable to probe network cameras, status is '255'. Output was:

No results from GetCapabilities: SOAP-ENV:ServerError deserializing message:
unbound prefix at line 2, column 2969, byte 3008 at /usr/local/lib/perl5/site_perl/SOAP/WSDL/Expat/Base.pm line 79.
at line 2 at /usr/local/lib/perl5/site_perl/SOAP/WSDL/Expat/Base.pm line 82.
What could be wrong?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests