Page 1 of 1

How to install live CD to hard drive

Posted: Thu May 13, 2010 2:53 am
by fishface

Can't figure out what is happening, but I get a blank screen after running the liveCD. I wish to install the LiveCD to the hard drive.

This is what happens.

1) I get to a screen which has the following options

Default: no swap, no copy-to-ram
larch copy-to-ran (also activates swap)
larch with swap
Memory tester

I select the first one 'Default no swap, no copy-to-ram'

2) It then starts to load

3) All the services start-up '[busy]' [done]' etc etc
4) When they have finished it then auto logs on the zm_user
5) It is at this point I have a blank screen and my monitor says it cannot display the video.
6) I can connect via web browsers and webcams work

Because I cannot access the system via shell I cannot do much.

It seems likely it is a simple setting to change the resolution as when I ctrl+alt+del the machine then starts the shutdown process and the display comes back into life, I can see all the various service being stopped.

The machine is more or less Ok, I just can't see any thing :cry: [/list]

Posted: Thu May 13, 2010 4:36 am
by cordel
You can get to a shell by pressing { [ctrl] + [Alt] + [F1] }
To return to the GUI { [ctrl] + [Alt] + [F7] }

From the shell or at the boot options, you can set a usable screen size.

Posted: Thu May 13, 2010 4:24 pm
by fishface

Using { [ctrl] + [Alt] + [F1] } produced a screen what looks like to be a load of errors, and flashing cursor which I couldn't do much with. Cannot remember the details, but one of the errors stated that it couldn't set the time on the hardware clock.

I then tried vga=791 as a boot option and that has worked, I can at least use see and use the shell, but it produce the following errors (I'm guessing, but I think it needs drivers or something for the ATI Mach 64 graphics card)

'failed to load module mach64 (module does not exist)
Fatal server error cannot run in framebuffer mode, please specify busIDs
please check log file at /var/log/Xorg.0

xinit. no such file or directory, unable to connect to x server

I'll try a work my through the errors.

Posted: Sun Oct 03, 2010 4:23 pm
by gerfry
cordel wrote:You can get to a shell by pressing { [ctrl] + [Alt] + [F1] }
To return to the GUI { [ctrl] + [Alt] + [F7] }

From the shell or at the boot options, you can set a usable screen size.
thanks cordel for the info

I have a similar problem - perhaps anyone an idea for me please?
when starting live larch cd, x crashes (no wonder due to different cards...) so you get the shell on a plate. there it says (again no wonder, larch helps) check the xserver config and fill the config file "/etc/X11/xorg.conf" from "hwd -x". to do that I need the root password, which I don't have...

Anyone a helping hand? (reread the download thread of the 1.24.2-1 larch live cd brought me to the point "start webbrowser where you get all info about users, phpmyadmin and so on; but without x no browser :()

without root pw the system is really hard to admin :/

thanks to any post/pm

greets fry

:: btw: zm as virtual machine is top!

Posted: Sun Oct 03, 2010 5:41 pm
by bb99

Posted: Sun Oct 03, 2010 6:06 pm
by gerfry
thanks, works so far, but...

the hwd -x produces nice files, using the cirrus it crashes again - using vesa I end up in darkness (probably shell) not seeing what I type ... anyone same issue / good idea to fix xorg.conf?

I just want to get the larch on hd - is there any shell-script on the livecd?

greets and thanks for any help!!!


btw: installing in xen3 virtual machine environment... but never experienced that before