ZMlarch/ZMLinuxOS_2008.7 not installing on HP Proliant Smar

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
Post Reply
Posts: 12
Joined: Sun May 09, 2010 1:41 am

ZMlarch/ZMLinuxOS_2008.7 not installing on HP Proliant Smar

Post by fishface » Sun May 09, 2010 1:56 am


Complete newb at this so I'm likely to being something stupid.

I have HP Proliant DL380 which I have tried without success to install ZMlarch, ZMLinuxOS_2008.7, Bluecherry etc, all with the same issue.

I can run the the liveCD without issue, web interface works, webcam the lot, but I do not know how to install the liveCD to the hard disk.

On booting the live CD if I try any other option other than the default (which works as I stated above) I can't even get the live versions to work. I see no way of getting to a prompt as the screen goes blank, so how do I install it to the disk?

The common theme here seems to be (after searching a bit) that it doesn't support the HP Smart Array 5i out-of-the-box so to speak.

I tried the ZMLinuxOS_2008.7 version, clicked on the desktop icon to install to disk and it cannot see the disk array.

The only way I've had some success is to install Unbuntu 9.04 and then use the Synaptic package manger to install Zoneminder, I was really hoping to use one the pre-configured distros though.

Posts: 12
Joined: Sun May 09, 2010 1:41 am

Post by fishface » Tue May 11, 2010 12:40 am

Ok, I've found a bit more out.

Using an Ubuntu 9.4 livecd, the only way I can get it to load is to disable apic, it then runs the live version and I can install to disk if I wish, however it then only recognizes a single CPU, most likely because apic has been disabled, but the system is unstable. I also have issue with the cciss working correctly, which AFAIK has been around for ages in the kernel.

Same things happens with Debian, and as I said, all the other 'ZM' live cd's, which seem to be based on the same installer.

I next tried Centos LiveCD, and this installed without a single glitch and loads the apic module/driver upon install (you see 'APIC installed [OK] - whiz pass)' and low and behold, I have 2 CPU registerered.

OpenSuSe10.3 and SLES11 both work as well, but SuSE looks like a real PITA to configure ZM.

I have no idea why this should be.

So, I most likely gonna use either CentOS or Fedora11 for ZM.

Posts: 46
Joined: Wed Mar 24, 2010 1:46 pm

Post by MarcoP » Tue May 11, 2010 11:26 pm

First of all, what generation of DL380 are you using?

By using SmartStart CD you can deploy the server installing a "linux" OS,
step by step wizard.

Did you tried using the array controller drivers from HP site ... ?

Posts: 12
Joined: Sun May 09, 2010 1:41 am

Post by fishface » Wed May 12, 2010 10:12 pm

It's a DL380 G3 2 x Xeon 2.8GHz with Smart Array 5i plus, 2GB mem.

I bought it second hand so do not have the SmartStart CD.

I haven't tried the drivers, I looked on the HP site and didn't see Debian listed, and to be honest got rather confused about all of the product names - I will look again and see if I can figure out the basic I need.

It's currently running fine on Debian 5.04 and have Zoneminder 1.24. 2up and running, all working except for one small thing, it doesn't recognize my USB webcam, this webcan works fine from the ZMLive CD, which I was going to start a new topic for this issue.

The webcam shows up as OmniVision Technologies, but I have no video device in /dev/video (zmu -d /dev/video0 -q -v comes up with nothing)

User avatar
Posts: 1112
Joined: Mon Mar 26, 2007 6:07 am
Location: Las Vegas, Nevada

Post by kingofkya » Thu May 13, 2010 7:24 am

i believe its modprobe ov18 or some thing i dont remember exactly hit tab after ov to see options

Posts: 12
Joined: Sun May 09, 2010 1:41 am

Post by fishface » Thu May 13, 2010 6:29 pm

FTR, I did run the HP SmartStart CD (v8.20 is the highest version you can use on the GL380 G3, you will get "CPU does not support long mode" see ... Id=1385476)

It passed all tests, and other than the diagnostic most of the other array features I configured via the RAID BIOS.

I can also confirm the server and RAID card have the most up-to-date firmware.

I'm not having much success.


1) LiveCD boots and runs, web interface fine, USB camera works perfectly
2) I cannot install the LiveCD to the hard disk - see
3) I've had the most success by installing Debian, and then manually installing and configuring ZM, it all worked except now the USB webcam does not work! :x

Posts: 46
Joined: Wed Mar 24, 2010 1:46 pm

Post by MarcoP » Fri May 14, 2010 1:19 am

kingofkya wrote:i believe its modprobe ov18
if I'm not mistaken it should be modprobe cciss

@fishface: great to hear that array controller drivers are up-to-date. Is the ROM up-to-date too?

However try ... AID_or_LVM

As far I remember Arch Linux's setup supports only /dev/sd*, /dev/hd* and some software RAID or device mapper configurations. May be different now.

Posts: 12
Joined: Sun May 09, 2010 1:41 am

Post by fishface » Fri May 14, 2010 2:33 am

Yep, everything is up-to-date, the RAID works fine under Debian and the Fedora 12 Live CD installed using the 'Install to hard drive' desktop icon, however, the Fedora 11 Live CD Install to hard drive' desktop icon, did nothing, you click on and nothing happens at all.

I'm confident the RAID array is functioning as it should, I have re-installed Debian and it works fine, except I cannot get the webcam to work.

I've more or less given up getting the ZMlarch live cd to install, I also get other odd errors, saying it cannot set the hardware clock, Debian and Fedora12 have no problem setting it!

I have found out a bit more about the camera.

When looking at various message and logs from the ZMlarch live (remember this works fine for me, webcams and everything, I just cannot install it to disk) it finds the following.

OV519 OV7648 - believe this is the camera type

Also, when using hwinfo --usb it can 'see' the camera

However, running 'Cheese' or Camorama produces no picture

I really want to get this to work and I'm tearing my hair out!

hwinfo --usb output

05: USB 00.2: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_5a9_8519_noserial_if2
Unique ID: yqzE.YXTkeOEDqMC
Parent ID: k4bc.4SMt+yGoEp4
SysFS ID: /devices/pci0000:00/0000:00:0f.2/usb1/1-3/1-3:1.2
SysFS BusID: 1-3:1.2
Hardware Class: unknown
Model: "OmniVision USB Camera"
Hotplug: USB
Vendor: usb 0x05a9 "OmniVision Technologies, Inc."
Device: usb 0x8519 "USB Camera"
Revision: "1.00"
Driver: "snd-usb-audio"
Driver Modules: "snd_usb_audio"
Speed: 12 Mbps
Module Alias: "usb:v05A9p8519d0100dc00dsc00dp00ic01isc02ip00"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #8 (Hub)

df -h output (I wanted this partioning layout - it a testbed at the moment)

Filesystem Size Used Avail Use% Mounted on
/dev/cciss/c0d0p3 4.9G 2.4G 2.6G 49% /
tmpfs 506M 0 506M 0% /lib/init/rw
udev 10M 716K 9.4M 7% /dev
tmpfs 506M 0 506M 0% /dev/shm
/dev/cciss/c0d0p1 122M 29M 87M 25% /boot
/dev/cciss/c0d1p1 34G 4.2M 34G 1% /data1
/dev/cciss/c0d0p7 723M 5.3M 718M 1% /home
/dev/cciss/c0d0p6 496M 4.3M 492M 1% /tmp
/dev/cciss/c0d0p2 9.8G 758M 9.1G 8% /var

Posts: 46
Joined: Wed Mar 24, 2010 1:46 pm

Post by MarcoP » Fri May 14, 2010 3:46 am

Its getting a bit confusing now. I was trying to help on getting ZM Arch work with your hardware, but kingofkya was helping with Debian and cam issue (yeah I now understand why modprobe ov18).

As far I concern I'll suggest you to stick with what you got so far and just try to get the cam working.

btw got no clue about multimedia things ... I'll pass this one.

Posts: 12
Joined: Sun May 09, 2010 1:41 am

Post by fishface » Fri May 14, 2010 4:05 am

MarcoP - I apologize for confusing you and the thread creep.

I basically have given up try to get ZMlarch Live to work and have been trying other distro's.

I will take your advice and stick to one thing now.

So, I have Debian 5.04 up and running, with ZM 1.24.2, web interface all working fine - but no video from the webcam. I will read the sticky thread about probing cameras, maybe that will help, but it seems to mostly deal with IP cameras not USB.

The fundamental issues is that the device is not listed in /dev/

Posts: 46
Joined: Wed Mar 24, 2010 1:46 pm

Post by MarcoP » Fri May 14, 2010 7:34 am

The original OV51x drivers did not provide support JPEG decompression.

You can try:

- Use MPEG compression instead of JPEG within ZM
- Try a patched version that provide JPEG decompression (no support anymore)
- Try the experimental 2.32 version from the original author website.

Again, I know nothing about multimedia so I'm just guessing here.

Some more infos here and here

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests